scrollbars #4 overflow:scroll for iframe has no effect

RESOLVED DUPLICATE of bug 93905

Status

()

RESOLVED DUPLICATE of bug 93905
17 years ago
5 years ago

People

(Reporter: rvj, Assigned: hyatt)

Tracking

Trunk
Future
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Assuming overflow:scroll is meant to allow the display of widget scrollbars 
irrespective of content depth, then overflow:scroll has no effect for iframe 
widget (unlike tree).

Have attached a simple test case but it appears that there is a need to treat 
the iframe widget like any other widget i.e.  allow background to be styled, 
allow 'static' scrollbars, etc
(Reporter)

Comment 1

17 years ago
Created attachment 56392 [details]
overflow:scroll test case for iframe
(Reporter)

Comment 2

17 years ago
Although overflow:scroll is a css spec property , its not clear whether it 
should apply to the outer scrollbars of the iframe element.

I assume it should , but if then please mark this bug as invalid

Updated

17 years ago
Attachment #56392 - Attachment mime type: text/plain → application/vnd.mozilla.xul+xml

Updated

17 years ago
Target Milestone: --- → Future
(Reporter)

Comment 3

17 years ago
Created attachment 61424 [details]
testcase for overflow:scroll bugs

Comment 4

17 years ago
confirm, attachment 61424 [details] (2nd on list) crashes mozilla 2002030309 (Win, 0.9.9).
(BE WARNED!  ... I was not ready to have mozilla crash)
worksforme, linux trunk build 2002-04-20-07.  First testcase shows a light green
background and scrollbars; second testcase has scrollbars and does not crash.

Please reopen if you're still seeing the problem with a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
Ive tried with candidate release 1 but overflow:scroll does not seem to have 
the behavior I expect

I understand overflow:scroll should always show BOTH scrollbars. This avoids 
the scrollbars apearing and disappearing irrespective of whether the content 
fills the window.

e.g. if you set the src to www.mozilla.org, the horizontal scrollbar is NOT 
displayed - when I understand it should be 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

17 years ago
PS Additionally the tree widget  in the second test displays double vertical
scrollbars.   (Window 98)


The auto logic for suppressing duplicate scrollbars when overflow:scroll option
is specified seems missing  (this has been reported as a separte bug but I
suspect it applies to all widgets support overflow:scroll style)
 
rc1 is not a current build...  I suspect jst's iframe rewrite fixed this, and
that did not land on branch.  Please retest with a recent trunk build.

Comment 9

17 years ago
No response ->WFM. Reporter please re-open if you still see the problem
on a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

16 years ago
Ive retested using Mozilla 1.0 under Windows 98 and only get a single vertical 
scrollbar.

As far as I understand, overflow:scroll should display both scrollbars 
irrepective of whether the content exceeds the inner width or height

I would expect the test case should display a horizontal scroll bar but no 
thumb because it does not exceed the innerwidth.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
This is a duplicate. We simply do not implement overflow:scroll on iframes/frames.
Whiteboard: DUPEME
(Reporter)

Comment 12

16 years ago
OK 

but its a bit suprising that it has been implimented for tree which does not 
even support horizontal scrolling  ......


... seems a bit inconsistant ?
(Reporter)

Comment 13

16 years ago
BTW what bug was this a duplicate of ?

Comment 14

16 years ago

*** This bug has been marked as a duplicate of 93905 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.