copy->paste broken in Mail/News

VERIFIED DUPLICATE of bug 107635

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 107635
16 years ago
13 years ago

People

(Reporter: [not reading bugmail], Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I was reading a news:thread message that had a url in the body.  I selected it
and hit copy, I then switched to a browser window and right-clicked on the
Location Bar and Paste is not an option.  so copy is not copying any text in
message display windows. didn't check other areas for copy paste issues.
(Reporter)

Comment 1

16 years ago
not sure what correct component this Mail/News window message display
(right-click) options falls under.
Component: Browser-General → Mail Window Front End
Product: Browser → MailNews
(Reporter)

Comment 2

16 years ago
see bug 79880 per Ben Bucksch. n.p.m.mailnews

Comment 3

16 years ago
Reassign
Assignee: asa → sspitzer
QA Contact: doronr → esther

Comment 4

16 years ago
I confirm this bug as I've been seing this problem for months (WindowsME). Bug
79880 is Linux only. I believe they may be the same problem. If you dup this
against 79880, please change that bug's Platform/OS to All/All. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
maybe related: bug 102561
(Reporter)

Comment 6

16 years ago
I was using 3 pane message windows.  Again no text is copied to clipboard from
the context menu's copy command after selection.
(Reporter)

Comment 7

16 years ago
I had just selected a www.anyurlhere.com text.. it was not at all a hyperlink..
then as I stated, selected copy on the context menu.
(Reporter)

Comment 8

16 years ago
Spam: Just a thought about why these dont work:

maybe they are related to the editor's context-menu is not currently implemented
and this is a part of that, a partial implementation.  
(Reporter)

Comment 9

16 years ago
see similar problem bug 108084 with composer.
(Reporter)

Comment 10

16 years ago
also see bug 103064

Comment 11

16 years ago
Isn't this a dupe of bug 107635 ? (if reproducible only when context menu is used)

Comment 12

16 years ago
I see this problem recurrently with both context menu paste and Edit -> Paste.

Comment 13

16 years ago
Jacek, I was talking about the context menu Copy command. Reporter said "no text
is copied to clipboard from the context menu's copy command". If you use context
menu Copy and :
- you are not able to paste anything on another Moz window or an external app
(like Notepad)
- or you paste a string copied with previous succesful copy command
- ctrl+c then Paste works for the same text selection,

then this is definitely a dupe of bug 107635

Comment 14

16 years ago
Dimitros: Possibly this is really what the reporter meant. But I believe there
is another problem with paste not working. You can paste into another
application but not into Mozilla. From the reporter's comment I'm not sure which
it is.
(Reporter)

Comment 15

16 years ago
This is also a problem with the Javascript Console's Context Menu's Copy. 
Sometimes its' Edit->Copy will work and the Ctrl-C, but not the Context Menu.

Jacek, 

about comment #13, That is what I'm talking about and definetely the problem
here in this bug report.. Also I tried just copying to the basic Notepad, but it
appears the Context Copy is not copying anything to paste at all.

see comment http://bugzilla.mozilla.org/show_bug.cgi?id=107635#c12

so Seth, as Dimitrious #12 comment, I think this is a dup of bug 107635.
(Reporter)

Updated

16 years ago
Depends on: 103064
(Reporter)

Comment 16

16 years ago
Spam: lets try this line bug 107635#comment 12

Without the Ctrl-E comments.
(Reporter)

Comment 17

16 years ago
there has to be a meta-tracking bug for Mail/News Context Menu bugs, because bug
103064 only talks about adding new context menu items for images.. not fixing
Edit context menu items.  Going to do a search.. and then maybe have to change
several bug's dependencies. :0
(Reporter)

Comment 18

16 years ago

*** This bug has been marked as a duplicate of 107635 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 20

16 years ago
this bug I'd like to say that you cannot use 'context' menu copy, but copy link
address for copying links, and copy for text.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.