percentage padding on header elements is ignored

RESOLVED DUPLICATE of bug 30802

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 30802
17 years ago
16 years ago

People

(Reporter: Anand Kumria, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101202


I've tried to reproduce the layout of the mozilla.org frontpage but using CSS
rather than tables. Part of my style sheet turns newsitem headers into h3
elements and applies a percentage padding to them.

Please see the attached screen shot, html and css which illustrates the problem.

Reproducible: Always
Steps to Reproduce:
1. simply view the html / css together
2.
3.

Actual Results:  The heading element <h3> is on the left

Expected Results:  The heading element <h3> should line up with and be padded
the same as other elements in green boxes
(Reporter)

Comment 1

17 years ago
Created attachment 56407 [details]
source HTML for my version of mozilla.org
(Reporter)

Comment 2

17 years ago
Created attachment 56408 [details]
associated style-sheet for mozilla.org
(Reporter)

Comment 3

17 years ago
Created attachment 56409 [details]
screen-shot of problem with CSS header padding
(Reporter)

Comment 4

17 years ago
Add endico@mozilla.org; perhaps the changes in the style-sheet and source html
may be useful.
Looks like a table problem to me (see testcase).  Note that using padding in em
would make more sense in the situation on the site than using percentage padding....

Still, something odd is going on with the calculation of percentage padding here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

16 years ago
This is at least related to tables.  The problem is that the table thinks it can
get away with only one pass of reflow whereas it really needs the second pass.



*** This bug has been marked as a duplicate of 30802 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.