Closed Bug 1083559 Opened 7 years ago Closed 6 years ago

Running x64 nightly builds while using a clean profile locks up firefox

Categories

(Firefox :: General, defect)

36 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mjthompson711, Unassigned)

Details

(Keywords: 64bit, regression)

Attachments

(2 files)

Attached file Bugzilla.rtf
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141015114030

Steps to reproduce:

Downloaded the latest zipped build of x64 firefox nightly for Windows.


Actual results:

Very soon after launching the browser, the whole PC becomes unresponsive and I am forced to perform a hard reset of Windows. This happens with a clean profile.


Expected results:

The browser should work normally. I am attaching my about:support information, which also contains a brief description of my PC and a copy of my MSINFO32 summary.
More information... It seems with a clean profile the browser doesn't lock up the entire PC. It only locks up firefox. If I disable OMTC, the browser runs normally. If I enable e10s with OMTC off, my PC locks up instantly.
Michael
Hardware: x86 → x86_64
Summary: Running x64 nightly builds while using a clean profile crashes my PC → Running x64 nightly builds while using a clean profile locks up firefox
Type about:support and paste the graphics section.
I confirmed.

Windows8.1 64bit is bad, Windows7 Pro is good.

Steps to reproduce:
1.download "firefox-36.0a1.en-US.win64-x86_64.installer.exe" and install.
2.confirm boot nightly(first profile).
3.exit nightly.
4.run "firefox -p", make new profile named "test".

Actual results:
not boot nightly.(display on task manager)

Expected results:
boot nightly.
Marking as New based on comment #3.
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Keywords: 64bit
Am I right in thinking the 2014-10-15 nightly works and the 10-16 nightly is broken for you?
Flags: needinfo?(mjthompson711)
None of the 64-bit builds work until I disable OMTC. The browser will launch and just freeze and become unresponsive. After I disable OMTC the browser works as expected. If I enable e10s AFTER disabling OMTC, the whole PC freezes and has to be reset by holding in the power button.
Flags: needinfo?(mjthompson711)
I reconfirm this bugs.

My notebook is Acer Aspire V5-171-F58D(Intel Core i5-3317U, 8GiB RAM, Intel HD Graphics 4000, Windows8.1).

GOOD:
Download "firefox-35.0a1.en-US.win64-x86_64.installer.exe"
 on http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-10-01-03-02-05-mozilla-central/
about:buildconfig is https://hg.mozilla.org/mozilla-central/rev/14665b1de5ee

BAD:
download:"firefox-35.0a1.en-US.win64-x86_64.installer.exe"
 on http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-10-02-03-02-02-mozilla-central/
about:buildconfig is https://hg.mozilla.org/mozilla-central/rev/2399d1ae89e9

(clean uninstall step is follow.)
1.uninstall Nightly and Mozilla Maintenance Service on Control panel.
2.remove directory.
  (1)C:\ProgramData\Mozilla
  (2)C:\Users\username\AppData\Local\Mozilla
  (3)C:\Users\username\AppData\Roaming\Mozilla
3.install nightly.

attached about:support.

Thanks.
Things working better these days? Lots of changes to the OMTC/Graphics pipeline since this bug was filed last year.
Flags: needinfo?(mjthompson711)
I am no longer having the issue
Thanks guys!
Michael T
Flags: needinfo?(mjthompson711)
Thanks for the quick reply!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.