Closed Bug 1083653 Opened 5 years ago Closed 4 years ago

Intermittent marStageSuccessPartialSvc.js | test failed (with xpcshell return code: 0), see following log:

Categories

(Toolkit :: Application Update, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox37 --- wontfix
firefox38 --- fixed
firefox39 --- fixed
firefox40 --- fixed
firefox-esr31 --- unaffected
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: cbook, Assigned: rstrong)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Windows XP 32-bit fx-team debug test xpcshell

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=916656&repo=fx-team

19:08:03 WARNING - TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\xpcshell\tests\toolkit\mozapps\update\tests\unit_service_updater\marStageSuccessPartialSvc.js | test failed (with xpcshell return code: 0), see following log:
An example (first 3 lines are not checked by the tests since they have paths) from a complete update on my system. I am very certain that the following call to LOG is the cause
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/updater/updater.cpp#2060

PATCH DIRECTORY <path to updates dir?\updates\0
INSTALLATION DIRECTORY <path to install dir>\Mozilla Firefox Beta
WORKING DIRECTORY <path to install dir>\Mozilla Firefox Beta
calling QuitProgressUI
EPARE REMOVEFILE xul.dll
PREPARE REMOVEFILE wow_helper.exe
etc...
succeeded
calling QuitProgressUI

Instead of trying to rework the logging I am just going to remove this one call to LOG.
Attached patch patch rev1Splinter Review
Pushed to try
https://treeherder.mozilla.org/#/jobs?repo=try&revision=52d02c0fbb43
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
This should also fix bug 1109219
Blocks: 1109219
Attachment #8588269 - Flags: review?(spohl.mozilla.bugs)
Comment on attachment 8588269 [details] [diff] [review]
patch rev1

Review of attachment 8588269 [details] [diff] [review]:
-----------------------------------------------------------------

Happy to try this. Do you know why a call to LOG would cause this?
Attachment #8588269 - Flags: review?(spohl.mozilla.bugs) → review+
There are 2 processes... one that is unelevated that starts the service and another that is launched elevated by the service. This is the unelevated one writing to the log file.
Makes sense, thanks!
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/51bdbe58fc2d
Flags: in-testsuite+
Target Milestone: --- → mozilla40
https://hg.mozilla.org/mozilla-central/rev/51bdbe58fc2d
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.