Thunderbird crash via descructor/nsLDAPConnection::~nsLDAPConnection when getLDAPAttributes in autoconfig

RESOLVED DUPLICATE of bug 1064230

Status

MailNews Core
LDAP Integration
--
critical
RESOLVED DUPLICATE of bug 1064230
4 years ago
3 years ago

People

(Reporter: Sewera, Unassigned)

Tracking

({crash, regression})

x86_64
Windows 7
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; MALC; rv:11.0) like Gecko

Steps to reproduce:

Took a Thunderbird 31-33 install on Windows XP and add getLDAPAttributes(host, base, filter, attribs) to autoconfig. Same config on TB 24 works great. Also TB 31 on Windows 7 and linux works.


Actual results:

Thunderbird crashed when starts

Comment 1

4 years ago
Do you get a crash ID?
see https://support.mozillamessaging.com/en-US/kb/mozilla-crash-reporter#w_viewing-crash-reports
Severity: normal → critical
Flags: needinfo?(mozilla)
Keywords: crash
(Reporter)

Updated

4 years ago
Crash Signature: fd0396e3-c37c-483e-a56c-b4184ddda510
Flags: needinfo?(mozilla)
(Reporter)

Comment 2

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> Do you get a crash ID?
> see
> https://support.mozillamessaging.com/en-US/kb/mozilla-crash-
> reporter#w_viewing-crash-reports

fd0396e3-c37c-483e-a56c-b4184ddda510
(In reply to Wayne Mery (:wsmwk) from comment #1)
> Do you get a crash ID?
> see
> https://support.mozillamessaging.com/en-US/kb/mozilla-crash-
> reporter#w_viewing-crash-reports

Comment 3

4 years ago
> fd0396e3-c37c-483e-a56c-b4184ddda510

This is an unsubmitted crash. You need to visit Help | Troubleshooting and click on on fd0396e3-c37c-483e-a56c-b4184ddda510 to get the to submit. That will then change to your crash ID.  And the crash signature will be shown in the crash-stats page.
Crash Signature: fd0396e3-c37c-483e-a56c-b4184ddda510
Flags: needinfo?(mozilla)
(Reporter)

Updated

4 years ago
Crash Signature: bp-72c4dde0-194a-444e-b0b0-e2e962141020
Flags: needinfo?(mozilla)

Comment 5

4 years ago
Does this also crash when using version 31.3.0?

(In reply to Sewera from comment #4)
> bp-72c4dde0-194a-444e-b0b0-e2e962141020  Version 	31.1.2

 0 	xul.dll	nsObserverService::RemoveObserver(nsIObserver*, char const*)	xpcom/ds/nsObserverService.cpp
1 	xul.dll	nsLDAPConnection::~nsLDAPConnection()	ldap/xpcom/src/nsLDAPConnection.cpp
2 	xul.dll	nsLDAPConnection::`scalar deleting destructor'(unsigned int)	
3 	xul.dll	nsLDAPConnection::Release()	mailnews/base/src/nsMsgStatusFeedback.cpp
4 	xul.dll	nsLDAPConnectionRunnable::~nsLDAPConnectionRunnable()	ldap/xpcom/src/nsLDAPConnection.cpp 
5 	xul.dll	nsLDAPConnectionRunnable::`vector deleting destructor'(unsigned int)
Status: UNCONFIRMED → NEW
Crash Signature: bp-72c4dde0-194a-444e-b0b0-e2e962141020 → [@ nsObserverService::RemoveObserver(nsIObserver*, char const*) ]
Component: Preferences → LDAP Integration
Ever confirmed: true
Flags: needinfo?(mozilla)
Keywords: regression, regressionwindow-wanted
Product: Thunderbird → MailNews Core
Summary: Thunderbird crash when getLDAPAttributes in autoconfig → Thunderbird crash via descructor/nsLDAPConnection::~nsLDAPConnection when getLDAPAttributes in autoconfig
Whiteboard: [regression:TB2?]

Comment 6

4 years ago
FWIW, every crash with this signature has ldap on stack.
~50% are startup

Comment 7

4 years ago
This is also reported as bug 1064230
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mozilla)
Resolution: --- → DUPLICATE
Whiteboard: [regression:TB2?]
Duplicate of bug: 1064230
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.