Navigation Toolbar control disappear from both View->Toolbars and toolbars context menu

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: tmp1, Unassigned)

Tracking

31 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8506040 [details]
menu screenshot

User Agent: Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20141011074935

Steps to reproduce:

Select menu View->Toolbars,
or right click on Navigation toolbar.



Actual results:

Submenu appears which allow to disable Menu and Bookmarks toolbars, but not Navigation toolbar.


Expected results:

Item to disable Navigation toolbar should also appear.
(Reporter)

Comment 1

4 years ago
This happened after update to version 31.2.0 (esr).
(Reporter)

Updated

4 years ago
Component: Untriaged → Toolbars and Customization

Comment 2

4 years ago
Created attachment 8506060 [details]
menubar.jpg

It's by design, natively, you can only enable or disable the Menu Bar and the Bookmarks Toolbar. Extra bars may be present if you install some add-ons or plugins in Firefox.
(Reporter)

Comment 3

4 years ago
Any link/explanation to what caused to introduce this decision in version 31?
Thanks.

Comment 4

4 years ago
This is cause by bug 870545.
(Reporter)

Comment 5

4 years ago
Please reintroduce the capability to disable Navigation bar.
This can be desirable for web developers, for kiosks, or just for minimalistic minded people.
Navbar is useless when vim-like extensions are installed.
Also, it seems just strange to break working features which didn't cause problem.
(In reply to tmp1 from comment #5)
> Please reintroduce the capability to disable Navigation bar.
> This can be desirable for web developers, for kiosks, or just for
> minimalistic minded people.

Fullscreen mode exists for that purpose.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.