POP3 username: mozilla changes my user name incorrectly

RESOLVED WORKSFORME

Status

P1
major
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: afucs, Assigned: cavin)

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011101
BuildID:    2001110101

Hi,

I´m using one of those stupid POp3 server who shares several virtual domains, so
my user name is my real email address: "xxxx@miaubrinquedos.com.br"

When setting up a POP3 account using the Mail & Newsgroup Account Settings,
Mozilla "fixes" the "xxxx@miaubrinquedos.com.br" to "xxxx".

It´s wierdo because I´m not getting the same results in Netscape 6.2 ... well in
fact it even prohibits me from changing the "User name".



Reproducible: Always
Steps to Reproduce:
1.Create a mail account with username like "xxxx@domain.com"
2.change to a different account setup page
3.the username will be "fixed" to "xxxx" instead of "xxxx@domain.com"

Actual Results:  mozilla reported that server answered with wrong password.

Expected Results:  log me in? :-)

Comment 1

17 years ago
this is bug 53970 / bug 14295 .. i thought these were fixed.

Reporter: If you exit mozilla completely (including eventual turbomode)
and then edit prefs.js to include this line:

user_pref("mail.allow_at_sign_in_user_name", true); 

Can you get messages then?

(Reporter)

Comment 2

17 years ago
sorry for the delay. I tried with no sucess. It keeps changing my correct 
username at the account setting tab
(Reporter)

Comment 3

17 years ago
I have changed to the

Mozilla 0.9.6
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120

sucess but it seems we have a new problem... in this release, mozilla freezes 
when I change the account name. I have to change it on the prefs.js by hand.

Comment 4

17 years ago
It can be linked to BUG # 101513 
The manually change of prefs.js is not 100% working, in fact i is not working. 
Fully described in that BUG. I can repeat some new tests if needed. 

I did test it Release 0.9.6, 0.9.6+ 2001112009 and also some older versions of
0.9.5+ and 0.9.6 pre releases. (Win98SE) 

Shortly, the manually change of username in prefs.js causes that mozilla cannot
see the folders (including sent folder and all folders created by user).

Comment 5

17 years ago
I am a former Earthlink customer. (Dropped them to go with broadband.) 
IIRC, Earthlink has moved to a similar system for their POP3 access. The proper 
POP3 username there was   accountname@earthlink.net    .  Maybe this bug can be 
confirmed by someone who knows more than I do.

I'm changing the summary line. 

Old: mozilla changes my user name incorrectly
New: POP3 username: mozilla changes my user name incorrectly
Summary: mozilla changes my user name incorrectly → POP3 username: mozilla changes my user name incorrectly

Comment 6

17 years ago
Reporter,
I created a new profile using 2001-12-18-06 build on win98. While I was 
creating this mail account I did specify my username with xxx@gmx.co.uk in the 
account wizard. I was able to log in.  I checked in server settings and the 
username was set correctly. I did not have to change pref.js file 
Can you try a latest build? 

Comment 7

17 years ago
I made new test on 2001121803 under Win98

I have test e-mail account mozilla@poczta.fm
both the SMTP and POP3 servers are poczta.fm

I did set the account and as pop3 username set the mozill string
than i did edit the username to correct one 'mozilla'
the alert about changing username appeard and after mozilla hangs and was not
responding

Than i remove the account
set same but set as username the mozillaa string
edit the username once again to correct string 'mozilla'

All is working now!!!!!

So the changing USERNAME is POSSIBLE if new POP3 username is shorter than the
PREVIOUS one!!!!

maby it can help with tracking the bug!

Comment 8

17 years ago
Is this about editing username and server name in account manager? I know
xxx@yyy.com works. 

Comment 9

17 years ago
over to cavin, because i see this line

So the changing USERNAME is POSSIBLE if new POP3 username is shorter than the
PREVIOUS one!!!!

Assignee: naving → cavin

Comment 10

17 years ago
changing the status based on navin's comments
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 11

17 years ago
The name change bug is fixed by bug 113590 (on 01/02/2002).  Sheela can you
verify it again (as I could not get it to fail using 01/17/02 build)?

Comment 12

17 years ago
I used 2002-01-22-06 build on mac 9.1 and I was not able to reproduce this
problem. I also tested following the steps in bug 113590. Changing the user name
does not cause application to crash or hang.
Checked it on mac os x using 2002-01-18-06 build and could not reproduce the
problem.
worksforme. 
(Assignee)

Comment 13

17 years ago
Andre, when you get a chacne can you try the latest build and see if the 
problems you mentioned in the bug are gone now? Thanks.

Comment 14

17 years ago
Is this bug a duplicate of bug 65649 (or vice versa)?
(Assignee)

Comment 15

17 years ago
Moving to moizlla1.0.
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 16

17 years ago
Note the originally stated bug is fixed. We don't change the user name when it
has an @ in the name.  We also allow for the user to edit the username field. 
And, I am not seeing the hang reported on 1-23 by Andre.  Sheela verified the
"shorter name problem" as stated in comment #9.  Note: I did see a crash  on
winxp & linux while testing this, however I found out it's not dependent on
changing the user name it's cancelling the password dialog while the failed
loging is checking the server again. I'll log a new one for that.  So Andre, can
you tell us if this works for you now. Jakub, can you tell us if this is working
for you too.

Comment 17

17 years ago
Just an update to above message about a crash.  Didn't find a bug, but can't
reproduce with 3-7 trunk builds so no bug logged.

Comment 18

17 years ago
nsbeta1- as per ADT
Keywords: nsbeta1+ → nsbeta1-

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Comment 19

17 years ago
This bug is not fixed in build 2002041711 for win32.  It makes email totally
unusable for me.  The old netscape communicator had this bug too.  I actually
have to use an MSFT product to read my email now.
(Reporter)

Comment 20

16 years ago
May this bug should be marked as "fixed"? Since build 1.0 I was not able to
reproduce (in fact I had been using the mozilla mail with login =
xxxx@xxx.com.br without problems).

Seems to be fixed.

Comment 21

16 years ago
Resolving as Works-For-Me per reporter's comment 20.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.