Closed Bug 1083965 Opened 5 years ago Closed 5 years ago

[Homescreen][Smart Collection] Launching a Smart Collection causes the device restart after viewing a black screen.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: Marty, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files)

Description:
If the user selects one of the Smart Collections on the homescreen, the device will display a black screen for several seconds, and then the device will restart itself.

This occurs with the default Smart Collections, as well as custom Smart Collections added by the user.

Note: The device does not produce a Crash Report
   
Repro Steps:
1) Update a Flame device to BuildID: 20141016040204
2) At the home screen, open a Smart Collection (Social, Games, or Music)
  
Actual:
The device displays a black screen, and then the device restarts
  
Expected: 
The Smart Collection opens properly.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141016040204 (Full Flash)
Gaia: 841d0d7d1b879f0ff4b5a8727f5dd23c7b0000a9
Gecko: a280a03c9f3c
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

  
Repro frequency: 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/5856/
See attached: logcat


------------------------------------

This issue does NOT occur on Flame 2.1
Smart collections open properly.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141016001201
Gaia: 477a9e61c3edf12f32a62a19d329cd277202cc6b
Gecko: 67573e422a0f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional Regression of a Core feature and fails smoke tests.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
I was able to reproduce this issue while shallow flashing, but it no longer does on the latest build.

Reproduces:
Environmental Variables:
Device: Flame 2.2
BuildID: 20141016065647
Gaia: 5c636a7a54b2c86d8ff6bc1aa1e5f9594c7bc586
Gecko: 9fe9bace9ed5
Version: 36.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


No longer reproduces:
Environmental Variables:
Device: Flame 2.2
BuildID: 20141016070843
Gaia: 5c636a7a54b2c86d8ff6bc1aa1e5f9594c7bc586
Gecko: 77f3ca1fe052
Version: 36.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
no longer repros
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → WORKSFORME
Discussed with tchung. Even though this doesn't repro on the tbox build we are leaving the bug open until the regular build comes out tomorrow. At that time if the bug doesn't repro it can be closed out.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Using Flame and:

Gaia   abef62c0623e5504a97b4fd411e879a67b285b52
SourceStamp ae1dfa192faf
BuildID 20141017040208
Version 36.0a1
v. 184

This is still happening intermittently. After an OTA today the first 4 times I pressed the "Around Me" Smart Collection the entire device rebooted. The 5th time it did not happen.
QA Whiteboard: [QAnalyst-Triage+]
Requesting a window since we can still reproduce let's find what caused it.
+ kevin grandon and Ran from E.me to help.  Do you guys know why this is happening?   this is a smoketest blocker that only happens on trunk, and not other branches.
Flags: needinfo?(ran)
Flags: needinfo?(kgrandon)
Nothing has changed recently in smart collections, so let's get the regression window. My hunch is that this is indexedDB based, and possibly the one that is causing other issues.
Flags: needinfo?(ran)
Flags: needinfo?(kgrandon)
Duplicate of this bug: 1076056
(In reply to Kevin Grandon :kgrandon from comment #8)
> Nothing has changed recently in smart collections, so let's get the
> regression window. My hunch is that this is indexedDB based, and possibly
> the one that is causing other issues.

is comment 1 not clear on a range?   from what i can see, it sounds like gecko is the same, but gaia changes from: 

Gecko (works) 77f3ca1fe052 to Gecko (broken) 9fe9bace9ed5
(In reply to Tony Chung [:tchung] from comment #10)
> (In reply to Kevin Grandon :kgrandon from comment #8)
> > Nothing has changed recently in smart collections, so let's get the
> > regression window. My hunch is that this is indexedDB based, and possibly
> > the one that is causing other issues.
> 
> is comment 1 not clear on a range?   from what i can see, it sounds like
> gecko is the same, but gaia changes from: 
> 
> Gecko (works) 77f3ca1fe052 to Gecko (broken) 9fe9bace9ed5

Oh right, I didn't see that, I assume this is from comment 2, and in that it shows as gaia is the same, but a difference in gecko.
I am looking into this issue again and have almost found the regression window (it is a gaia issue).  The build from yesterday that I was unable to repro on actually can reproduce this issue.  

Some things to note: This issue requires a restart to begin but sometimes requires up to 5 restarts before it will begin.  A symptom that indicates that a build might reproduce this issue are if the screen flashes when pressing a collection (but does not restart) and the black screen from the title is also not necissarily something that always occurs (the restart can take anywhere from instantly to 10 seconds and the longer it is the more you will see a black screen.

I will have the regression-window very soon, definitely before EOD.
This feels like it could also be bug 994190, but let's see what the regression window comes up with.
Forgive me I mistyped gaia when I meant gecko earlier, hasty typing is no good.  Here is the window.  This issue was hard because there is another crash issue when pressing the left most collection as soon as able but shows no other symptoms of this bug.  I plan to investigate this issue more on Monday.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140929090301
Gaia: 77ef35f5429bc3dfe9ca192b9aacc3c0bf8857de
Gecko: b13afdbcf97b
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140929103401
Gaia: 8c1c17dc0b87c67d44c8b9df06c43ad78df4f241
Gecko: df363eb7ac1a
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.2
BuildID: 20140929104701
Gaia: 8c1c17dc0b87c67d44c8b9df06c43ad78df4f241
Gecko: bcf35e3725f0
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 8c1c17dc0b87c67d44c8b9df06c43ad78df4f241
Gecko: bcf35e3725f0

First Broken gaia / Last Working gekko - Issue does NOT occur
Gaia: 8c1c17dc0b87c67d44c8b9df06c43ad78df4f241
Gecko: df363eb7ac1a

Gecko Pushlog: 
https://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=df363eb7ac1a&tochange=bcf35e3725f0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Thank you for the clarification and getting that window. Unfortunately it feels incorrect to me. I'm going to see if I can try without the patches from bug 994190. It might also be tricky to bisect this because that bug was landed, reverted, and re-landed. This could interfere with bisection. I don't have any concrete evidence of bug 994190, but based on what other people are seeing, it seems likely.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Kevin any update here? Its been more than a couple days and QA is reporting the same smoketest failure, so appreciate urgent help :)
Flags: needinfo?(kgrandon)
I am unable to reproduce this on the latest build. Adding qawanted to see if they are still seeing this issue:

Gaia-Rev        27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/88adcf8fef83
Build-ID        20141023040204
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
Flags: needinfo?(kgrandon)
Keywords: qawanted
I am able to reproduce this issue on the latest 2.2 Nightly build 

Actual Result - As soon as the homescreen comes up and I click on a Smart Collection icon the device will reset.  


Device: Flame 2.2 (full flashed)
Build ID: 20141023040204
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


I am NOT able to repro on the latest 2.2 Tinderbox build

Actual results - if I click on a smart collection icon immediately upon homescreen boot I will see the homescreen redraw once but then everything works fine - if I wait a few seconds on homescreen boot then everything works fine. 

Device: Flame 2.2 (Tinderbox-Eng-Shallow flashed)
Build ID: 20141023110739
Gaia: f46d56d812480bff7f3b35e8cacbedfa4d49edc5
Gecko: d8de0d7e52e0
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(kevingrandon)
Keywords: qawanted
QA Contact: jmercado
Hmm, seems like there is still a bug here, but odd that the two builds are behaving differently.
Flags: needinfo?(kevingrandon)
Based on comment 19 it seems that we have landed something in gecko that changes the behavior here. It seems that the original STR here no longer reproduces, so going to close this as worksforme.

I'm also unable to reproduce the "redraw" as mentioned in comment 19, but there may still be a bug. Please open another bug to track this issue, or reopen this one if it reproduces after the next nightly build.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → WORKSFORME
I still have seen this intermittently doing an OTA on the User build, most recently on a 2.1 device where I have not seen it before.

Last seen on nightly:

Gaia   1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
SourceStamp 09fb60a37850
BuildID 20141023001201
Version 34.0
v188

Selected the Music collection and the phone rebooted. I updated to:

Gaia   0f76e0baac733cca56d0140e954c5f446ebc061f
SourceStamp 7d78ff7d25b6
BuildID 20141023161200
Version 34.0
v188

And it did not reproduce following the same STR.

Since it happened on 2.1 I think we might want to keep our eyes open for this bug on both branches.
reopening, as I am able to reproduce this on trunk today using the original steps. I selected the default collection "Music" following the OTA and the phone rebooted. I did not get the typical geolocation prompt before this happened.

Gaia   f46d56d812480bff7f3b35e8cacbedfa4d49edc5
SourceStamp d8de0d7e52e0
BuildID 20141023160203
Version 36.0a1
v188

Is it possible this has something to do with not getting the geolocation prompt?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Marcia Knous [:marcia - use needinfo] from comment #23)
> reopening, as I am able to reproduce this on trunk today using the original
> steps. I selected the default collection "Music" following the OTA and the
> phone rebooted. I did not get the typical geolocation prompt before this
> happened.
> 
> Gaia   f46d56d812480bff7f3b35e8cacbedfa4d49edc5
> SourceStamp d8de0d7e52e0
> BuildID 20141023160203
> Version 36.0a1
> v188
> 
> Is it possible this has something to do with not getting the geolocation
> prompt?

Did you do an 2.0 -> 2.1 upgrade or an 2.1 -> 2.1 update?
Flags: needinfo?(mozillamarcia.knous)
Can we get a logcat with the exact timing information when the crash happens? I don't see anything in the logcat that shows that the device rebooted.
Keywords: qawanted
[snip]

> 
> Did you do an 2.0 -> 2.1 upgrade or an 2.1 -> 2.1 update?

Updated 2.1->2.1. Will work on getting a better logcat
Flags: needinfo?(mozillamarcia.knous)
This issue has not been encountered by our the smoke team at Q-Analysts in either the nightly build from yesterday, 20141027040237, or today: 20141028040202
Removing the smoketest keyword for now but we will keep an eye out to see if the issue crops up again and report back.
Keywords: smoketest
Attached file reset_logcat.txt
Along with Oliver I can no longer reproduce this issue on the latest builds.  I went back to a build I kenw I could reproduce it on in order to grab the logcat.  In this logcat I pressed the collection at 13:43:27.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Status: REOPENED → RESOLVED
blocking-b2g: 2.2? → ---
Closed: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.