[Window Management] Opening homescreen settings goes to the main settings page first

RESOLVED DUPLICATE of bug 1007600

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1007600
3 years ago
3 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.1 affected, b2g-v2.2 fixed)

Details

(Whiteboard: [2.1-flame-test-run-3], [systemsfe], URL)

Attachments

(1 attachment)

Description:
When the user taps on homescreen settings, they are redirected to the main settings page for a good 2 or 3 seconds before the "homescreen settings" page actually appears.  

Prerequisite: Ensure that the settings app is not already running in the background. 

Repro Steps:
1)  Updated Flame to Build ID: 20141015001201
2)  Tap and hold your finger on an empty spot on the homescreen.
3)  Tap on "Homescreen Settings".
4)  Pay close attention to the transitions.

Actual:
The user is redirected to the main settings page for a good 2 to 3 seconds before transitioning to the "Homescreen Settings" page.

Expected:
The user is taken directly to the "Homescreen Settings" page.

Environmental Variables
Device: Flame 2.1(KK)(319mb)(Full Flash)
Build ID: 20141015001201
Gecko: https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/4853208cb48a
Gaia: 379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Platform Version: 34.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%
Link to failed test case: Found during exploratory testing. 
See attached: video clip, logcat
Youtube: http://youtu.be/7DU5GK8lncI

Please note that if the settings app is already running in the background then the user is taken directly to "Homescreen Settings".
This issue also occurs on Flame 2.2.

The user is directed to the main settings page for 2 or 3 seconds before being taken to the "Homescreen Settings" page.

Flame 2.2 

Device: Flame 2.2 Master KK (319mb) (Full Flash)
Build ID: 20141015040201
Gaia: 5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Gecko: 62f0b771583c
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 36.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------------------------

This issue does not occur on Flame 2.1 because homescreen settings did not exist.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regression
Created attachment 8506370 [details]
homescreensettingslog.txt
(Reporter)

Updated

3 years ago
Whiteboard: [2.1-flame-test-run-3] → [2.1-flame-test-run-3], [systemfe]
(Reporter)

Updated

3 years ago
Whiteboard: [2.1-flame-test-run-3], [systemfe] → [2.1-flame-test-run-3], [systemsfe]
Correction to comment 1 that should say "This issue does not occur on Flame 2.0 because homescreen settings did not exist".
[Blocking Requested - why for this release]:

Nominating this to block 2.1. The user can interact with the settings app when it first loads because the app takes so long to load into the homescreen settings. This is poor UX and slow performance
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Not a main use-case and its not a regression. Lets fix on trunk.
blocking-b2g: 2.1? → backlog
This was fixed in bug 1007600 which is implemented on trunk. Thank you for filing.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → DUPLICATE
Duplicate of bug: 1007600
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.