[mozharness] The entire mozharness process is a single step in treeherder log view

RESOLVED DUPLICATE of bug 1100414

Status

defect
RESOLVED DUPLICATE of bug 1100414
5 years ago
3 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [treeherder])

Reporter

Description

5 years ago
This probably is a bug to fix on treeherder's end, feel free to reassign appropriately, although that could be considered a problem in the log format or in the way the data is exposed to treeherder. As a matter of fact, it doesn't affect treeherder only. For instance, I've been relying on the build-steps database to gather information on where time is spent e.g. before actually starting to build, etc. This now requires parsing every single build log.

See e.g. https://treeherder.mozilla.org/ui/logviewer.html#?job_id=7156&repo=elm

The whole fx_desktop_build.py step is considered as a single step, when we had individual steps before.
Note we will have some of the mozharness steps broken down in influxdb when bug 1071281 is finished, but that will initially only be at the "action" level of mozharness (so things like clobber, setup-mock, build, etc). However, the build step would still be a single stat point, so all of the build/buildsymbols/check/etc would be globbed together. We can look into reporting stats there as well, though that would likely have to be separate from mozharness.

How were you thinking this would be solved in treeherder? Maybe do something funky with BUILDSTATUS?
Component: General Automation → Mozharness
Whiteboard: [treeherder]
do we do something else for mozharness tests (also all one step)?

IIUC this is just a side effect of using mozharness. not sure how treeherder works but maybe we can regex off: '###### Running $foo step'.

breaking this off from blocking 'trunk rollout bug' and attaching it to the overall desktop mozharness tracker.
Blocks: 1055912
No longer blocks: 1055918
I'm calling this a dupe of a treeherder bug.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100414
You need to log in before you can comment on or make changes to this bug.