The bookmark manager is empty

VERIFIED FIXED in seamonkey2.33

Status

--
major
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: tonymec, Assigned: stefanh)

Tracking

({regression, uiwanted, useless-UI})

Trunk
seamonkey2.33
regression, uiwanted, useless-UI
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.32 unaffected, seamonkey2.33+ fixed)

Details

Attachments

(1 attachment)

Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33a1 ID:20141015003005 c-c:06b9b65bc279 m-c:62f0b771583c

Reproducible: Every time

Steps to reproduce:
1a. Hit Ctrl+B
or
1b. Bookmarks → Manage bookmarks

Actual results:
The bookmark manager opens, but it is empty.

Expected results:
My bookmarks should be visible in the bookmark manager.

Additional info:
My bookmarks are visible in the Bookmark menu, and bookmark folders still correctly produce submenus (and sub-submenus, where applicable).

I'm not sure if this bug is in the SeaMonkey bookmarks frontend or in the Toolkit Places backend, hence the places@toolkit Cc. Maybe both (was there a recent change in the backend which broke the frontend?)

N.B. The SeaMonkey "Bookmarks & History" module seems unowned, so I'm guessing who may act as owner & peers for its bugs. Please redirect if I missed.

This bug is fairly recent. I don't think I saw it in SeaMonkey 2.32a1 (but if someone else sees it in 2.32a2, please update the flags accordingly).
(Assignee)

Comment 1

4 years ago
This is what I get in the console when launching the BM:
Error: TypeError: bs.setFolderReadonly is not a function
Source File: resource:///modules/PlacesUIUtils.jsm
Line: 1077

Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: Component returned failure code: 0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS) [nsINavBookmarksService.runInBatchMode]
Source File: resource:///modules/PlacesUIUtils.jsm
Line: 1124
this is likely a Seamonkey regressions due to toolkit changes in bug 1068671.
(Assignee)

Comment 3

4 years ago
Looks like this is caused by http://hg.mozilla.org/mozilla-central/rev/b30d47d94a85
(Assignee)

Comment 4

4 years ago
(mid-aired)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1083070
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1083480
(Assignee)

Updated

4 years ago
Keywords: regressionwindow-wanted
Duplicate bug 1083480 is for platform "Other / Mac OS X" => setting this bug to All/All.
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Comment 8

4 years ago
Created attachment 8507250 [details] [diff] [review]
Mostly C&P

This is a straight port of Mano’s work in bug 1068671, it also includes the fix in bug 1083376. It doesn’t work, though (It could be because it's late at night for me and I've just done c&p). I don't know if I'll be able to pick this up again, but the patch can probably be used as a as starting point for someone else.

Comment 9

4 years ago
Comment on attachment 8507250 [details] [diff] [review]
Mostly C&P

Actually this patch seems to work, but you might need the patches in bug 1087942 too.

Updated

4 years ago
Assignee: nobody → stefanh
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1086616
(Assignee)

Comment 11

4 years ago
Comment on attachment 8507250 [details] [diff] [review]
Mostly C&P

I'm not able to build (unrelated to this) atm and I'm leaving for vacation (1 week) tomorrow. But there's no reason that it shouldn't work on mac if it works on win or linux.
Attachment #8507250 - Flags: review?(neil)

Comment 12

4 years ago
'Mostly C&P' works on x86_64, but only with the additional patches mentioned in Comment 9.
(Assignee)

Comment 13

4 years ago
(In reply to Hartmut Figge from comment #12)
> 'Mostly C&P' works on x86_64, but only with the additional patches mentioned
> in Comment 9.

Thanks Hartmut, I feel much better now :-)

Updated

4 years ago
tracking-seamonkey2.33: --- → +
Depends on: 1087942
Comment on attachment 8507250 [details] [diff] [review]
Mostly C&P

>-    case "placesCmd_new:folder":
>+    case "placesCmd_new:folder":                         
Bogus whitespace change. r=me with that fixed.

>+    return parentNode != null &&
Nit: explicit != null is probably unnecessary.

>+    let obs = Object.freeze({
Nit: freezing of this object is probably unnecessary.
Attachment #8507250 - Flags: review?(neil) → review+

Comment 15

4 years ago
http://hg.mozilla.org/comm-central/rev/072eb34fcd1f

>>-    case "placesCmd_new:folder":
>>+    case "placesCmd_new:folder":                         
> Bogus whitespace change. r=me with that fixed.

>>+    return parentNode != null &&
> Nit: explicit != null is probably unnecessary.

>>+    let obs = Object.freeze({
> Nit: freezing of this object is probably unnecessary.
I fixed the above issues on checkin.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.33: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.33

Comment 16

4 years ago
Verified fixed with new build on Linux x86_64.
Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33a1 ID:20141026003001 c-c:4b11354bfcf1 m-c:441055ff60e5
Status: RESOLVED → VERIFIED

Updated

4 years ago
Depends on: 1122702

Updated

3 years ago
Duplicate of this bug: 1084277
You need to log in before you can comment on or make changes to this bug.