Closed Bug 1084301 Opened 8 years ago Closed 8 years ago

PIN text edit is focused at start but there's no keyboard

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1080051
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: bbouvier, Assigned: gduan)

References

Details

(Keywords: regression, Whiteboard: [DUPEME])

Attachments

(1 file)

STR:
- restart your phone.
- during Firefox logo screen, contemplate a blue drop appearing and disappearing a few seconds later.
- PIN screen appears
- Focus gets in the PIN text edit.

Expected:
- the keyboard should appear

Actual:
- the keyboard doesn't appear. One has to lose focus (tap outside) and re-focus (tap inside) in the PIN text edit for the keyboard to appear.


B2G version:
Gaia-Rev        841d0d7d1b879f0ff4b5a8727f5dd23c7b0000a9
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a280a03c9f3c
Build-ID        20141016040204
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
blocking-b2g: --- → 2.2?
Component: General → Gaia::System::Input Mgmt
Keywords: regression
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: [systemsfe][DUPEME]
Adding qawanted to see if we can still reproduce this issue since the patch for bug 1081860 might have fixed this.
Keywords: qawanted
Tested with Full Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK, Flame 2.1 KK

Actual Results: With SIM PIN enabled, the user will see a blue caret on the firefox boot screen (2.2 only) then it disappears. When the user gets to the SIM PIN screen, the keyboard does not automatically appear. User has to choose to tap in the text field to get it to populate.

Repro Rate: 4/4

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141020055012
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: f2d7d694aae5
Version: 36.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141020072210
Gaia: 6456e9d03a6f9a226818a1bccefc489a9bb7cb56
Gecko: 105d1bb4180f
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.0 KK

Actual Result: Keyboard pops up on the SIM PIN screen automatically.

Repro Rate: 0/2

Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141020025114
Gaia: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko: 09b9387be5ad
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140828230659
Gaia: f087c45c328f16bf6f8d5a4d9452fa9a27aa6c7b
Gecko: 2162e10743be
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140828234459
Gaia: f087c45c328f16bf6f8d5a4d9452fa9a27aa6c7b
Gecko: a57d1aa27da9
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

They have the same Gaia.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=2162e10743be&tochange=a57d1aa27da9

Caused by Bug 1013847.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
[Blocking Requested - why for this release]: Just swapping to the appropriate branch - no 'why' was ever given on the initial blocking request.



Possibly caused by Bug 1013847 - can you take a look Edgar?
Blocks: 1013847
blocking-b2g: 2.2? → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(echen)
QA Contact: pcheng
Attached file pin_text_log
Have no idea why bug 1013847 cause this bug, probably because the timing of 'cardstatechange' event is changed and hit a Gaia issue. Hi Alive, could you help to take a look this? Thank you.
Flags: needinfo?(echen) → needinfo?(alive)
I will not say this is a blocker.. my WIP bug https://bugzilla.mozilla.org/show_bug.cgi?id=1079748 is able to fix it anyway.
Flags: needinfo?(alive)
That's the first thing the user sees when he starts the phone. We should try to come up with a workaround for 2.1
blocking-b2g: 2.1? → 2.1+
Oh not sure why the systemsfe tag was on here. Seems like you guys are taking care of it. Feel free to triage again.
Whiteboard: [systemsfe][DUPEME] → [DUPEME]
So, we got 2 issues here,
 1. during Firefox logo screen, contemplate a blue drop appearing and disappearing a few seconds later.
 2. Keyboard won't show up

I can see issue 1 but not issue 2 with current master build.
Set qawanted to check if issue 2 is still reproducible.
Keywords: qawanted
(In reply to Rudy Lu [:rudyl] from comment #11)
> So, we got 2 issues here,
>  1. during Firefox logo screen, contemplate a blue drop appearing and
> disappearing a few seconds later.
>  2. Keyboard won't show up
> 
> I can see issue 1 but not issue 2 with current master build.
> Set qawanted to check if issue 2 is still reproducible.

(2) is still reproducible on latest master build. Note that the issue is the keyboard won't AUTOMATICALLY show up. One has to tap inside the sim pin field to invoke the keyboard.

Device: Flame 2.2 Master (shallow flash)
BuildID: 20141027075744
Gaia: 0888735b2c5932624808147b85a60d698d9d7352
Gecko: 20408ad61ce5
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
George, could you help look into this since you're already involved with bug 1081860 and bug 1080051.

From my point of view, the "Can repro" conclusion from comment 12 might be a different case from the original bug description.

 1. The bug description, The SIM pin input field is already focused, but the keyboard does not show up, and clicking on the input field won't get the keyboard to show.
 2. comment 12 - The input field is not focused (so, the keyboard won't show up, for sure), and the then clicking on it will trigger the keyboard.
Flags: needinfo?(gduan)
Assignee: nobody → gduan
Flags: needinfo?(gduan)
bug 1079748 will solve comment 12 on master branch.

I am still investigating proper solution for 2.1 branch.
Status: NEW → ASSIGNED
Clearing blocking status as the symptom appears in a very specific combination (no lock screen, sim locked, first boot) and is easily recoverable.
blocking-b2g: 2.1+ → backlog
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1080051
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.