If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to send a mms with attachment, the message dissapears from the message thread after tapping Send button

RESOLVED WORKSFORME

Status

Firefox OS
RIL
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: viorela, Unassigned)

Tracking

({qablocker, regression})

unspecified
ARM
Gonk (Firefox OS)
qablocker, regression

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Sending a message with picture attached fails, the message dissapears after tapping Send button and it is not sent.  I'm able to reproduce this manually and by running the automated test test_sms_with_attachments.py
Repro rate: 5 out of 5

#STR:
1. Launch Messages app
2. Click new message
3. Add a phone number in the recipient section
4. Add a text in the message field
5. Tap Add an attachment button, then select Camera option
6. Take a picture and tap Select, to add the picture to the message
7. Tap Send button

#Expected results:
The message dissapears from the new message thread; it is not sent.  

#Actual results:
The message is displayed in the new message thread; it is succesfully sent.

Regression range, based on b2g-i builds:
Last working:
Gaia-Rev        abef62c0623e5504a97b4fd411e879a67b285b52
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/3dba8eb39239
Build-ID        20141016074239
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141016.120936
FW-Date         Thu Oct 16 12:09:51 EDT 2014
Bootloader      L1TC10011800

First failing:
Gaia-Rev        abef62c0623e5504a97b4fd411e879a67b285b52
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/cc7fc5918561
Build-ID        20141016115830
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141016.152732
FW-Date         Thu Oct 16 15:27:43 EDT 2014
Bootloader      L1TC10011800

No gaia changes.

Gecko changes: https://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=3dba8eb39239&tochange=cc7fc5918561

Jenkins report: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.ui.functional.smoke/63/HTML_Report/
(Reporter)

Updated

3 years ago
Component: Gaia::UI Tests → Gaia::SMS
Keywords: qablocker, qaurgent, regressionwindow-wanted, smoketest
Whiteboard: [fromAutomation]
(Reporter)

Comment 1

3 years ago
We need to find a regression range based on mozilla-inbound builds
(Reporter)

Comment 2

3 years ago
Video of the issue: https://www.dropbox.com/s/l6crcuv45c709k7/VID_0008.3gp?dl=0
This issue REPROES in Flame 2.2 Master
Results: The message dissapears from the new message thread; it is not sent. 

**********************************************
Environmental Variables:
----------------------------------------------
Device: Flame 2.2 [Full Flash]
BuildID: 20141017040208
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
----------------------------------------------
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
Created attachment 8506983 [details]
logcat_20141017_MMSClose.txt
Issue DOES NOT REPRO on Flame 2.1 KK
Results: The message is displayed in the new message thread; it is successfully sent.

**********************************************
Environmental Variables:
----------------------------------------------
Device: Flame 2.1
BuildID: 20141017001201
Gaia: 1ea74943cfe525c76a074ca1d7de8e51a70f6b98
Gecko: 2befa902ff5c
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------------------
[Blocking Requested - why for this release]:
Functional regression of a core feature that fails smoke tests.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(pbylenga)
Keywords: regression
QA Contact: aalldredge
I was unable to reproduce this issue using the steps in the description. I had to open another app and have it running in the background for the issue to occur.

----------------------------------------------------
Central Regression Window (Shallow Flash)(319mb)
----------------------------------------------------

Last Working:
Device: Flame 2.2 Master
BuildID: 20141016115532
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: cc7fc5918561
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken:
Device: Flame 2.2 Master
BuildID: 20141017004453
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: cc7fc5918561

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cc7fc5918561&tochange=ae1dfa192faf

All merges are from FX team, Cannot check Inbounds.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, regressionwindow-wanted
NI - to the communications / sms owner to find someone to take a look at the regression-window pushlog

(we don't have a lot of experience with identifying FX merge regressions causers)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(echang)
QA Contact: aalldredge
Hey,

how does it work when you send a MMS from an existing thread?
Keywords: qawanted
Blocks: 1083126
Summary: Unable to send a sms with attachment, the message dissapears from the message thread after tapping Send button → Unable to send a mms with attachment, the message dissapears from the message thread after tapping Send button
NI me, I want to try today with a current build, and investigate.
Flags: needinfo?(felash)
(Reporter)

Comment 11

3 years ago
I was able to reproduce this issue manually on latest master build, by following STR from comment 0.
Repro rate, using latest master: 1 out of 6 times.

Jenkins report: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/70/HTML_Report/

Build info:
Device firmware (date) 	20 Oct 2014 04:40:40
Device firmware (incremental) 	eng.cltbld.20141020.074029
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	20 Oct 2014 00:42:08
Gaia revision 	dc496d04907d
Gecko build 	20141020040204
Gecko revision 	ca6b46cbca3b
Gecko version 	36.0a1

I was also able to reproduce this behaviour by sending an MMS from an existing thread.
I can't reproduce from the latest master (base v184) on my Flame :/

From the issue description, it sounds like we don't get the "sending" event from Gecko. So I'm gonna move this to the RIL Component in case the RIL peers can reproduce and have an idea about the issue.
Component: Gaia::SMS → RIL
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #9)
> Hey,
> 
> how does it work when you send a MMS from an existing thread?

Issue DOES occur when sending MMS from an existing thread. 
I restarted and powered down the device multiple times. 

The repro rate I saw was: 5/5

Environmental Variables:

Device: Flame Master
Build ID: 20141020040204
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: ca6b46cbca3b
Version: 36.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
I was unable to reproduce.
Is it related to base image? 
Duane, do you mind try reproduce with base image v188?

Environmental Variables:

Device: Flame Master
Build ID: 20141019160202
Version: 36.0a1 (Master)
Firmware Version: v188
Flags: needinfo?(ddixon)
Hi Julien,
This issue does not exist in the Flame 2.0 & Woodduck 2.0 and it work normal when I send MMS from an existing thread.
Flame version:
rose@rose-System-Product-Name:~/B2G-flash-tool$ ./check_versions.sh 
Gaia-Rev        9c7dec14e058efef81f2267b724dad0850fc07e4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c17df9fe087d
Build-ID        20141019160201
Version         32.0
Device-Name     flame-kk
FW-Release      4.4.2
FW-Incremental  34
FW-Date         Tue Sep 30 14:06:36 CST 2014
Bootloader      L1TC00011840
Woodduck version:
Gaia-Rev        a273ab9c18e9184eb02722b25c73e2ba7680cc09
Gecko-Rev       e7df4dde2d9dbedee942333d34eaea2afe32bebc
Build-ID        20141017100433
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1413510704
FW-Date         Fri Oct 17 09:52:15 CST 2014
QA-Wanted: to check 2.2 with v188 base
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ddixon)
Keywords: qawanted
Will check v188 after submitting this comment.

I'm seeing this every time on the master build below. I received a mms from another device then tried to respond with a mms with attached image and when I tap send the message disappears and is not sent.

Before I tried sending an MMS, I tried sending an SMS with just text and it worked correctly. However after the problem with the MMS, when sending an SMS with just text now even those are broken at this point.

***Once this bug occurs, even if you close out Messages app, if you try to open and compose a message, the user is unable to even launch a new message. Buttons no longer work in this app. Even when accessing messages app from other means such as through contacts, the app does not work. Rebooting will fix the problem.

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141020185822
Gaia: 457a54fc3200b80e4f5e1cd3acaa062309230732
Gecko: 29fbfc1b31aa
Version: 36.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
I cannot reproduce this issue using the V188 base with 2.2 KK. All my images sent correctly from new and existing threads.

Repro Rate: 0/7 attempts.

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141020185822
Gaia: 457a54fc3200b80e4f5e1cd3acaa062309230732
Gecko: 29fbfc1b31aa
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Keywords: qawanted
Wesley - issue does not occur with the new v188 base - is this safe to close as fixed by updated firmware?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(whuang)
I see v188 is used for smoketest, so it's an official base now. 
As the issue can't be produced on v188, I think we can set RESOLVED WORKSFORME.
Flags: needinfo?(whuang)
No reproducible on v184.
Flags: needinfo?(echang)
(In reply to Cody Roesch [:croesch] from comment #17)

> ***Once this bug occurs, even if you close out Messages app, if you try to
> open and compose a message, the user is unable to even launch a new message.
> Buttons no longer work in this app. Even when accessing messages app from
> other means such as through contacts, the app does not work. Rebooting will
> fix the problem.

Cody, would you by chance have a log when launching the Messages app again in this state? (being sure it's been closed before)
Maybe we have an issue that appears only when something else is breaking, and we can fix it.
Flags: needinfo?(croesch)
Julien,
     For some reason I cannot get the bug to happen this morning on the same build as yesterday. Not sure what happened but I'll keep trying through out the day. I'll give you the log when I can reproduce.
Providing some information from what Smoke Test has seen this week:

On Monday and Tuesday of this week, we were seeing this 100% of the time on both v180 AND v188 bases with a Full Flashed 2.2 nightly build.

As of today, we have not encountered this issue at all, on either v180 or v188 bases, even when returning to previous builds where the issue was occurring previously.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Removing smoketest blocker since we're unable to reproduce today.

Adding qawanted for further investigation.
Flags: needinfo?(pbylenga)
Keywords: smoketest → qawanted
Closing as WFM based on comment 18-21 + comment 24
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Keywords: qawanted
Resolution: --- → WORKSFORME
Julien,
    Still unable to reproduce this bug as is the Smoke team not able to. Could this have been a service issue? I don't understand why it won't repro when everything is the same. Same base same build just a different day. So until this decides to pop up again, no log can be made available.
Flags: needinfo?(croesch)
As I said, the issue is likely that we didn't get the "sending" event from Gecko.

Hey Bevis, do you know of any condition where this could happen?
Flags: needinfo?(btseng)
(In reply to Julien Wajsberg [:julienw] from comment #28)
> As I said, the issue is likely that we didn't get the "sending" event from
> Gecko.
> 
> Hey Bevis, do you know of any condition where this could happen?

From the log in comment 4, there seems something broken in the IPC protocol in IDB and we are not able to get any error feedback from [1] after requesting to save the sending message.
This could be the reason why there was no "sending" event returned from Gecko.
Otherwise, we should see the log "Saving sending message is done. Start to send." printed at [2] before notifying "sending" event.

In addition, according to previous comments, the only thing I saw in common is that this issue happened only on base image v180. :(

[1] http://dxr.mozilla.org/mozilla-central/source/dom/mobilemessage/gonk/MmsService.js#2296
[2] http://dxr.mozilla.org/mozilla-central/source/dom/mobilemessage/gonk/MmsService.js#2304
Flags: needinfo?(btseng)
paste the error log for reference:
10-17 08:12:09.706  2235  2235 I Gecko   : -@- MmsService: Running protocol version: 1.1
10-17 08:12:09.706  2235  2235 I Gecko   : -@- MmsService: send: aParams: {}
10-17 08:12:09.706  2235  2235 I Gecko   : -@- MmsService: createSavableFromParams: aParams: {}
10-17 08:12:09.716  2235  2235 I Gecko   : -@- MmsService: createSavableFromParams: normalize phone number from +16502728385 to +16502728385
10-17 08:12:09.716  2235  2235 I Gecko   : -@- MmsService: createSavableFromParams: aMessage: {"headers":{"to":[{"address":"+16502728385","type":"PLMN"}]},"parts":[{"headers":{"content-type":{"media":"application/smil","params":{"name":"smil.xml","charset":{"charset":"utf-8"}}},"content-location":"smil.xml","content-id":"<smil>"},"content":"<smil><head><layout><root-layout width=\"320px\" height=\"480px\"/><region id=\"Image\" left=\"0px\" top=\"0px\" width=\"320px\" height=\"320px\" fit=\"meet\"/><region id=\"Text\" left=\"0px\" top=\"320px\" width=\"320px\" height=\"160px\" fit=\"meet\"/></layout></head><body><par dur=\"5000ms\"><img src=\"frankenstein.jpg\" region=\"Image\"/></par></body></smil>"},{"headers":{"content-type":{"media":"image/jpeg","params":{"name":"frankenstein.jpg"}},"content-location":"frankenstein.jpg","content-id":"<frankenstein.jpg>"},"content":{}}],"type":"mms","timestamp":1413558729725,"receivers":["+16502728385"],"sender":"16509336960","iccId":"89014103276352319757","deliveryStatusRequested":false}
10-17 08:12:09.756  2235  2272 I Gecko   : 
10-17 08:12:09.756  2235  2272 I Gecko   : ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x120005,name=PBackground::Msg_PBlobConstructor) Value error: message was deserialized, but contained an illegal value
10-17 08:12:09.756  2235  2272 I Gecko   : 
10-17 08:12:09.756  2235  2272 I Gecko   : IPDL protocol error: could not look up PBlob
10-17 08:12:09.756  2235  2272 I Gecko   : IPDL protocol error: Error deserializing 'PBlobParent'
10-17 08:12:09.756  2235  2272 I Gecko   : 
10-17 08:12:09.756  2235  2272 I Gecko   : ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x60004,name=PBackgroundIDBDatabase::Msg_PBackgroundIDBDatabaseFileConstructor) Value error: message was deserialized, but contained an illegal value
10-17 08:12:09.756  2235  2272 I Gecko   : 
10-17 08:12:09.766  2235  2272 I Gecko   : IPDL protocol error: could not look up PBackgroundIDBDatabaseFile
10-17 08:12:09.766  2235  2272 I Gecko   : IPDL protocol error: Error deserializing 'DatabaseFileOrMutableFileId[i]'
10-17 08:12:09.766  2235  2272 I Gecko   : IPDL protocol error: Error deserializing 'files' (DatabaseFileOrMutableFileId[]) member of 'ObjectStoreAddPutParams'
10-17 08:12:09.766  2235  2272 I Gecko   : IPDL protocol error: Error deserializing 'commonParams' (ObjectStoreAddPutParams) member of 'ObjectStorePutParams'
10-17 08:12:09.766  2235  2272 I Gecko   : IPDL protocol error: Error deserializing 'RequestParams'
10-17 08:12:09.766  2235  2272 I Gecko   : 
10-17 08:12:09.766  2235  2272 I Gecko   : ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0xE0006,name=PBackgroundIDBTransaction::Msg_PBackgroundIDBRequestConstructor) Value error: message was deserialized, but contained an illegal value
removed nom as it's no longer reproducible.
blocking-b2g: 2.2? → -
You need to log in before you can comment on or make changes to this bug.