Closed Bug 1084462 Opened 8 years ago Closed 8 years ago

talos regressions on inbound (v.36) on Oct 14 from revision ea2ea74d0e33

Categories

(Firefox Build System :: General, defect)

All
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

when bug 1061335 landed (to turn on vs2013 for the builders) we saw a lot of improvements and a few regressions:
http://54.215.155.53:8080/alerts.html?rev=ea2ea74d0e33&table=1&show_improvement=1

there is a bug in alert manager where the improvements are showing for pgo & non pgo, so look here to see the regressions:
http://54.215.155.53:8080/alerts.html?rev=ea2ea74d0e33&table=1

while there are a few, I want to make sure we are fine with them:
a11y - 4.5% - win7 / win8
webgl terrain - 3.6% winxp
session restore - 2.2 - 3.2% (xp/7/8)
tp5o responsiveness - 4% (winXP)
libxul memory during link - 37% regression

obviously this is a case of serious wins.  I think what concerns me most is the a11y test.
I should clarify that PGO saw big wins and non pgo is the only bit that saw some regressions.  We only ship PGO, so all of the regressions mentioned are actually wins when looking at PGO.
on merged branches, I see non-pgo tp5o slight regression:
tp5 optimized - 2.25% win7/8
tp5 scroll - 3.5% win xp

it is possible that these merges are showing regression as a side effect of other patches in the merge, but it looks most likely that this change is the root cause.
Totally don't care about the non-PGO case. Can I just mark this WONTFIX?

Also, I'll file a bug to disable/remove the "libxul memory during link" stat: now that we're using a 64-bit toolchain, that number doesn't matter.
+1 on removing the link stats!

I am glad we have a simple resolution here- if PGO is a massive improvement and we only ship PGO, then wontfix for me!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Cool, I was wondering what that was. Sounds fine to me. Go go gadget PGO!
For sheer curiosity's sake, I'd be interested to see the link memory usage from bug 922912, bug 609976, bug 1084162. If we could keep the test around until those land, I'd appreciate it.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.