[UI] Alert Manager - table view needs to differentiate between pgo and non pgo

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jmaher, Assigned: kaustabh93, Mentored)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good next bug][lang=python])

(Reporter)

Description

4 years ago
I ran into a case where we had non pgo regressions and pgo improvements for the same test/platform.  Knowing that, the table  view gets confused:
http://54.215.155.53:8080/alerts.html?rev=ea2ea74d0e33&table=1

We should make sure that there is a clear distinction between pgo and non pgo for a given revision.  

1) we can fix our merge detection and force this to be ignored because pgo will be merged
2) we can split the table cells and add a little 'p' or something like that to denote that we have different values for pgo vs non pgo
3) we should ignore #1 and make it possible to see what each cell looks like merged, ideally when moused over (indicate in the cell that there is additional data)
(Reporter)

Updated

4 years ago
Whiteboard: [good next bug][lang=python]
(Reporter)

Updated

4 years ago
Assignee: nobody → kaustabh93
(Reporter)

Comment 1

4 years ago
first round of changes for this were landed with: https://github.com/jmaher/alert_manager/pull/99
(Reporter)

Comment 2

4 years ago
I believe we can call this done, thanks for continuing to work on this!
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.