Closed Bug 1084501 Opened 5 years ago Closed 5 years ago

Set proper permissions for pre-installed trusted apps

Categories

(Core Graveyard :: DOM: Apps, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.1+, firefox34 wontfix, firefox35 wontfix, firefox36 fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
mozilla36
blocking-b2g 2.1+
Tracking Status
firefox34 --- wontfix
firefox35 --- wontfix
firefox36 --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: zoran.jovanovic, Assigned: zoran.jovanovic)

Details

(Whiteboard: [Tako_Blocker])

Attachments

(1 file)

When trusted hosted apps are installed from a preloaded
offline cache their permissions are not correctly set
due to information on 'kind' of application being missing
on pre-install.
Attachment #8507078 - Flags: review?(jonas)
Attachment #8507078 - Flags: review?(fabrice)
Attachment #8507078 - Flags: review+
Whiteboard: [Tako_Blocker]
[Blocking Requested - why for this release]:

since its r+ and partner need this fix, raise for 2.1? for landing to 2.1 branch.
blocking-b2g: --- → 2.1?
blocking-b2g: 2.1? → 2.1+
Once this lands on central, please request b2g34 approval so this can be approved for uplift on the branch.
Assignee: nobody → zoran.jovanovic
https://hg.mozilla.org/mozilla-central/rev/87f031a85885
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Unable to verify due to not enough STRs.
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-verify-]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-verify-] → [QAnalyst-Triage+][QAnalyst-verify-]
Flags: needinfo?(ktucker)
Please request b2g34 approval on this when you a chance.
Flags: needinfo?(zoran.jovanovic)
Flags: needinfo?(zoran.jovanovic) → needinfo?(fabrice)
@Fabrice: Can you please help out?
Attachment #8507078 - Flags: approval-mozilla-b2g34+
Flags: needinfo?(fabrice)
Hi Zoran,
That is to say after you failed to download an app sucessfully but its shortcut already showed on Home, click this shortcut. Then this app will start downloading itself. The issue is: after the download is completed,some default settings for location in APP permissions are not correct?
Flags: needinfo?(zoran.jovanovic)
(In reply to SandKing from comment #10)
> Hi Zoran,
> That is to say after you failed to download an app sucessfully but its
> shortcut already showed on Home, click this shortcut. Then this app will
> start downloading itself. The issue is: after the download is completed,some
> default settings for location in APP permissions are not correct?

It is possible to preload appcache for a hosted app and have an initial offline support. (See https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Market_customizations_guide#How_do_you_prepare_a_preloaded_hosted_app_for_initial_offline_support.3F) In this case, if app whose cache is preloaded is of trusted kind and requires permissions, these permissions would not have been granted since 'kind' was not resolved. This is fixed in this bug.
Flags: needinfo?(zoran.jovanovic)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.