Embedded vimeo videos can't go fullscreen

RESOLVED INVALID

Status

()

Core
Audio/Video
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
See the URL for example.  When I press the fullscreen button, I get this in the console:

"Request for full-screen was denied because this domain has been blocked from full-screen by user."

But when I go to https://vimeo.com, the UI in the location bar shows me that I have changed the full-screen permission to "Allow".
I cannot reproduce with Nightly.

Can you try a fresh profile? Which firefox version? HTML5 player or flash?

Do you mean the fullscreen button in the vimeo embed's playback controls or is there a different one?
Flags: needinfo?(ehsan.akhgari)
(Reporter)

Comment 2

4 years ago
I'm pretty sure this is a result of something in my profile.  Well, that's where the permission is stored.  :-)

This is on Nightly, with their HTML5 player.  When I click the fullscreen button in the vimeo playback controls, nothing happens, and I get that error in the console.

I'd be happy to look up things in my profile if you can tell me what kind of info would help you debug this.
Flags: needinfo?(ehsan.akhgari)
No idea. There are only a handful of fullscreen prefs in my about:config. Do you have any of those set to non-default values? Some have hyphens so try searching for just 'full'.
Flags: needinfo?(ehsan.akhgari)
(Reporter)

Comment 4

4 years ago
No, I haven't changed any of them...
Flags: needinfo?(ehsan.akhgari)
(Reporter)

Comment 5

4 years ago
Sigh.  It turns out I had an "allow" permissions for vimeo.com but a "deny" one for player.vimeo.com.  Not sure how I got the latter.  Sorry for the false alarm!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Glad you figured it out. Nice to learn there's an about:permissions too; I wasn't aware of that!
You need to log in before you can comment on or make changes to this bug.