[Contacts] Error prompt prevents user from exiting contact screen

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: CorinneI, Assigned: sergi)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8507131 [details]
Error Prompt Logcat.txt

Description:
If the user tries to add a contact from an empty contact list to a message or E-mail, the error prompt that appears can cause the messages app, or email app, to become stuck on a contact screen.
   
Prerequisites: 
Must have an empty contact list and an active E-mail acount linked to device with no contacts imported.

Repro Steps:
1) Update a Flame device to BuildID: 20141017001201
2) Open the messages app from the home screen
3) Tap the create a message icon
4) Tap the "+" icon to try and add a contact
5) When error prompt appears tap the home button
6) Open the E-mail app from the home screen
7) Tap the create new email icon
8) When no error prompt appears tap the home screen
9) Open the E-mail app from the home screen again
  
Actual:
No error prompt appears and E-mail app will be stuck in a contact screen that has no visible rocketbar or "x" icon. Rocektbar can still be interacted with.
  
Expected: 
Error prompt should appear when trying to add contact from empty contact list.
  
Environmental Variables:
Device: Flame 2.1 kk (319mb)(Full Flash)
BuildID: 20141017001201
Gaia: 1ea74943cfe525c76a074ca1d7de8e51a70f6b98
Gecko: 2befa902ff5c
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: Issue does not occur if contact screen is invoked by dialer app
  
Repro frequency:  100%
See attached:  Youtube Video, Logcat

Youtube Link: https://www.youtube.com/watch?edit=vd&v=1aK058RxgNo
Flags: needinfo?(dharris)
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][2.1-exploratory-3]
(Reporter)

Comment 1

4 years ago
Issue does NOT occur on

Flame 2.0

Device: Flame 2.0 KK (319mb) (Full Flash)
BuildID: 20141017000203
Gaia: 9c7dec14e058efef81f2267b724dad0850fc07e4
Gecko: c17df9fe087d
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Actual: Error prompt appears in bot the email and messages app

Issue DOES occur on

Flame 2.2 

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141017040208
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Actual: Error prompt does not occur and contact screen appears.
[Blocking Requested - why for this release]:

Although this bug requires many inputs, this is a regression, 100% repro rate, and the user is stuck on a screen. Nominating to block 2.1
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?][2.1-exploratory-3]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted
This issue is no longer occurring on latest 2.2. Updating tracking flag.

Device: Flame 2.2 Master
BuildID: 20141017004453
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Window will be attempted in 2.1 branch.
status-b2g-v2.2: affected → unaffected
QA Contact: pcheng
The environmental variables for the no longer occurring build should be:

Device: Flame 2.2 Master
BuildID: 20141023110739
Gaia: f46d56d812480bff7f3b35e8cacbedfa4d49edc5
Gecko: d8de0d7e52e0
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
(Reporter)

Updated

4 years ago
Whiteboard: [2.1-flame-test-run-3] → [2.1-exploratory-3]
triage: regression
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S7 (24Oct)
Cannot reproduce in latest 2.1

Will record a video to show it
Here is the video for 2.1 working
https://drive.google.com/file/d/0B3RfQh7fuZjALXo4NUxqSlFNM2M/view?usp=sharing
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Tested twice on:

Gaia-Rev        0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/7d78ff7d25b6
Build-ID        20141024001204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.jlorenzo.20141002.104456
FW-Date         Thu Oct  2 10:45:09 CEST 2014
Bootloader      L1TC00011880

And I was not to reproduce the issue.
Assignee: nobody → sergi.mansilla
Resolution: WORKSFORME → FIXED
I was able to reproduce it in a Peak with latest nightly, but now I can't anymore.
Keywords: regressionwindow-wanted
Moving back to "Works for me" as we don't know which commit fixed this.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.