Firefox 33.0 freezes when waking up from sleep

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: SimonSapin, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Since upgrading to 33.0, Firefox is unresponsive every time my laptop wakes from sleep-to-RAM. A few seconds after trying to interact with it, GNOME shows its "Firefox is unresponsive" dialog with the option to "Force quit", which seems to be the only way to recover. (Though I may have not tried waiting very long.)

Please let me know what I can do to help debug this. I’m running GNOME 3.14 (upgraded from 3.12 at the same time Firefox was upgraded from 32.x) on Archlinux x86_64.
(Reporter)

Comment 1

4 years ago
Thunderbird 32.2.0 seems affected too.

… or sometimes, at least.
What you could try is to find the regression range if you can reproduce it every time.
- http://mozilla.github.io/mozregression/
Component: General → Untriaged
(Reporter)

Comment 3

4 years ago
I just assumed this issue was related to the upgrade to Firefox 33 since it started at the same time, but it might not be. (GNOME was updated at the same time.)

I now believe this is the issue: https://bugs.archlinux.org/task/42422

Firefox uses GTK+2, and Evince (GNOME’s PDF reader) uses GTK+3. Loading the Evince plugin into Firefox brings symbols for both GTK+ versions in the same process, which causes bad things to happen.

After removing libevbrowserplugin.so as suggested in the Archlinux bug tracker and making the laptop sleep and wake up, I can not reproduce the freeze which had happened every time so far.

I’ll close this in a while if I still can’t reproduce the issue. What is the correct resolution for a bug that is not in Firefox/Gecko but in a plugin? Invalid?

Comment 4

4 years ago
(In reply to Simon Sapin (:SimonSapin) from comment #3)
> I’ll close this in a while if I still can’t reproduce the issue. What is the
> correct resolution for a bug that is not in Firefox/Gecko but in a plugin?
> Invalid?

Yup. Glad it seems to be fixed now!
(Reporter)

Comment 5

4 years ago
Yes, looks like https://bugs.archlinux.org/task/42422 was it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.