Crash in Music on song loading

RESOLVED DUPLICATE of bug 1075562

Status

Firefox OS
Gaia::Music
RESOLVED DUPLICATE of bug 1075562
3 years ago
3 years ago

People

(Reporter: gandalf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I upgraded witia's Keon from 1.3 to 2.2 master and it crashes Music on loading files from SD card.

The log is fairly cryptic, but looks like this:

I/Gecko   ( 2786): 
I/Gecko   ( 2786): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x120005,name=PBackground::Msg_PBlobConstructor) Value error: message was deserialized, but contained an illegal value
I/Gecko   ( 2786): 
I/Gecko   ( 2786): IPDL protocol error: could not look up PBlob
I/Gecko   ( 2786): IPDL protocol error: Error deserializing 'PBlobParent'
I/Gecko   ( 2786): 
I/Gecko   ( 2786): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x60004,name=PBackgroundIDBDatabase::Msg_PBackgroundIDBDatabaseFileConstructor) Value error: message was deserialized, but contained an illegal value
I/Gecko   ( 2786): 
I/Gecko   ( 2786): 
I/Gecko   ( 2786): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   ( 2786): 
I/Gecko   ( 2786): [Parent 2786] WARNING: pipe error (180): Connection reset by peer: file /home/geeksphone/FOS/keon/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 451
W/GeckoConsole( 2786): [JavaScript Error: "IndexedDB UnknownErr: ActorsParent.cpp:7697"]
W/GeckoConsole( 2786): [JavaScript Error: "IndexedDB UnknownErr: ActorsParent.cpp:6070"]
Looks a hell lot like bug 1075562

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1075562
You need to log in before you can comment on or make changes to this bug.