Recipient autocomplete: Increase maximum default number of result entries immediately visible in dropdown from current limit of 4 contacts

RESOLVED FIXED in Thunderbird 38.0

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: richard.leger, Assigned: mkmelin)

Tracking

31 Branch
Thunderbird 38.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Upgraded from TB 24.x to TB 31.2.0


Actual results:

The newly set auto-completion search result display default limit (in To, Cc, Bcc fields) is currently set to 5 contacts displayed.




Expected results:

- Increase the newly set auto-completion search result display default limit (in To, Cc, Bcc fields) to the previous value available in TB 24.x (I think it was about twice the amount: 10 contacts).
- Eventually allow end-users to change this limit within the options, that would be a great plus.
Component: Untriaged → Message Compose Window
OS: Windows 7 → All
Hardware: x86_64 → All
Mine only shows 4 in the scroll area. And srolling for the proper user can now be additional clicks.

I trust Richard when he says this is a regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 2

5 years ago
I tend to agree that 4 seems unnecessarily little, forcing some users to needlessly scroll.
Otoh, seeing less contacts might educate users to refine their searches to reduce the total number of results... ;)

At the end of the day, it really depends on user habits and scenarios. So I agree 100% that this should be user-configurable at least with a hidden pref. Personally, I wouldn't mind to expose that pref in the Options UI, too.
Summary: Increase the newly set auto-completion search result display default limit (in To, Cc, Bcc fields) from 5 contacts to 10 min + end-user option → Recipient autocomplete: Increase maximum default number of result entries immediately visible in dropdown from current limit of 4 contacts, and implement user-configurable pref

Updated

5 years ago
Summary: Recipient autocomplete: Increase maximum default number of result entries immediately visible in dropdown from current limit of 4 contacts, and implement user-configurable pref → Recipient autocomplete: Increase maximum default number of result entries immediately visible in dropdown from current limit of 4 contacts (e.g. to 10), and implement user-configurable pref

Comment 3

5 years ago
10 contacts shown also looks like a reasonable default limit to me, unless somebody comes up with design/UX reasons against that. It would be interesting to find out which bug/who reduced the number, and why.

Comment 4

5 years ago
Richard, what makes you think this is a regression? Probably not.

TB 24.6.0: max 4 contacts shown
TB 2.0.0.24 (20100228): max 4 contacts shown

One reason in favor of a higher default now is the fact that even the same person might have a number of different email addresses these days.

Updated

5 years ago
See Also: → 624209
(In reply to Thomas D. from comment #3)
> 10 contacts shown also looks like a reasonable default limit to me, unless
> somebody comes up with design/UX reasons against that. It would be
> interesting to find out which bug/who reduced the number, and why.

The only negative side I can think of is that 10 contacts is a lot more information, which may make it harder to single out single people (Especially if they have many contacts with the same or very similar names). I would probably go with 6 or 7 myself, but I don't suppose it's very important.
Reporter

Comment 6

5 years ago
What was the limit prior it was changed recently?
10 contacts would be the most adequate limit to my opinion. 

Then if it is possible to allow end-user to change it via an option to reduce it or increase it, that would be great as well.
Assignee

Comment 7

5 years ago
No it was 4 rows forever.
Summary: Recipient autocomplete: Increase maximum default number of result entries immediately visible in dropdown from current limit of 4 contacts (e.g. to 10), and implement user-configurable pref → Recipient autocomplete: Increase maximum default number of result entries immediately visible in dropdown from current limit of 4 contacts
Assignee

Comment 8

5 years ago
I tried 10 but that was not so nice: too much irrelevant info, so I agree 6 could be good.

I don't think we need to have a pref for it. Should be easy enough for someone to make an extension if needed.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8549810 - Flags: ui-review?(josiah)
Attachment #8549810 - Flags: review?(josiah)
Assignee

Comment 9

5 years ago
6 is also the default if no maxrows attr is set
Reporter

Comment 10

5 years ago
Please check with previous version of Thunderbird, I am pretty sure it was more than 4 entries up to recent versions.

If not an option in the Options windows UI can the option be made available via the about:config interface at least?
Reporter

Comment 12

5 years ago
Thanks for your help on this, much appreciated. 
6 it will be then [still better than 4] :)

I would still argue though that an option in about:config would be great at the least for those who would appreciate to see more contacts at once (than the default 6) in the list without having to scroll-down. This minimum feature shall not be too much overhead development wise (or would it?) and would bring freedom to end-users without necessity of a pointless add-on.

For some, it would be more performant to see 10 or more contacts at once (mainly considering the size of desktop screens now-a-day), as it would requires less action from end-users.

How "nice" it looks is less of a relevance, while this could eventually be improved as well but that is another story...

Also I don't understand what "irrelevant info" would there be as it would only show email list of your contacts after all. That appears to me as a relevant and useful information. In any case the information would still remain there, you would just need to scroll down (or type more characters) to see it...

About "6 is also the default if no maxrows attr is set", that may be coming from an overall global default settings within the Mozilla XUL framework as I noticed that the address bar auto-complete feature in Firefox shows 6 entries by default as well.
Assignee

Comment 13

5 years ago
It actually often is irrelevant info while you've typed just one or two chars, as the matches lower down is likely just matches within a word. 

Every pref do add maintenance burden, even if it might not appear that way at first glance.
Attachment #8549810 - Flags: ui-review?(josiah) → ui-review+
Attachment #8549810 - Flags: review?(josiah) → review+
Assignee

Comment 14

4 years ago
https://hg.mozilla.org/comm-central/rev/1aa67131558d
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
You need to log in before you can comment on or make changes to this bug.