Add rule should allow editing selector to one that doesn't match the current element

RESOLVED DUPLICATE of bug 1139058

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1139058
3 years ago
2 years ago

People

(Reporter: Luke, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200257

Steps to reproduce:

Added a rule with add rule option in inspector list.


Actual results:

Instead of showing a ".myclass:before" or ".myclass:after", it disappears. Similarly, if I add a class and change its selector to have :before, the rule disappears, though this doesn't happen to the original css rules.


Expected results:

It should reliably be able to change or set selector.
Component: Untriaged → Developer Tools: Inspector
This is a bigger problem. Changing the selector to anything that doesn't apply to the current element will cause the new rule to disappear.
Summary: Before/after rule created with add-rule disappears. → Add rule should allow editing selector to one that doesn't match the current element
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 33 Branch → Trunk

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139058
You need to log in before you can comment on or make changes to this bug.