error: no matching function for call to NS_NewInputStreamChannel(nsIChannel**, nsIURI*&, nsCOMPtr<nsIStringInputStream>&, const nsLiteralCString&)

RESOLVED DUPLICATE of bug 1084481

Status

RESOLVED DUPLICATE of bug 1084481
4 years ago
4 years ago

People

(Reporter: ewong, Unassigned)

Tracking

SeaMonkey 2.31 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Bug 1063197 made some API changes to NS_NewInputStreamChannel.

Linux 32 c-c build is busted:

nsNNTPNewsgroupList.cpp
/usr/bin/ccache /tools/gcc-4.7.3-0moz1/bin/g++ -o nsIMAPHostSessionList.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /builds/slave/c-cen-t-lnx/build/mozilla/config/gcc_hidden.h -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DMOZ_GLUE_IN_PROGRAM -DOSTYPE=\"Linux2.6.32-220.7.1.el6\" -DOSARCH=Linux -DNO_NSPR_10_SUPPORT -I/builds/slave/c-cen-t-lnx/build/mailnews/imap/src -I.  -I../../../dist/include  -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nspr -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nss       -fPIC   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MP -MF .deps/nsIMAPHostSessionList.o.pp  -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Werror=endif-labels -Werror=int-to-pointer-cast -Werror=missing-braces -Werror=pointer-arith -Werror=return-type -Werror=sequence-point -Werror=unused-label -Werror=trigraphs -Werror=type-limits -Wno-invalid-offsetof -Wcast-align -gdwarf-2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -gdwarf-2 -freorder-blocks -Os  -fno-omit-frame-pointer      /builds/slave/c-cen-t-lnx/build/mailnews/imap/src/nsIMAPHostSessionList.cpp
nsImapIncomingServer.cpp
../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp: In member function ‘nsresult nsAddbookProtocolHandler::GenerateXMLOutputChannel(nsString&, nsIAddbookUrl*, nsIURI*, nsIChannel**)’:
../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp:100:99: error: no matching function for call to ‘NS_NewInputStreamChannel(nsIChannel**, nsIURI*&, nsCOMPtr<nsIStringInputStream>&, const nsLiteralCString&)’
../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp:100:99: note: candidates are:
In file included from ../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp:16:0:
../../../dist/include/nsNetUtil.h:653:1: note: nsresult NS_NewInputStreamChannel(nsIChannel**, nsIURI*, nsIInputStream*, nsIPrincipal*, nsSecurityFlags, nsContentPolicyType, const nsACString_internal&, const nsACString_internal&)
../../../dist/include/nsNetUtil.h:653:1: note:   candidate expects 8 arguments, 4 provided
../../../dist/include/nsNetUtil.h:721:1: note: nsresult NS_NewInputStreamChannel(nsIChannel**, nsIURI*, const nsAString_internal&, const nsACString_internal&, nsIPrincipal*, nsSecurityFlags, nsContentPolicyType, bool)
../../../dist/include/nsNetUtil.h:721:1: note:   candidate expects 8 arguments, 4 provided
../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp: In member function ‘virtual nsresult nsAddbookProtocolHandler::NewChannel(nsIURI*, nsIChannel**)’:
../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp:145:91: error: no matching function for call to ‘NS_NewInputStreamChannel(nsIChannel**&, nsIURI*&, nsCOMPtr<nsIAsyncInputStream>&, const nsLiteralCString&)’
../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp:145:91: note: candidates are:
In file included from ../../../../mailnews/addrbook/src/nsAddbookProtocolHandler.cpp:16:0:
../../../dist/include/nsNetUtil.h:653:1: note: nsresult NS_NewInputStreamChannel(nsIChannel**, nsIURI*, nsIInputStream*, nsIPrincipal*, nsSecurityFlags, nsContentPolicyType, const nsACString_internal&, const nsACString_internal&)
../../../dist/include/nsNetUtil.h:653:1: note:   candidate expects 8 arguments, 4 provided
../../../dist/include/nsNetUtil.h:721:1: note: nsresult NS_NewInputStreamChannel(nsIChannel**, nsIURI*, const nsAString_internal&, const nsACString_internal&, nsIPrincipal*, nsSecurityFlags, nsContentPolicyType, bool)
../../../dist/include/nsNetUtil.h:721:1: note:   candidate expects 8 arguments, 4 provided
make[4]: *** [nsAddbookProtocolHandler.o] Error 1
make[4]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/mailnews/addrbook/src'
make[3]: *** [mailnews/addrbook/src/target] Error 2
make[3]: *** Waiting for unfinished jobs....
/usr/bin/ccache /tools/gcc-4.7.3-0moz1/bin/g++ -o nsImapIncomingServer.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /builds/slave/c-cen-t-lnx/build/mozilla/config/gcc_hidden.h -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DMOZ_GLUE_IN_PROGRAM -DOSTYPE=\"Linux2.6.32-220.7.1.el6\" -DOSARCH=Linux -DNO_NSPR_10_SUPPORT -I/builds/slave/c-cen-t-lnx/build/mailnews/imap/src -I.  -I../../../dist/include  -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nspr -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nss       -fPIC   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MP -MF .deps/nsImapIncomingServer.o.pp  -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Werror=endif-labels -Werror=int-to-pointer-cast -Werror=missing-braces -Werror=pointer-arith -Werror=return-type -Werror=sequence-point -Werror=unused-label -Werror=trigraphs -Werror=type-limits -Wno-invalid-offsetof -Wcast-align -gdwarf-2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -gdwarf-2 -freorder-blocks -Os  -fno-omit-frame-pointer      /builds/slave/c-cen-t-lnx/build/mailnews/imap/src/nsImapIncomingServer.cpp
nsImapMailFolder.cpp

Comment 1

4 years ago
DUP to MailNews Core Bug 1084481
Mozilla Central Bug 1063197 - Storing LoadInfo on all channels created through NS_NewInputStreamChannel
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1084481
You need to log in before you can comment on or make changes to this bug.