Proxy: http does not prompt for proxy auth w/ transparent proxy

RESOLVED WORKSFORME

Status

()

Core
Networking
--
minor
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Dave Roberts, Unassigned)

Tracking

({helpwanted})

Trunk
x86
Windows NT
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

I sit behind a proxy server that requires authentication. Somehow I lost my
configuration, and I had "direct connection to internet".  When I tried to
access an external site, I was prompted for my username and password in the
normal manner.  When I typed this in, the browser looked like it was downloading
the page, but once completed, simply showed the page that I was already on. I
finally tracked this down to my proxy settings, and re-enabled my manual proxy
configuration, which fixed the problem.  This is a repeatable bug.

In Netscape 4.7, I would have had a warning stating that I proxy authentication
is required.. I think this was the contents of the page returned from the proxy
server.


Reproducible: Always
Steps to Reproduce:
1. Require a proxy server that requests authentication.
2. All web traffic goes through proxy server for Internet access.
3. Set proxy settings to "direct connection to the internet".
4. Try to access a site.

Actual Results:  External page was not displayed, despite the browser looking
like it was downloading said page.

Expected Results:  Displayed the error page returned from the proxy server.  As
I didn't have any proxy settings, it shouldn't prompt me for my proxy username &
password.

Comment 1

15 years ago
Works fine for me. However, since this bug was reported, a newer version of 
Mozilla (1.0 RC1) has been released. Reporter, please can you check to see 
whether this bug is still present in a recent build (Moz1-RC1 or a new nightly 
build) and inform us? If not, can you please resolve this report?

Comment 2

15 years ago
Tested with:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020424
(Reporter)

Comment 3

15 years ago
Using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1) Gecko/20020417
I still get a similar problem.  Having "direct connection" set, and then trying
to access this site, I was asked to "Enter username and password for proxy
at\nUsername:".  Having entered my credentials, I got an alert dialog box with a
warning triangle icon and the message "The document contains no data."

If I have my proxy settings set properly, the authentication dialog says "Enter
user and password for proxy at <proxy hostname>\nUsername:".

Note that all Internet traffic passes through this proxy server, it is a dual
homed gateway.  Therefore any attempt to access the Internet directly will still
pass through the proxy server, and it will return a "401 Unauthorized", unless
the appropriate HTTP header is sent in the request.

Comment 4

15 years ago
David:

It sounds like you have two possible problems:

1- Your proxy settings mysteriously began to say "direct" in the prefs panel one
day. 

2- You get proxy auth when using direct. This problem is probably a result of
your network configuration (if you hit a proxy server and get back a 407 <give
me proxy auth> response, then we will throw up a dialog box.)
(Reporter)

Comment 5

15 years ago
1) Correct, but it's not happened since

2) ISTM that there are better ways that Moz could handle it.  In Communicator,
if you didn't have a proxy server configured in your settings, and the browser
saw a response requiring authentication, then it would display the response that
it saw (usually an error message, saying I need to authenticate).  Moz is trying
to be clever and still allow me to authenticate, but once I do, it gives me the
error "The document contains no data."

Irrespective of how my network is configured Moz should cope one way or the
other.  Either allow me to authenticate and get the pages requested, or display
the error and force me to configure my proxy server settings.

Comment 6

15 years ago
cc: darin

I don't think mozilla is being "clever", I think there just pieces of http code 
that are reacting to what they get.

Lets deal with each problem at hand.

First, lets get your prefs.js lines that relate to networking/proxies. Lets see
if your prefs panel is displaying direct when it might actually be using a proxy
connection.

"network.proxy.*"

(Reporter)

Comment 7

15 years ago
Let's forget the first portion, it (resetting to direct) hasn't happened since I
reported the bug.  My network settings are fine, I simply reset them with the UI
and everything is fine.

However, if I manually switch back to direct (for the sole purpose of testing
this bug), I get the errors as reported.

I guess you guys need to decide what to do if the browser is not configured for
proxy access, but is confronted with a HTTP response stating that authentication
is required.  Do you (a) simply display the text portion of the HTTP response
within the browser (as Communicator 4 did) or (b) ask the user for his
authentication credentials (as you do now) but getting rid of the error that
pops up.

Comment 8

15 years ago
Okay, I think I have a correct summary now.

(ugh. A transparent proxy that asks for auth.)

I haven't done a lab reproduction, but setting to NEW +helpwanted.
Status: UNCONFIRMED → NEW
Component: Networking → Networking: HTTP
Ever confirmed: true
Keywords: helpwanted
Summary: External pages not shown if proxy auth required, but is not configured → Proxy: http does not prompt for proxy auth w/ transparent proxy

Comment 9

15 years ago
darin
Assignee: neeti → darin

Updated

15 years ago
Target Milestone: --- → Future

Comment 10

15 years ago
Darin: since you are futuring this, can you look at this and comment on the
validity? (no point in futuring something if invalid...)

Comment 11

15 years ago
without a packet trace it's difficult for me to say if this bug is valid or not.
 there's a very good chance that the proxy server is not behaving as well as it
could, but i can't know that without understanding what is actually passing
between mozilla and the proxy server.

dave: can you use a tool like www.ethereal.com to capture network traffic on
port 80?  the tool is not exactly user friendly, but if possible it would
seriously help us understand how to resolve this bug.  thx!!
(Reporter)

Comment 12

15 years ago
So I've captured the proxy jumping in and asking for authentication, and the
next HTTP request had a valid username/password. There were approximately 8 of
these HTTP requests before Mozilla popped up a dialog box saying that the data
is empty (or something like that).

My firewall will not let me post the trace file up so I will email it privately
to Darin, CC to BenC. It's a small file in tcpdump/libpcap format.

FWIW this is regression from Communicator 4.

Updated

15 years ago
Keywords: 4xp

Comment 13

14 years ago
do you still have the issue with 1.4 ?

Comment 14

11 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: benc → networking
Target Milestone: Future → ---

Comment 15

8 years ago
WFM with both Firefox 3.0.11 and Firefox 3.5.1 (on Windows XP Pro SP3).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.