Infinite loop in javascript console (may be unrelated to console)

RESOLVED DUPLICATE of bug 85831

Status

--
critical
RESOLVED DUPLICATE of bug 85831
17 years ago
8 years ago

People

(Reporter: ken.horn, Assigned: hewitt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
While debugging a web page (using for reference, window.open() then in child
doing things like opener.location = ".../etc" or opener.location.ref= "../etc"
style, then a this.close()) - I got an exception in the console. Didn't manage
to get the full text of it but was something like:

chrome:// ..... /addItem ()..
This appeared to be in an infinite loop - consuming 98% of CPU. The console
could still be closed and the rest of the browser worked normally, other than
the 98% CPU. Exiting the app did not kill the process in task mgr  -- had to
kill it manually.
JS console.  I've seen this on Linux too but can't come up with reliable steps
to reproduce...  The issue is that addItem() gets undefined somehow or at least
something thinks it is.  The resulting exceptions swamp the JS console.
Assignee: asa → hewitt
Status: UNCONFIRMED → NEW
Component: Browser-General → JavaScript Console
Ever confirmed: true
OS: Windows NT → All
QA Contact: doronr → jrgm
Hardware: PC → All
Might not this be a dupe of bug 85831?
So it is.  Thanks, David!

*** This bug has been marked as a duplicate of 85831 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey

Updated

8 years ago
Component: Error Console → Error Console
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.