Audit improper use of 'callschanged' event for initialization

RESOLVED DUPLICATE of bug 1048680

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1048680
4 years ago
3 years ago

People

(Reporter: drs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
In bug 1081811, we're going to remove firing of the 'callschanged' event on MozTelephony when first attaching listeners or when the telephony API becomes ready. See bug 1081811 comment 2 for a more thorough explanation.

In this bug, we should do an audit of our uses of the 'callschanged' event to confirm that we're not abusing it to do any initialization.

I did a quick check and we currently have 2 listeners for this:
https://github.com/mozilla-b2g/gaia/blob/7a381373d1039351126cb903543a21c32e6e3772/apps/callscreen/js/calls_handler.js#L21
https://github.com/mozilla-b2g/gaia/blob/7a381373d1039351126cb903543a21c32e6e3772/apps/callscreen/js/conference_group_handler.js#L27

Neither of these seems to have any initialization code. But we should do a more thorough check once bug 1081811 is ready/lands.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048680
You need to log in before you can comment on or make changes to this bug.