a frameset document with "No frames" option jams print engine

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: j.wunsch, Assigned: rods)

Tracking

Trunk
Future
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When trying to print any document that consists of a frameset with the
"No frames" print option, the print engine "jams".  Obviously, this
would not be expected to result in any pages being output :), but i
stumpled across this problem when trying to teach Galeon about more
print options.  The first attempt starts creating a Postscript output
file (apparently an incomplete file), but the browser continues.  The
next attempt to print anything causes the DocumentViewerImpl::Print()
to immediately return NS_ERROR_NOT_AVAILABLE.
(Reporter)

Comment 1

18 years ago
Created attachment 56548 [details] [diff] [review]
suggested patch against Mozilla 0.9.5,1

Comment 2

17 years ago
Marking new, adding patch since I didn't find a dupe and it has code.

However, I couldn't find this no frames option. Can you confirm?
Assignee: dcone → rods
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: patch
(Assignee)

Comment 3

17 years ago
YOu shouldn't be allowed to select No Frames when there is a frameset. So how
did that happen? I am quite sure very bad thing will happen.

I think the fix here is when there is a frameset make sure that "no frames " is
ever set.
Status: NEW → ASSIGNED
Summary: a frameset document with "No frames" option jams print engine → [KNOW FIX]a frameset document with "No frames" option jams print engine
Target Milestone: --- → mozilla0.9.8
(Reporter)

Comment 4

17 years ago
Well, i experienced the problem when i added the various frame
printing options to Galeon.

If i had found documentation about whether the currently displayed
URL in mozilla-embedded is a frameset, i would have loved to base
the printing options decision on that. ;-)

Anyway, i think it couldn't hurt either to have the bandaid in place,
thank you!
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Set to Moz1.1. Rod is adding the ability to determine if the currently displayed
page is a frameset in bug 115136.
Depends on: 115136
Summary: [KNOW FIX]a frameset document with "No frames" option jams print engine → a frameset document with "No frames" option jams print engine
Target Milestone: mozilla0.9.9 → mozilla1.1
(Assignee)

Updated

17 years ago
Priority: -- → P2
Target Milestone: mozilla1.1 → Future

Comment 6

15 years ago
Can anyone reproduce this with a current copy of mozilla? Does anyone a sample
URL that demonstrates this problem? 
Resolving WFM. I don't see a "No frames" print option in Mozilla1.7. 
If anyone can still reproduce this, please reopen (and with a clear description
of how to reproduce).
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.