noscript options not working

RESOLVED DUPLICATE of bug 1090450

Status

()

RESOLVED DUPLICATE of bug 1090450
4 years ago
4 years ago

People

(Reporter: grgoffe, Unassigned)

Tracking

({steps-wanted})

35 Branch
x86_64
Linux
steps-wanted
Points:
---

Firefox Tracking Flags

(e10s-)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140517030204

Steps to reproduce:

Attempt to read email from mail.yahoo.com. noscript menu is minimally populated.


Actual results:

noscript option to block or enable blocking items and other options except for "enable all scripts" are missing from the pulldown menu. Enable all scripts fails to enable anything. yahoo mail "boxes" not displayed. When I drag down add-ons and disable blocking for noscript, "box" contents are displayed.


Expected results:

"normal" noscript operations.
(Reporter)

Updated

4 years ago
Version: 32 Branch → 35 Branch

Comment 1

4 years ago
I'm having this issue on 35.0a2 also. Perhaps we should take it up with the noscript devs?
(Reporter)

Comment 2

4 years ago
Halrgar,

I thought they are camping out on this web site?

George...
For those seeing this: if you go to Firefox Preferences, is the "Enable E10s" checkbox enabled?

If so, try disabling that & restarting Firefox -- hopefully that should fix it. (If so, then this is a duplicate of bug 1058542.)

Comment 4

4 years ago
There's no 'enable e10s' checkbox. I can't find a relevant pref in about:config either.

This broke for me when I updated to 35.0a2 (2014-10-19).
(In reply to K. Gadd (:kael) from comment #4)
> There's no 'enable e10s' checkbox.

It should be present if you visit about:preferences (at the very top of the "General" section).

> I can't find a relevant pref in about:config either.

The corresponding about:config pref is "browser.tabs.remote.autostart", but probably better to tweak it via the UI if possible.
e10s is only supported on the Nightly channel, so you shouldn't see the "Enable E10S" checkbox in Aurora's about:preferences. In fact, e10s prevents itself from being enabled on Aurora, Beta, and Release channels (even if you do tweak your "browser.tabs.remote.autostart" pref). If you are seeing this bug on Aurora 35.0a2, then it is probably not an e10s bug.
tracking-e10s: --- → -

Comment 7

4 years ago
I cannot reproduce, even on Nightlies.
Could you check on a clean profile with just NoScript installed?
(In reply to Chris Peterson (:cpeterson) from comment #6)
> e10s is only supported on the Nightly channel, so you shouldn't see the
> "Enable E10S" checkbox in Aurora's about:preferences. In fact, e10s prevents
> itself from being enabled on Aurora, Beta, and Release channels

(The checkbox is there, but you're right that it's non-functional in Aurora, as far as I can tell. So, looks like this indeed isn't e10s-related; sorry for the red herring. I was led astray by bug 1058542 comment 12. :) )
For those who can reproduce this, it would help if you could figure out steps to reproduce, starting from a completely fresh Firefox profile.
Keywords: steps-wanted
(Reporter)

Comment 10

4 years ago
With a new profile and re-installing(?) no-script, no-script does appear and the pulldown does appear to be populated. I'm gonna check with my "normal" profile... WILL report back here.
(Reporter)

Comment 11

4 years ago
I'm not sure what happened. ALL the other plugins I had installed have disappeared.

Comment 12

4 years ago
The problem appears to be that automatic updates broke (?) for noscript at some point. The 'latest' version of noscript installed for me was 2.8.x.x but when I created a clean profile and installed noscript, I got 'NoScript Security Suite' with a version in the 2.9.x.x range and that version worked. Uninstalling the 2.8.x.x I had and installing 2.9.x.x fixed it.

Maybe the old version of NoScript should be blacklisted as incompatible with 35.0.a2+

Comment 13

4 years ago
Confirmed - updated noscript to 2.6.9.2 and the menu is populated on 35.0a2 2014-10-22 build
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Probably caused by bug 1090450
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1090450
You need to log in before you can comment on or make changes to this bug.