Initial bookmark sync between desktop and mobile doesn't work if there are too many bookmarks

VERIFIED WONTFIX

Status

Cloud Services
Firefox Sync: Cross-client
VERIFIED WONTFIX
4 years ago
4 years ago

People

(Reporter: JanH, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Create a new sync account on a desktop instance of Firefox with lots of bookmarks (in my case 6154 bookmarks).
2. Connect mobile Firefox to that account.

What happens:
- Bookmarks syncing doesn't work.
- If I check the logcat on my mobile device, I find entries like these:

I/FxAccounts(19384): firefox :: CountCheckingServer11RepositorySession :: First sync for bookmarks: 6154 items.
W/FxAccounts(19384): firefox :: CountCheckingServer11RepositorySession :: Too many items to sync safely. Skipping.

What should happen:
- Bookmarks syncing should work

Other things to note:
- The last time I ran into this problem I was using FF31 on my mobile.
- What makes this bug slightly more confusing from a user experience point of view is that if the initial bookmarks sync worked fine (because there were less bookmarks on desktop Firefox at that time), you don't experience any problems even if the number of bookmarks subsequently grows above the magic limit, because sync is only doing incremental updates. It's only when you have to reset the sync account on mobile and start again that you suddenly find that bookmarks syncing has stopped working. Plus you don't get any immediately visible indication why it doesn't work.
All I can say is… yup.

This is working as designed; that limit is there for a reason. The alternative is that you file a bug about Sync trashing your bookmarks. Above 5,000, and we start to run into essential limitations on syncing that make the likelihood of problems approach 100%.

Bug 814331 added this limit, if you want to see some backstory.

I'm marking this bug as depending on Bug 814801, which is the shortest path to being able to remove this dependency.

But this bug isn't itself actionable, and the issues are well-understood, so I'm going to mark this as RESOLVED WONTFIX, which is Bugzilla-speak for "this behavior isn't going to be changed".

The recommended workaround is to shift bookmarks that you don't expect to have as part of your Awesomebar into Pinboard.in, or some other kind of non-bookmark storage.

If you wish you can experiment with working around this limitation (which you seem to know how to do), but I generally recommend against using Sync with large numbers of bookmarks.

Thanks for the report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Firefox Sync: Backend → Firefox Sync: Cross-client
Depends on: 814801, 814331
Hardware: ARM → All
Resolution: --- → WONTFIX
(Reporter)

Comment 2

4 years ago
Thanks for the feedback and the explanation, at least now I know where approximately the limit is. Also, it's gotten me to clean up my bookmarks somewhat and because I stumbled across a relatively large number of temporary bookmarks I hadn't bothered to delete so far, I managed to prune them back to ~ 3500 bookmarks without too much difficulties, or having to resort to offloading some of them elsewhere.
OK.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.