If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[crash] 'save link as' causes crash

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
critical
RESOLVED WORKSFORME
16 years ago
a year ago

People

(Reporter: Brice Ruth, Assigned: asa)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
At the URL above, selecting 'save link as' for PDF manual link, causes Mozilla
to crash after clicking 'ok' in location dialog and progress window pops up - no
data is downloaded, apparently.  Link doesn't actually go to a PDF (I realized
belatedly) - it goes to another d/l page.  Nevertheless, this shouldn't crash
Mozilla, right?

Comment 1

16 years ago
WorksForMe using Fizzilla/2001101516. Contextually choosing "Save Link As..." on the PDF 
version of the MySQL Manual successfully saves a "manual.pdf" file to the chosen location, and 
Fizzilla doesn't crash.

The PDF file isn't valid, though. A valid PDF is only obtained by following the link and choosing a 
download server.

Reporter, you'll need to provide a Fizzilla Build ID as well as a CrashReporter log for this.
Severity: major → critical
Keywords: crash

Comment 2

16 years ago
This also crashed my browser. Fizzilla/2001102205

Not sure about a CrashReporter log... I've never used it.

Comment 3

16 years ago
--> File handling
WFM 20011109/WinNT4

Brice: You may wish to try a more recent build:
       http://ftp.mozilla.org/pub/mozilla/nightly/latest/
Component: Browser-General → File Handling

Comment 4

16 years ago
Nick, run Console and check the Preferences. You'll see options for crash reporting.

Comment 5

16 years ago
This works for me on Mozilla 0.9.6 (build ID 2001112020). Marking as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.