Firefox doesn't handle <ftpcode> properly.

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: k4-yamanaka, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20141011074935

Steps to reproduce:

When I access the below site by using FTP protocol, it shows a download link.
ftp://ftp.software.ibm.com/software/tivoli_support/misc/CandO/TierTable/

The link is "ftp://ftp.software.ibm.com/software/tivoli_support/misc/CandO/TierTable/IBM_STG_TierTable_2012-04-26.xml;type=i" and the URL path contains "type=<typecode>" . I clicked the download link.



Actual results:

Firefox FTP client doesn't handle FTP URL that includes typecode properly. It shows the link file (when that is an xml or a readable text). 



Expected results:

Firefox browser should have downloaded the file as binmode instead of showing it.
A chrome browser handle this properly, IE doesn't.
(Reporter)

Updated

4 years ago
Summary: Firefox doesn't treat <ftpcode> properly. → Firefox doesn't handle <ftpcode> properly.

Updated

4 years ago
Component: Untriaged → Networking: FTP
Product: Firefox → Core
Status: UNCONFIRMED → NEW
QA Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=211816
Ever confirmed: true
I'm sorry, but can you elaborate on exactly why Firefox should do this unconditionally?

The fact that the transfer mode of a particular FTP resource is binary is in no way any good indication of what the actual contents of that resource is nor how to treat it. Bug 211816 also points out that Firefox already does the transfer using binary so type=i is just superfluous.
(Reporter)

Comment 2

4 years ago
I'd just like Firefox to download a file as binary mode in the case that the link has explicitly "type=i". Firefox may handle the file as binary already, but it shows the file in the browser if it's a text file or something like xml. When I save the file that Firefox browser show me, the file isn't same as the original that is placed at the FTP site. It seems to insert much line feed or maybe change LF to CRLF. I also tried to download the file by using "Save as another name", but things were not what I had expected, neither.

Could you try the IBM site I described in the 1st post?
Thanks.
(Reporter)

Comment 3

4 years ago
I'm sorry that I was behind the my company web proxy with the issue.
I've realized that you won't reproduce the symptom I met, because the ftp link with type=i is generated by my company web proxy (squid). I'm not sure if there is a site that has an ftp link with typecode.

I'll look around for a site where you can reproduce the issue.
We are in a period where ftp is clearly deprecated and in general, making changes to the code is riskier than letting it ride unless there is a patch and reviewer available to make a good judgment about it. So I'm going to wontfix ftp bugs related to enhancements, interop errors, etc.. We will be better off putting our energy into including a different js based ftp stack.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.