Closed Bug 1085338 Opened 5 years ago Closed 5 years ago

putting frequently used punctuation in "bn-Provat" layout might be improved

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.4 wontfix, b2g-v2.0 wontfix, b2g-v2.0M affected, b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S7 (24Oct)
Tracking Status
b2g-v1.4 --- wontfix
b2g-v2.0 --- wontfix
b2g-v2.0M --- affected
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: optical.mahir, Assigned: optical.mahir, Mentored)

Details

(Whiteboard: [good first bug][lang=js][mentor-lang=zh])

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.2; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140925030203

Steps to reproduce:

1. Select "বাংলা-প্রভাত" layout.
2. Put a ","(comma)


Actual results:

To put comma one have to follow two steps.


Expected results:

This should be simplified and make a long-press feature on '.'(dot) in "bn-Provat" layout .
OS: All → Gonk (Firefox OS)
Thanks Mahir for filling this Bug. It seems to be very useful for me. But, I think it would be better if we can have "," in the bottom line of the Keyboard, in the left side of "Space". Like Taiwanese Keyboard. Can you please check the Taiwanese Keyboard?

Rudy Lu, is it possible to verify the bug for fixing?
Flags: needinfo?(rlu)
Flags: needinfo?(optical.mahir)
Hardware: All → ARM
Hi, it is possible to add "," as an alternative char for ".".
Please refer to the following syntax example in English layout,
https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/layouts/en.js#L21

We could modify bn-Probhat.js to follow the above pattern.

--
(In reply to Safwan Rahman from comment #1)
> Thanks Mahir for filling this Bug. It seems to be very useful for me. But, I
> think it would be better if we can have "," in the bottom line of the
> Keyboard, in the left side of "Space". Like Taiwanese Keyboard. Can you
> please check the Taiwanese Keyboard?

We would only show "," at the bottom line of the keyboard when there is only one keyboard layout enabled.
So, it would be better if we can add the alternative chars as suggested above.

> 
> Rudy Lu, is it possible to verify the bug for fixing?
Mentor: rlu
Flags: needinfo?(rlu)
Whiteboard: [good first bug][lang=js][mentor-lang=zh]
Well, I've been working around this bug/improvement. And I've added ',' , '?' ':' and '!' as the alternative characters of '.' 

 :rudyl, will you assign and mentor me to fix this bug?
Flags: needinfo?(optical.mahir) → needinfo?(rlu)
Hi Mahir,

Yeah sure, assign to you first as you express interest to work on this.
If this is the first time you work on Gaia, please help refer to this link for how to submit a patch (pull request),
https://github.com/mozilla-b2g/gaia/blob/master/CONTRIBUTING.md

Thanks.
Assignee: nobody → optical.mahir
Flags: needinfo?(rlu)
Hi Mahir,

Is it possible to create a pull request, which is easier for review.

See the instructions here for details and let me know if you need any help,
https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Submitting_a_Gaia_patch
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(optical.mahir)
Here's the pull link: https://github.com/mozilla-b2g/gaia/pull/25351
Flags: needinfo?(optical.mahir)
Target Milestone: --- → 2.1 S7 (24Oct)
Attached file Patch to add comma (obsolete) —
(Create an attachment to host the pull request link.)

Hi Mahir,

Thanks for submitting the patch.
I have made some comments on the pull request.
Please help address it.

Thanks.
Attachment #8508490 - Flags: review?(rlu)
I've tried to fix your mentioned issue, Rudy.
Flags: needinfo?(rlu)
Comment on attachment 8508490 [details] [review]
Patch to add comma

Looks good with only one nit, the  '{' after this block has wrong indentation.
Please help correct it and we're good to merge your change!

Thank you very much.
Flags: needinfo?(rlu)
Attachment #8508490 - Flags: review?(rlu) → review+
I have corrected, Rudy, can you please squash?
Attached file Squashed commit
pr for squashed commit.
Attachment #8508490 - Attachment is obsolete: true
Attachment #8509242 - Flags: review+
This will land on master when the tree is re-opened.
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/b95d82bc34929ecaccd9fd5e6101263e8344b7bd


--
Thanks for your contribution, great work!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Rudy, since the patch on bug - 1072458 got uplifted onto 1.4+ branch. Can't we uplift it also?
Flags: needinfo?(rlu)
I think this is an improvement instead of fixing a blocking issue.
Will try to ask for approval to uplift to v1.4.
Flags: needinfo?(rlu)
Comment on attachment 8509242 [details] [review]
Squashed commit

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A, minor improvement for easier typing ',' for Bangla, which is one of our shipping locale for v1.4.
[User impact] if declined: more steps required to type ",".
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): pretty low, just modify keyboard layout definition to add alternative chars.
[String changes made]: N/A.
Attachment #8509242 - Flags: approval-gaia-v1.4?
Comment on attachment 8509242 [details] [review]
Squashed commit

Unfortunately, its too late to land this on 1.4 or 2.0 at this point so approving this for 2.1 instead which is the earliest release you can see this getting fixed.
Attachment #8509242 - Flags: approval-gaia-v1.4? → approval-gaia-v2.1+
Attached video Confirm.MP4
Hi Mahir,
The phenomenon seems the same on b2g-2.0 b2g-2.0 and b2g-2.0M, that is to say this issue is not fixed, right?
Flags: needinfo?(optical.mahir)
Dear SandKing,

My fix was too late for b2g-2.0, it's Available in v2.1 and v2.2 and onwards :)

The video You shared seems to be using en-US layout and my fix is for bn-Provat layout.
Flags: needinfo?(optical.mahir)
You need to log in before you can comment on or make changes to this bug.