sending mail fails when promted with HTML Mail Question dialog

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
blocker
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: asa, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({smoketest})

Trunk
x86
Windows 2000
smoketest

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When attempting to send mail with HTML content the HTML Mail Question dialog
pops up asking me if I want to Send in Plain Text and HTML, Send in Plain Text
Only, or Send in HTML Only. Selecting any of these three options and clicking
the OK button dismisses the dialog but does not send the mail. 

JS Console has this warning: 
Error: document.documentElement.getButton is not a function
Source File: chrome://messenger/content/messengercompose/askSendFormat.js
Line: 151

If the HTML Mail Question dialog does not pop up the mail sends fine.
(Reporter)

Comment 1

17 years ago
heh. I suck. here's the rest of the info.

windows trunk mozilla build 110503 on win2K
tested IMAP with and without SSL

HTML message send is a smoketest. This is a blocker.


Keywords: smoketest

Comment 2

17 years ago
hewitt mistakenly changed a line in askSendFormat.js. patch coming.
(Reporter)

Comment 3

17 years ago
related to the recent XUL changes? adding blake and joe.

Comment 5

17 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
using build 20011113 this is fixed. verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.