Incorrect time (clock) and status showed in the statusbar

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: cgerardin, Assigned: gmarty)

Tracking

unspecified
FxOS-S1 (26Jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8508235 [details]
Screenshot of the lockscreen

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200324

Steps to reproduce:

Flash to latest 2.2 and boot the phone.


Actual results:

Time and 3G / Wifi status on the statusbar is incorrect when an application is on the foreground or the screen is locked (time showed on the lockscreen is ok)


Expected results:

Correct time and connection status showed on the statusbar.
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Comment 1

4 years ago
Phone used : ZTE Open C (france)

Comment 2

4 years ago
dupe of bug 1061797?
I think I just started seeing this as well, and it's different from bug 1061797.

The clock in the status bar is wrong at the lockscreen or when in an app, but it's fine when I'm at the homescreen.  Is that what you're seeing as well?


The odd thing is that I started seeing it noticeably after the bug was filed -- I didn't have problems in gaia 6a7fb482a03c5083ef79b41e7b0dfab27527cd04 from Monday, but I do see it with gaia 3c1668ad793d4f1a40831c46638acef38e0db230 from Friday.  So the trigger of the bug might not be something purely in the build...
Summary: Incorrect time and status showed in the statusbar → Incorrect time (clock) and status showed in the statusbar
I can also confirm this, and yes it is not bug 1061797:
 
On the homescreen, the status is current.
When an app ist in the foreground, the status is what *was* current at the time when any app was first launched after reboot.
The old status is identical for *all* apps, no matter whether it is freshly started or not.

e.g.: current is: no WiFi, time "23:56", in an app, the WiFi signal is still shown and time is 21:32. Which I remember is around the time when I first launched the first app after booting the phone.

Very interesting "feature": when I pull down the status menu, the current info "blends" over the old info, making it completely unreadable.

configuration here:
Flame running latest-central build-ID 20141230010205
I've seen this too so I'm confirming it. AFAIK the statusbar is handled by the system app, not the homescreen so I think it would be best to move this bug in the system component.
Status: UNCONFIRMED → NEW
Component: Gaia::Homescreen → Gaia::System
Ever confirmed: true
qaurgent since its on 2.2.
Can QA confirm?
Keywords: qaurgent, qawanted
blocking-b2g: --- → 2.2?
I have seen the statusbar in both the SMS and Email app display the wrong time - it seems to be the time at which that app was launched. I imagine it affects all foreground app, but those 2 are most likely to be long-running.

Updated

3 years ago
Duplicate of this bug: 1100010
I cannot reproduce this bug on latest Flame 2.2. I was able to reproduce bug 1061797 (it shows wrong time on lockscreen after reboot), but not this bug. Status bar shows correct time while in an app.

This bug reminds me of bug 1154635 where it has been fixed by Bug 1154800.

Reporter please test on latest and see if it still occurs.

Device: Flame 2.2 (319MB, full flashed, KK)
BuildID: 20150604002503
Gaia: b96e657ce2822df5da5da1a8ba91c38ad3281bc9
Gecko: 273f8ee45c88
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Leaving qawanted for others to attempt.
Flags: needinfo?(ktucker)
Flags: needinfo?(cgerardin)
I also did not reproduce this issue after 10 flashes to today's Flame 2.2 Nightly build.

Actual Results: Time and status bar showed the same information both in and out of apps.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150604002503
Gaia: b96e657ce2822df5da5da1a8ba91c38ad3281bc9
Gecko: 273f8ee45c88
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
This issue DOES reproduce on the latest Flame 2.2

Differe

Device: Flame 2.2
Build ID: 20150610002502
Gaia: 06edb0f8db7c2f45cde54401a8593663059861a4
Gecko: a3d7b08fb0ec
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Contact: bzumwalt
Issue DOES reproduce on the latest Flame 2.2

Comparing status bar time between Homescreen and open app shows difference of up to 3 minutes between the two times. Homescreen time is correct, open app shows either a few minutes fast or a few minutes slow (both observed in multiple apps.)

Noticed that just before completing FTU after flashing, there was a split second where the status bar time read an hour fast before correcting itself on homescreen.

Link to video of time difference switching between homescreen and cost control app: http://youtu.be/PY9YxBsvX1I


Device: Flame 2.2
Build ID: 20150610002502
Gaia: 06edb0f8db7c2f45cde54401a8593663059861a4
Gecko: a3d7b08fb0ec
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)
Keywords: qaurgent, qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(mhenretty)
Whiteboard: [systemsfe]
Component: Gaia::System → Gaia::System::Status bar, Utility tray, Notification
Guillaume, can you take a look here?
Assignee: nobody → gmarty
Flags: needinfo?(mhenretty)
(Assignee)

Comment 14

3 years ago
I found a STR for this bug that does NOT reproduce on master:
1. Start to open the utility tray
2. Lock the screen with the utility tray being opened mid-way (keep your finger on the screen while locking)
3. Unlock the screen

The status bar when minimised won't update its time until the utility tray is opened and closed again, it will then work as expected.
(Assignee)

Comment 15

3 years ago
Created attachment 8622512 [details] [review]
Github PR

Etienne, can you review this patch please? I added unit tests to cover the STR described above.
Attachment #8622512 - Flags: review?(etienne)

Updated

3 years ago
status-b2g-master: --- → affected
Comment on attachment 8622512 [details] [review]
Github PR

small comment about the test, but r=me with that!
Attachment #8622512 - Flags: review?(etienne) → review+
(Assignee)

Comment 18

3 years ago
Comment on attachment 8622512 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Status bar
[User impact] if declined: The time shown by the status bar may be different depending on its state after a bit of fiddling with the utility tray.
[Testing completed]: This patch is very minimal but completely unit tested. There is a STR above that can be used for manual testing.
[Risk to taking this patch] (and alternatives if risky): Very low for the reason mentioned just above.
[String changes made]: None.
Attachment #8622512 - Flags: approval-gaia-v2.2?

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
status-b2g-master: affected → fixed

Comment 19

3 years ago
Comment on attachment 8622512 [details] [review]
Github PR

Approving as this improves user experience.
Attachment #8622512 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Needs rebasing for v2.2 uplift.
Flags: needinfo?(gmarty)
Target Milestone: --- → FxOS-S1 (26Jun)
(Assignee)

Comment 21

3 years ago
Here's a patch for v2.2:
https://github.com/mozilla-b2g/gaia/pull/30718
Flags: needinfo?(gmarty)
(Assignee)

Comment 23

3 years ago
It's all green now :-)
Flags: needinfo?(gmarty)

Updated

3 years ago
Depends on: 1183928
Flags: needinfo?(cgerardin)
Flashed to the same build used on comment 12 and I still couldn't reproduce the problem. However using the str provided at comment 14 I WAS able to reproduce the bug. I doubt that Brogan tried with this STR when he reproduced it so I dug deeper.

It has to do with having some apps opened in the background, return to homescreen, lock the phone and unlock it, a minute or two has passed, and then re-open the apps that were opened before. Highly likely that I at comment 9 didn't try this (locking/unlocking the phone with apps in background) that's why I wasn't seeing it.

This issue is verified as fixed on Flame and Aries. Status bar time remains consistent and correct after locking and unlocking the phone with app opened in the background.

Verified on:
Device: Flame 2.6
BuildID: 20151209030343
Gaia: 961528f4391668bc89ec0be14fa367cea099b588
Gecko: 319be5e7ce3061c7c16f24d750b6dacdbcac4c35
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Aries 2.6
BuildID: 20151209121803
Gaia: 961528f4391668bc89ec0be14fa367cea099b588
Gecko: 319be5e7ce3061c7c16f24d750b6dacdbcac4c35
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.5
BuildID: 20151208120554
Gaia: 2d54c29f429bed790b5d8284633812dc2b782518
Gecko: ff31a251b2f6149edf4fc0a199133ef2e190ceac
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.2
BuildID: 20151209032501
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 4381c4b69b9c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-v2.5: --- → verified
status-b2g-master: fixed → verified
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.