[2.1][l10n][Dialer] Multiple locales: Conference call header text is truncated

RESOLVED WONTFIX

Status

Mozilla Localizations
da / Danish
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: RobertM, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: LocRun2.1-2)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8508335 [details]
2014-01-03-13-50-57.png

Description:
While in a conference call with 3 or more people, the header text at the top is truncated.
   
Prereq: Have a SIM card inserted in the device and set language to Danish. Have at least 2 contacts saved with numbers you can call.

Repro Steps:
1) Update a Flame device to BuildID: 20141020001201
2) Tap on the 'Contacts' app
3) Call one of the contacts.
4) While in a call, tap the phone icon to add another contact to the call.
5) Once the 3rd person joins, tap the up arrow to create a conference call. Observe the header.
  
Actual:
The word "Gruppesamtale(2)" should be the header, but instead you see "Gruppesamtal..."
  
Expected: 
The word "Gruppesamtale(2)" should be the header (Which translates too "Conference(2)")
  

Flame 2.1(319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141020001201
Gaia: 2904ab80816896f569e2d73958427fb82aebaea5
Gecko: 12dc9b782f2a
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
This issue also occurred on Flame2.0 (319mb)

When creating a conference call with 2 other people, while in Danish, the conference call header is truncated.

Flame 2.0 (319mb)(Full Flash)

Device: Flame 2.0 
Build ID: 20141020000206
Gaia: 9c7dec14e058efef81f2267b724dad0850fc07e4
Gecko: c17df9fe087d
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Comment 2

3 years ago
Created attachment 8508337 [details]
Flame2.1logcat.txt
(Reporter)

Comment 3

3 years ago
Bug Link to Failed Test case: https://moztrap.mozilla.org/manage/case/14716/
(Reporter)

Updated

3 years ago
Summary: [2.1][l10n][Component] Danish: Conference call header text is truncated → [2.1][l10n][Dialer] Danish: Conference call header text is truncated
Seems like instead of seeing the "..." there could just be the last missing letter "e"
Flaggin UX to see if this is something they can fix? thanks
Flags: needinfo?(firefoxos-ux-bugzilla)
Duplicate of this bug: 1086699
Happens on multiple locales with longer strings (Serbian Cyrillic is one of them). Changing title to reflect this
Summary: [2.1][l10n][Dialer] Danish: Conference call header text is truncated → [2.1][l10n][Dialer] Multiple locales: Conference call header text is truncated
Blocks: 1074053
No longer blocks: 1085589
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 7

3 years ago
Truncation is not ideal but is technically acceptable (unless it does not make sense in the stated language). Also flagging Przemek to see if this is something we can handle in header size/layout.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(pabratowski)
This doesn't look this it's using the header web component, it's a unique control. I'm not sure if using a header would work with this design, forwarding this issue to the owner of the caller app. 

+ Carol
Flags: needinfo?(pabratowski) → needinfo?(chuang)

Comment 9

3 years ago
The top part showing "Conference(2)" is not the header.
and yes, the text is supposed to be '...' if it's too long.

I don't think it's a big issue that "Gruppesamtale" got truncated because once you click on "Gruppesamtal...", you can see the list of people in the group.
Thanks!
Flags: needinfo?(chuang)

Comment 10

2 years ago
We've stopped shipping Firefox OS for phones. Thus resolving this as WONTFIX.

Thank you for testing and reporting.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.