Closed Bug 1085738 Opened 5 years ago Closed 4 years ago

Homescreen overlays over Settings App

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.1-bug-bash])

Attachments

(1 file)

Attached image 2014-10-20-16-55-55.png
Flame, while running:

Found device
Gaia   2904ab80816896f569e2d73958427fb82aebaea5
SourceStamp 12dc9b782f2a
BuildID 20141020001201
Version 34.0
Base image: v188
Full flash

STR:
1. Unsure - see attached screenshot where the Homescreen overlays the Settings app. In this state the screen is able to be scrolled.

Seen by both myself and Parul using today's build and v188 base. Adding qawanted for further investigation. Have not yet been able to reproduce.
tchung mentioned this was seen a while back as Bug 1028318, but the bug it is duped to leads to a trail of a bug that was resolved fixed. For qawanted let's see if the steps in those two bugs lead us to a better repro rate.
Keywords: regression
Marcia,
   I was not able to get the homescreen icons to appear on the settings app but following your direction to use steps from those other bugs, I was able to get the Rocketbar Icons on top of the settings app. So hopefully you can work off this information.

Prerequisite: 
1. Reboot the device.
2. any app running in the background. (contacts, settings, messages etc.)
STR:
1. Quickly tap on the app you have running in the background then quickly tap on the rocketbar.
3. You may see a blue caret icon in the top left corner of the screen.
4. A keyboard should pop up and if you type a letter on the keyboard, icons from the rocketbar will appear on top of the app window.

Repro Rate: 5/5 IF the keyboard appears and you type a letter on the keyboard.

Tested with Full Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141022184714
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

------------------------------------------------------------------
------------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141023073622
Gaia: 4f7d614e65622297e715a3a3ca22f03e738183be
Gecko: e0aa2b65d02b
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Flags: needinfo?(mozillamarcia.knous)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
I was able to reproduce this issue with a 100% repro rate using the following STR:

1) Type anything in the rocketbar
2) Tap the home button
3) Open any app (or stay on the homescreen), and double tap on the rocket bar

Actual: The E.me apps will appear over whatever is in the foreground

qawanted for branch checks
Keywords: qawanted
I hit this on 2.1 today during the bug bash, but not sure how i got it.  stil need to debug this and figure out what happened.  i was on a build from 10/23, v188 base image.
Whiteboard: [2.1-bug-bash]
I actually think the Rocketbar icons could be a different bug than the homescreen icons. Has anyone been able to reproduce what I have in the screenshot - the homescreen apps being shown over settings and able to be scrolled?
Flags: needinfo?(mozillamarcia.knous)
Since I'm unable to get this bug to occur. I'm unassigning myself as QA Contact to allow others to check on this and try to get steps.

I see people saying the have gotten homescreen icons on top of other apps but nobody has provided any direction to look at other than a screenshot and to reference other bugs. We've tried the steps in the related bugs but that has only let to the rocketbar problem which is a different issue. 

If anyone sees this please put what you were doing at the time. This would give us some idea what may have been involved.
QA Contact: croesch
I am unable to reproduce this issue after an hour of trying.  Leaving the tag for another to try.
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
Unable to reproduce this issue.  I was unable to reproduce the homescreen icons overlapping an opened application.   

Repro attempts: 0/25

Device: Flame 2.1
BuildID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
I'm unable to reproduce this issue after on hour of trying either. I mimicked the setup from comment 0's screenshot and played around it with no repro. Removing qawanted tag due to inability to repro from multiple parties including bug reporter.

Device: Flame 2.1
BuildID: 20141020001201
Gaia: 2904ab80816896f569e2d73958427fb82aebaea5
Gecko: 12dc9b782f2a
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.