Closed Bug 1085810 Opened 6 years ago Closed 6 years ago

[System::Keyboard] Keyboard is not hidden when custom dialog is shown in system app

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: sharaf.tir, Assigned: rudyl)

Details

(Whiteboard: [LibGLA, TD-112690, QE03, B])

Attachments

(2 files)

Precondition: In "Device A" BT is enabled and paired with "Device B"

STR:

1) In "Device A" Open contact app, select new contact, focus on name field. Keyboard will be shown
2) from "Device B" share some file.
3) in "Device A" BT file transfer confirmation notification will be shown, tap on that.

Expected behavior:
The keyboard is hidden and we can see the BT transfer confirmation dialog.

Actual behavior:
The keyboard is not hidden
ni? to Ian Liu for his comments
Flags: needinfo?(iliu)
Whiteboard: [LibGLA, TD-112690, QE03, B]
Hi Rudy, would you please kindly look into the issue ?

Thanks!
Flags: needinfo?(rlu)
I cannot reproduce this issue with v2.1 as Device A (the receiving part).

==
Gaia-Rev        3d9cc667f4e929861a9a77c41096bbf5a9c1bde0
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/928b18f7d8ff
Build-ID        20141021161205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141020.191459
FW-Date         Mon Oct 20 19:15:10 EDT 2014
Bootloader      L1TC10011800

Mark QA wanted for branch check.
Flags: needinfo?(rlu)
Keywords: qawanted
Hi Mike, could you please kindly help test on Flame 2.0 and Flame 2.1 and provide its logcat  ?
Thank you very much !
Flags: needinfo?(mlien)
I'm not able to reproduce the issue with following build version. Looks like keyboard is hidden normally after clicked on notification toast.

Gaia-Rev        4d7f051cede6544f4c83580253c743c22b0cb279
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ae4d9b4ff2ee
Build-ID        20141021230530
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141022.022512
FW-Date         Wed Oct 22 02:25:30 EDT 2014
Bootloader      L1TC10011800
Flags: needinfo?(iliu)
Attached file logcat.log
v2.0 can reproduce this problem
Gaia-Rev        ec722129a962704fda0dd5f39e7efd01261ae946
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/52280df0e39f
Build-ID        20141022160205
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141022.203951
FW-Date         Wed Oct 22 20:40:02 EDT 2014
Bootloader      L1TC10011880
Flags: needinfo?(mlien)
Hi Rudy, Could you please kindly check the issue happening on 2.0 ? looks like we fixed the issue on 2.1.
Or do you suggest QA bisect to find the useful patch for it ? 
Thank you very much !
Flags: needinfo?(rlu)
Attached file Patch V1
[Root Cause]
on v2.0, clicking on the notification toast would not get the focus, because of we do preventDefault in mousedown handler.
after v2.1, I suspect this has been changed by this bug, Bug 1041383.

[Solution]
(Uplifting Bug 1041383 to v2.0 should not be a feasible solution, because that is a feature bug.)

Hide the keyboard when receiving 'notification-clicked' event.
This solution should go to master as well, because it also fixes the following case,
  - Drag down the utility tray and then click the notification of bluetooth transfer.

Alive, could you help take a look at this approach?
Thanks.
Attachment #8510199 - Flags: review?(alive)
Assignee: nobody → rlu
Component: Gaia::System → Gaia::System::Input Mgmt
Comment on attachment 8510199 [details] [review]
Patch V1

r+ if the console.log is removed
Attachment #8510199 - Flags: review?(alive) → review+
master,
https://github.com/mozilla-b2g/gaia/commit/0bd1503f7f4e4ce1cced59434f9a6c4dee22b47f

--
Alive, thanks for the review.

--
Change the status of v2.1 to affected for the following case,
 - Drag down the utility tray and then click the notification of bluetooth transfer.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Issue is verified fixed Flame 2.2 (Full Flash, nightly) 

Actual Results: The keyboard will hide correctly when user receives and taps on bluetooth transfer notification, or utility tray is pulled down while keyboard is up in Contacts app. 

Device: Flame 2.2
BuildID: 20141104040207
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: 54d05732f29b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
-----------------------------------------------------------------
I am unable to reproduce this bug on Flame 2.1 (Full Flash, nightly). 

Actual Results: Tapping on transfer notification or pulling down the utility tray to view/tap on the notification, the keyboard hides correctly and does not cause UI to malfunction. 

Device: Flame 2.1
BuildID: 20141104001202
Gaia: 8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko: 388b03efe92d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
-----------------------------------------------------------------
Issue DOES occur in Flame 2.0 (Full Flash, nightly). 

Actual Results: Tapping on transfer notification or pulling down the utility tray to view/tap on the notification causes keyboard to remain up, thus, UI malfunctions. 

Device: Flame 2.0
BuildID: 20141104000201
Gaia: fe2167fa5314c7e71c143a590914cbf3771905a8
Gecko: 241e51806687
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.