switch over to PRPackedBool where possible

RESOLVED DUPLICATE of bug 695256

Status

defect
RESOLVED DUPLICATE of bug 695256
18 years ago
7 years ago

People

(Reporter: sspitzer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

switch over to PRPackedBool where possible

alecf writes:

"it's just a PRBool that's only 1 byte large (instead of 4 bytes)
its in prtypes.h I think.  the trick is that if you put it in a struct or a
class (i.e. nsMsgFolder). you should put all the PRPackedBools next to each
other in the declarations"
for a sample of how powerful this can be, check out bug 108597
alecf suggested that we get a bloat log, look for which objects we create a lot 
of, and and then start fixings those first.

these would be good to start with:

./addrbook/src/nsAbCardProperty.h:	PRBool   m_bIsMailList;
./db/msgdb/public/nsMsgHdr.h:    PRBool m_recipientsIsNewsgroup;
./db/msgdb/public/nsMsgThread.h:  PRBool m_cachedValuesInitialized;


Status: NEW → ASSIGNED
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9.7
cc'ing naving who is working on footprint also.
Keywords: nsbeta1+
Target Milestone: mozilla0.9.7 → mozilla0.9.8
bienvenu has pointed out that this don't make sense in all cases.

for example, it makes the most sense when you've got a structure with several 
boolean members.

moving to 1.0, this can wait.  we can audit our code later.
Target Milestone: mozilla0.9.8 → mozilla1.0
moving to 1.0.1, none of these are 1.0 blockers.
Target Milestone: mozilla1.0 → mozilla1.0.1
not needed for nsbeta1, this can wait.
Keywords: nsbeta1+nsbeta1-
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Status: ASSIGNED → NEW
Filter on "Nobody_NScomTLD_20080620"
QA Contact: esther → backend
Product: Core → MailNews Core
Target Milestone: mozilla1.0.1 → ---
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 695256
You need to log in before you can comment on or make changes to this bug.