Text not truncated with ellipsis

RESOLVED INVALID

Status

()

Core
Layout: Text
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Mattias Östergren, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Precondition
http://jsbin.com/dibipuyoce/ is accessible.

Please  note that the step-by-step is reproducible on Firefox nightly desktop browser (36.0a1) and FFOS 2.1 (tested on Flame/34.0a2 20141001125143).
Chrome (38.0.2125.101 m) and Firefox browser (32.0.3 & 33.0) works.

Step-by-step
1. On your (Windows) desktop computer, open the link in Chrome (or Firefox Stable).
2. What you now see on your screen is a correct rendering of the page i.e. the expected behavior. Text is truncated with ellipsis.
3. Next, open the same link in Firefox Nightly. Or open the link in FFOS 2.1 browser app.
4. The page is rendered differently - text is not truncated with ellipsis.
Jet, is this the right component, or is there a better place for it?
Flags: needinfo?(bugs)

Comment 2

3 years ago
John: This one's reported to be a recent regression. Can you have a look?
Component: CSS Parsing and Computation → Layout: Text
Flags: needinfo?(bugs) → needinfo?(jdaggett)
Looks like a change in flexbox layout.
Flags: needinfo?(jdaggett) → needinfo?(dholbert)
We're doing what the spec calls for here -- this is an expected result of bug 1015474.  This is a relatively recent spec change, which is why Chrome doesn't match us on it (yet).

Basically: flex items will refuse to shrink below their minimum intrinsic width, unless you explicitly specify "min-width" or "width" or "max-width" on them.

You get the expected result if you add "min-width: 0;" to the rule for .row .column.
Blocks: 1015474
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(dholbert)
Resolution: --- → INVALID

Comment 5

3 years ago
Thanks, Mats and Daniel!
Resolution: INVALID → FIXED

Updated

3 years ago
Resolution: FIXED → INVALID
Duplicate of this bug: 1098165
Duplicate of this bug: 1108514
You need to log in before you can comment on or make changes to this bug.