java.io.IOException: Failed to extract workspace.tar.gz

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
5 months ago

People

(Reporter: andrei, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
Seems we failed to extract the workspace archive,
> java.io.IOException: Failed to extract workspace.tar.gz
which seems to have been caused by:
> java.io.EOFException: Unexpected end of ZLIB input stream

Most likely explanation is that the file was not completely downloaded from master, resulting in a corrupt tarball.


Complete log:
> 03:02:20 Started by user anonymous
> 03:02:20 [EnvInject] - Loading node environment variables.
> 03:02:20 Building remotely on mm-ub-1310-32-4 (13.10 ubuntu linux 32bit) in workspace jenkins/workspace/release-mozilla-beta_remote
> 03:02:20 
> 03:02:21 Deleting project workspace... done
> 03:02:21 
> 03:02:21 Restoring workspace from build #122165 of project get_mozmill-tests
> 03:02:21 java.io.IOException: remote file operation failed: jenkins/workspace/release-mozilla-beta_remote at hudson.remoting.Channel@1bcb88e:mm-ub-1310-32-4
> 03:02:21  at hudson.FilePath.act(FilePath.java:910)
> 03:02:21  at hudson.FilePath.act(FilePath.java:887)
> 03:02:21  at hudson.FilePath.untar(FilePath.java:473)
> 03:02:21  at hudson.plugins.cloneworkspace.CloneWorkspacePublisher$WorkspaceSnapshotTar.restoreTo(CloneWorkspacePublisher.java:243)
> 03:02:21  at hudson.plugins.cloneworkspace.CloneWorkspaceSCM$Snapshot.restoreTo(CloneWorkspaceSCM.java:383)
> 03:02:21  at hudson.plugins.cloneworkspace.CloneWorkspaceSCM.checkout(CloneWorkspaceSCM.java:149)
> 03:02:21  at hudson.model.AbstractProject.checkout(AbstractProject.java:1414)
> 03:02:21  at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:671)
> 03:02:21  at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
> 03:02:21  at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:580)
> 03:02:21  at hudson.model.Run.execute(Run.java:1684)
> 03:02:21  at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
> 03:02:21  at hudson.model.ResourceController.execute(ResourceController.java:88)
> 03:02:21  at hudson.model.Executor.run(Executor.java:231)
> 03:02:21 Caused by: java.io.IOException: Failed to extract workspace.tar.gz
> 03:02:21  at hudson.FilePath.readFromTar(FilePath.java:2089)
> 03:02:21  at hudson.FilePath.access$200(FilePath.java:172)
> 03:02:21  at hudson.FilePath$3.invoke(FilePath.java:475)
> 03:02:21  at hudson.FilePath$3.invoke(FilePath.java:473)
> 03:02:21  at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2462)
> 03:02:21  at hudson.remoting.UserRequest.perform(UserRequest.java:118)
> 03:02:21  at hudson.remoting.UserRequest.perform(UserRequest.java:48)
> 03:02:21  at hudson.remoting.Request$2.run(Request.java:328)
> 03:02:21  at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
> 03:02:21  at java.util.concurrent.FutureTask.run(FutureTask.java:262)
> 03:02:21  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> 03:02:21  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> 03:02:21  at hudson.remoting.Engine$1$1.run(Engine.java:63)
> 03:02:21  at java.lang.Thread.run(Thread.java:745)
> 03:02:21 Caused by: java.io.EOFException: Unexpected end of ZLIB input stream
> 03:02:21  at com.jcraft.jzlib.InflaterInputStream.fill(InflaterInputStream.java:186)
> 03:02:21  at com.jcraft.jzlib.InflaterInputStream.read(InflaterInputStream.java:106)
> 03:02:21  at org.apache.tools.tar.TarBuffer.readBlock(TarBuffer.java:257)
> 03:02:21  at org.apache.tools.tar.TarBuffer.readRecord(TarBuffer.java:223)
> 03:02:21  at hudson.org.apache.tools.tar.TarInputStream.getNextEntry(TarInputStream.java:228)
> 03:02:21  at hudson.FilePath.readFromTar(FilePath.java:2067)
> 03:02:21  ... 13 more
> 03:02:21 Archiving artifacts
> 03:02:21 Email was triggered for: Failure - Any
> 03:02:21 Sending email for trigger: Failure - Any
> 03:02:21 #23203 is still in progress; ignoring for purposes of comparison
> 03:02:21 #23203 is still in progress; ignoring for purposes of comparison
> 03:02:21 Sending email to: mozmill-ci@mozilla.org
> 03:02:22 Finished: FAILURE
How often does that happen? Did a retrigger fixed it? Did we had problems with fetching the mozmill-tests?
Flags: needinfo?(andrei.eftimie)
Btw. I see a failure here:
http://mm-ci-master.qa.scl3.mozilla.com:8080/job/get_mozmill-tests/122153/console

If that corresponds to the build you are referring to please file a mozmill-ci issue. This is not Infrastructure related.
(Reporter)

Comment 3

4 years ago
(In reply to Henrik Skupin (:whimboo) from comment #1)
> How often does that happen? Did a retrigger fixed it? Did we had problems
> with fetching the mozmill-tests?

Only once.
The rebuilt build has not started yet (in queue, the queue is long).

Affected build is: http://mm-ci-master.qa.scl3.mozilla.com:8080/job/release-mozilla-beta_remote/23204/
Flags: needinfo?(andrei.eftimie)
(Reporter)

Comment 4

4 years ago
For tracking, the failed build was rebuilt as: http://mm-ci-master.qa.scl3.mozilla.com:8080/job/release-mozilla-beta_remote/24451/
So the referenced workspace #122165 of get_mozmill-tests has passed. Maybe it would be good to check how that workspace archive looks like:

http://mm-ci-master.qa.scl3.mozilla.com:8080/job/get_mozmill-tests/122165/console
We haven't seen this problem for a while and this continuous pulling of the mozmill-tests repository is history. Lets close this bug as WFM for now. We can reopen if it is happening for other jobs too.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

5 months ago
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.