Status

()

Core
Layout
VERIFIED INVALID
16 years ago
15 years ago

People

(Reporter: Gabriel Bouvigne, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
http://www.mp3-tech.org/gloss/glosa.html

On the top left of this page, I can see a black glitch with 0.9.5.
It seems to be caused by "<span class="glosspage"></span>" near the beginning 
of the HTML code.
You can see that http://www.mp3-tech.org/gloss/glosb.html does not show this 
bug because it doesn't include the same "<span class="glosspage"></span>"

Comment 1

16 years ago
Confirming on 2001102603 Win2k.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Confirming with 2001110516.

But why is this a bug ? Definition is :

.glosspage {  border-color: #000000 black black; color: #000000; border-style:
dashed}

And there is an empty <span> with a dashed border around it.... This is a
problem for the author of the page. If it isn't intended then the <span>-tags
shouldn't be there. It is not a Mozilla problem.
(Reporter)

Comment 3

16 years ago
So you think that an empty <span></span> should apply the style?

We'll I didn't thinked in this case the style should be applied. But if it's 
the case, I sincerely apologise.

Comment 4

16 years ago
http://www.w3.org/TR/html4/struct/global.html#h-7.5.4
states nothing about empty <span>'s.
My guess is that it makes no difference if the tag is empty or contains other
tags or text.

If you want an answer from a CSS/HTML programmer (ie you can rely on =) feel
free to leave this bug open (or ask in #mozilla), otherwise please resolve this
bug invalid.
CSS2 Section 10.8: Empty inline elements generate empty inline boxes, but these
boxes still have margins, padding, borders and a line height, and thus influence
these calculations just like elements with content.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
Thanks Hixie
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.