Default account in mail settings is not working

RESOLVED DUPLICATE of bug 852355

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 852355
3 years ago
3 years ago

People

(Reporter: brg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Tested with Flame v2.0 today build(Gecko-f99214e.Gaia-63b56a7).
STR:
1)Set two mail accounts: Example: one in gmail.com other in hotmail.com
2)Set gmail.com as default mail account
3)Leave mail app opened in the inbox of hotmail.com
4)Go to any other app and share an image by mail
5)The default account choose to send the mail wont be gmail (the one set as default) but the hotmail :-( --> K.O

Expected result:
Composer is open in the default account and mail is sent using it.

Current result:
Composer is wrongly not considering the mail defaul account setting.

Additional info:
If mail app is closed in step 3, then it is working fine.

[Blocking Requested - why for this release]: This a broken feature.
This is working perfect in version 1.3, tested in unagi, build from 20140926.
(In reply to Beatriz Rodríguez [:brg] from comment #0)
> [Blocking Requested - why for this release]: This a broken feature.
> This is working perfect in version 1.3, tested in unagi, build from 20140926.

The current behaviour is how the email app has always operated.  In your test of this on an unagi with v1.3, it seems likely the email app was OOM-killed and re-opened when you triggered the share activity.  (Alternatively, one of the mitigation fixes we uplifted to address black-screen issues may have taken a short-cut that altered our behaviour.  However, when v1.3 branched the behaviour was as it exists on trunk and was intentional, if suboptimal.)

Bug 852355 is the bug to let the user pick the account they are sending from.
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852355
You need to log in before you can comment on or make changes to this bug.