Investigate and fix test_call_log_all_calls intermittent failures

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RobertC, Assigned: RobertC)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

5 years ago
test_call_log_all_calls is failing intermittently on Jenkins and on local device for different reasons.
The test fails intermittently on both v2.2 and v2.1

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/220/HTML_Report/
Assignee

Comment 1

5 years ago
This patch is for the following error:
Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_call_log_all_calls.py", line 64, in test_call_log_all_calls
self.assertEqual(len(call_list), 2)
AssertionError: 1 != 2
Attachment #8511047 - Flags: review?(viorela.ioia)
Attachment #8511047 - Flags: review?(jlorenzo)
Attachment #8511047 - Flags: review?(florin.strugariu)
Assignee

Comment 2

5 years ago
test_call_log_all_calls started failing recently with the errors present in the following adhoc run:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/235/HTML_Report/

The first digit of the plivo phone number is missing in the call log. Where there any changes done recently in the dialer app which might cause this?

We could not reproduce the issue locally.
Flags: needinfo?(tchung)
Flags: needinfo?(gsvelto)
I'm not aware of changes to how we handle the call log that might do this. needinfo'ing :fcampo because he might know more.
Flags: needinfo?(gsvelto) → needinfo?(fernando.campo)
See Also: → 1088756
I found the change we've seen since October 20th, it's the test itself. It has been modified to check incoming call and it was landed at that date (see bug 1075547 comment 3).

Here's the reason why we don't reproduce locally. In the US, carriers don't add a + for domestic calls, not like in Romania, Canada or France. Then, some providers, like AT&T, don't add the country code (1, in our test case) but some do, like T-Mobile. That's also the reason why this test was intermittent.

Hence, we shouldn't check for the country code in our test for now. Also, to explain that, let's put a comment in the code, about country codes and US carriers.

I opened bug 1088756 to ask UX what we should do with country codes in the US.
Blocks: 1075547
Flags: needinfo?(tchung)
Flags: needinfo?(fernando.campo)
Comment on attachment 8511047 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25570

LGTM. Let's just check for the phone number minus the country code, and the patch will be okay to me.
Attachment #8511047 - Flags: review?(jlorenzo) → review-
Assignee

Comment 6

5 years ago
Comment on attachment 8511047 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25570

Removed country code and started an adhoc run:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/240/console
Attachment #8511047 - Flags: review- → review?(jlorenzo)
Comment on attachment 8511047 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25570

Looks good, r+
Attachment #8511047 - Flags: review?(viorela.ioia) → review+
Comment on attachment 8511047 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25570

Tested locally. As a country code can be 3 or 4 digits long, this line (https://github.com/mozilla-b2g/gaia/pull/25497/files#diff-6cf85291d551807eb78eb6e6bfbc6a59R35) might be problematic if another SIM card from another country does not display the country code. But I hope bug 1088756 will fix this issue in the meantime.

R+
Attachment #8511047 - Flags: review?(jlorenzo) → review+
Assignee

Comment 10

5 years ago
Posted file uplift to v2.1
Attachment #8512540 - Flags: review?(viorela.ioia)
Assignee

Updated

5 years ago
Attachment #8511047 - Attachment description: Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25497 → Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25570
Attachment #8511047 - Flags: review?(florin.strugariu)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
QA Whiteboard: [fxosqa-auto-s2]
You need to log in before you can comment on or make changes to this bug.