Lightning and Thunderbird disagree about timezone support in ics files

RESOLVED FIXED in 4.0.0.1

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED FIXED
3 years ago
2 months ago

People

(Reporter: Ian, Assigned: MakeMyDay)

Tracking

Lightning 3.3
4.0.0.1
x86
All
Dependency tree / graph

Details

Attachments

(13 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8508714 [details]
Attached Message Part.ics

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

A mail message with an attached ics file is displayed correctly when lightning is installed. However, adding that meeting to the calendar results in a timezone issue.

- Send the attached ics files to yourself.
- View the message in Thunderbird (with Lightning installed)


Actual results:

- The correct time is shown in the Thunderbird preview window (timezone is accepted).
- Accepting the event and adding it to your calendar shows wrong time (timezone is not accepted).


Expected results:

Adding the event should use the same method for interpreting the timezone information as the preview (also provided by Lightning). The correct time should be on the appointment.

Updated

3 years ago
Component: General → E-mail based Scheduling (iTIP/iMIP)
Product: Thunderbird → Calendar
Version: 31 → Lightning 3.3
(Assignee)

Updated

3 years ago
Attachment #8508714 - Attachment mime type: text/calendar → text/plain
(Assignee)

Comment 1

3 years ago
Ian, can you please confirm your Thunderbird/Lightning version and also provide any message from the error console (strg+shift+j) if any while reproducing the issue?
(Reporter)

Comment 2

3 years ago
The latest release. I updated (multiple times) to ensure that I was on the latest release prior to reporting. For the record those are:

Thunderbird 31.2.0
Lightning 3.3.1

Error log shows the following:

[JavaScript Error: "Unknown timezone "Eastern Standard Time" in "Audit Outcome Meeting:  MK-0431, PN 082 TECOS, Dr. Joanna Niegowska - Warsaw, Poland".  Treated as 'floating' local timezone instead: 6 May 2014 09:00
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VEVENT
LAST-MODIFIED:20141023T152709Z
DTSTAMP:20141023T152709Z
UID:040000008200E00074C5B7101A82E00800000000905A06FA594ECF0100000000000000
 00100000008FF1127CCD0BF54DBC80AB445E6C4F68
SUMMARY:Audit Outcome Meeting:  MK-0431\, PN 082 TECOS\, Dr. Joanna Niegow
 ska - Warsaw\, Poland
PRIORITY:5
STATUS:CONFIRMED
ORGANIZER;CN=Kraig Finger;EMAIL=kraig_finger@merck.com;SCHEDULE-AGENT=CLIE
 NT:urn:uuid:490F4EA7-5B45-4EF1-A00D-7AA92F4FA767
ATTENDEE;RSVP=TRUE;CN=Samuel Engel;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIP
 ANT;EMAIL=samuel_engel@merck.com:urn:uuid:01282C4A-6884-43D2-9DB7-909D5FA9
 9D38
ATTENDEE;RSVP=TRUE;CN="Triolo, Christine C.";PARTSTAT=NEEDS-ACTION;ROLE=RE
 Q-PARTICIPANT:mailto:christine_triolo@merck.com
ATTENDEE;RSVP=TRUE;CN=Micki Blair;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIPA
 NT;EMAIL=micki_garee@merck.com:urn:uuid:818F140D-5BD3-4A5C-A5E2-D39298595D
 15
ATTENDEE;RSVP=TRUE;CN=Angela Gee;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIPAN
 T;EMAIL=angela_gee@merck.com:urn:uuid:80AB8A7C-9162-4B28-8084-06347C879E64
 
ATTENDEE;RSVP=TRUE;CN="Henry, Karen L (RAI)";PARTSTAT=NEEDS-ACTION;ROLE=RE
 Q-PARTICIPANT:mailto:karen_l_henry@merck.com
ATTENDEE;RSVP=TRUE;CN=Karen Hannan;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIP
 ANT;EMAIL=karen.hannan@duke.edu:urn:uuid:3EAEB8D3-42BC-48E6-B219-B539567CA
 C4B
ATTENDEE;RSVP=TRUE;CN=Tyrus Rorick;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIP
 ANT;EMAIL=tyrus.rorick@duke.edu:urn:uuid:FC7C4B25-9A38-4BE4-8B7C-97939BE0D
 7C0
ATTENDEE;RSVP=TRUE;CN=Joanne Milton;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICI
 PANT;EMAIL=joanne.milton@dtu.ox.ac.uk:urn:uuid:3EFAC609-D8D6-4635-9226-8B5
 75F22635F
ATTENDEE;RSVP=TRUE;CN="Williams, Steven";PARTSTAT=NEEDS-ACTION;ROLE=REQ-PA
 RTICIPANT:mailto:steven.williams@merck.com
ATTENDEE;RSVP=TRUE;CN="Degennaro-Culver, Frances";PARTSTAT=NEEDS-ACTION;RO
 LE=REQ-PARTICIPANT:mailto:frances.degennaro-culver@merck.com
ATTENDEE;RSVP=TRUE;CN=Dianne Leloudis;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTI
 CIPANT;EMAIL=dianne.leloudis@duke.edu:urn:uuid:A425CA77-2BEA-450A-BFF1-ACC
 77E4F785C
ATTENDEE;RSVP=TRUE;CN=Sarah Hayden;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIP
 ANT;EMAIL=sarah.hayden@duke.edu:urn:uuid:10CADA9D-82FA-4BB6-8919-B6BDBAE0E
 D4F
ATTENDEE;RSVP=TRUE;CN=Nicoletta Colombo;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PAR
 TICIPANT;EMAIL=nicoletta.colombo@parexel.com:urn:uuid:DE7A131D-E615-4E65-A
 F5B-5F7C10B0220B
ATTENDEE;RSVP=TRUE;CN=Gonny Sombroek;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTIC
 IPANT;EMAIL=gonny.sombroek@parexel.com:urn:uuid:E784607C-2B2A-44EC-9BA5-97
 B3D41326E1
ATTENDEE;RSVP=TRUE;CN="'VanDevender, Don'";PARTSTAT=NEEDS-ACTION;ROLE=REQ-
 PARTICIPANT:mailto:Don.VanDevender@parexel.com
ATTENDEE;RSVP=TRUE;CN="Kleczar-Domanska, Elzbieta";PARTSTAT=NEEDS-ACTION;R
 OLE=REQ-PARTICIPANT:mailto:elzbieta_kleczar@merck.com
ATTENDEE;RSVP=TRUE;CN="'Muschel, Isabell'";PARTSTAT=NEEDS-ACTION;ROLE=REQ-
 PARTICIPANT:mailto:Isabell.Muschel@parexel.com
ATTENDEE;RSVP=TRUE;CN=Mateu Guylaine;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTIC
 IPANT;EMAIL=guylaine.mateu@parexel.com:urn:uuid:F73AA0A2-F82E-454D-AD34-DA
 2D99E9259B
ATTENDEE;RSVP=TRUE;CN="Boezer, JC (Jaap)";PARTSTAT=NEEDS-ACTION;ROLE=REQ-P
 ARTICIPANT:mailto:jaap.boezer@merck.com
ATTENDEE;RSVP=TRUE;CN="Zwol van, M (Mario)";PARTSTAT=NEEDS-ACTION;ROLE=REQ
 -PARTICIPANT:mailto:mario.vanzwol@merck.com
ATTENDEE;RSVP=TRUE;CN="Ouwerkerk, MJA (Mathieu)";PARTSTAT=NEEDS-ACTION;ROL
 E=REQ-PARTICIPANT:mailto:mathieu.ouwerkerk@merck.com
ATTENDEE;CN=Ian Kennedy;PARTSTAT=TENTATIVE;ROLE=REQ-PARTICIPANT;EMAIL=ian.
 kennedy@dtu.ox.ac.uk:urn:uuid:8FB51B57-154B-4BD1-83FA-B37D32B29F6A
DTSTART;TZID=Eastern Standard Time:20140506T090000
DTEND;TZID=Eastern Standard Time:20140506T100000
CLASS:PUBLIC
DESCRIPTION;LANGUAGE=en-US:Meeting has been rescheduled due to bank holida
 y schedule in Europe.  My apologies for this oversight.\n\nP.S.  Directed 
 Audit is currently scheduled for 14-18Apr-2014.\n\nKind Regards\,\nKraig\n
 \n________________________________________________________________________
 __________________________________________________________________________
 __________________________\n\nThis meeting has been scheduled to discuss t
 he results of the directed audit at Dr. Niegowska’s site for the TECOS s
 tudy.\n\nThis was the best available time slot to host the meeting.  If fo
 r some reason you cannot attend\, please identify a suitable delegate.\n\n
 Kind Regards\,\nKraig\n\n\n******* DO NOT DELETE OR CHANGE ANY OF THE TEXT
  BELOW THIS LINE *******\n\n----------------------------------------------
 -------------------------\nJOIN USING WebEx\n\nGo To:\nhttps://merck.webex
 .com/merck/j.php?J=747886606\n\nMeeting Password ----- This meeting does n
 ot require a password.\nMeeting Number ----- 747 886 606\n\n--------------
 ----------------------------------------------------------\nAUDIO CONNECTI
 ON\nProvide your phone number when you join the meeting to receive a call 
 back. Alternatively\, you can call:\nCall-in toll-free number: 1-866-24610
 76  (US)\nCall-in number: 1-224-3572872  (US)\nShow global numbers: https:
 //www.tcconline.com/offSite/OffSiteController.jpf?cc=5543207904\nConferenc
 e Code: 554 320 7904\n\n\n------------------------------------------------
 ------------------------\n\nIMPORTANT NOTICE: This WebEx service includes 
 a feature that allows audio and any documents and other materials exchange
 d or viewed during the session to be recorded. By joining this session\, y
 ou automatically consent to such recordings. If you do not consent to the 
 recording\, discuss your concerns with the meeting host prior to the start
  of the recording or do not join the session. Please note that any such re
 cordings may be subject to discovery in the event of litigation.\n\nhttp:/
 /www.webex.com\n\n\n\n
LOCATION;LANGUAGE=en-US:Teleconference
SEQUENCE:1
TRANSP:OPAQUE
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-APPT-SEQUENCE:1
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-OWNERAPPTID:721569758
X-MOZ-RECEIVED-DTSTAMP:20140402T171118Z
X-MOZ-RECEIVED-SEQUENCE:1
END:VEVENT
END:VCALENDAR
"]
(Reporter)

Comment 3

3 years ago
Created attachment 8510374 [details]
Images of how it looks in Thunderbird
(Reporter)

Comment 4

3 years ago
Created attachment 8510375 [details]
Images of how it looks in Lightning
(Reporter)

Comment 5

3 years ago
ps. This is not Mac specific it also happens on Windows.
(Reporter)

Updated

3 years ago
OS: Mac OS X → All
(Assignee)

Comment 6

3 years ago
Do you have calendar.icaljs enabled? (->menu->options->options->advanced->config editor)
(Reporter)

Comment 7

3 years ago
First I couldn't find that menu is either Mac or Windows. Neither has a Options menu.

I did look find Menu->Tools->Options->Advanced->Config Editor... on Windows.

I also found Menu->Thunderbird->Preferences->Advanced->Config Editor... on Mac

I'm assuming that is what you are talking about.

Searching for calendar.icaljs on Windows shows it and it is disabled.
Searching for calendar.icaljs on Mac doesn't show anything.
(Reporter)

Comment 8

3 years ago
Ah, on Mac Lightning was not enabled. Once enabled I do find calendar.icaljs and it is disabled.
(Reporter)

Comment 9

3 years ago
Enabling or disabling this item on Windows does not correct this issue. The same on Mac. Calendar gets wrong time zone when event is added, however, the preview in the message pane has the correct time zone.
(Assignee)

Comment 10

3 years ago
A timezone definition is missing in the event in the error message, which seems to the one processed by Lighnting. Based on the attached ics, it has been in the orignal event, so it have beendropped by Lightning while processing. Assumingly, this happened because the TZ is not in Olson format. This should be handled more gracefully.
(Reporter)

Comment 11

3 years ago
Given that the preview of the calendar file that appears in the body of the message is provided by Lightning it would appear that two parts of the plug-in operate in different ways when provided with the exact same data. Please can someone mark this as confirmed as I obviously can't do that. Also I would like to see this block future releases of Lightning as it's pretty fundamental flaw that make it pretty useless as a product. The original iCal file originated from Exchange which is a pretty common source for these types of attachment.
(Assignee)

Comment 12

3 years ago
What type of calendar did you use for storing this event in Lightning (Local, CalDAV, ICS, Google Provider)? I probably would need an invitation for digging into this. Can you send one to me - you obviously have access to an account on this Exchange-Server.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 13

3 years ago
The calendar was stored in a CalDav server on a Mac OS X server. I do not have access to an Exchange server, I am the recipient not the provider. I have attached the original ics file to this bug report.
(Assignee)

Comment 14

3 years ago
Thanks, I just checked this with your ics and a local calendar with the same result. We definitely must preserve the vtimezone component.
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Assignee: nobody → makemyday
(Reporter)

Comment 15

3 years ago
As I said previously the part of Lightning that shows the preview in Thunderbird already deals with the ics file perfectly, it's just the part that adds the info to the calendar that doesn't. I would suggest that you compare the two parts.

Comment 16

3 years ago
I am experiencing a similar error.

My calendar is synchronized via CalDav and some people are using Outlook

Thunderbird 31.3.0
Lightning 3.3.2

I recieve the following error

[JavaScript Error: "Unknown timezone "W. Europe Standard Time" in "Allgemeine Infrastukturthemen".  Treated as 'floating' local timezone instead: Thu 25 Mar 2010 16:30
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Berlin
X-LIC-LOCATION:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20100325T062326Z
LAST-MODIFIED:20110218T100023Z
DTSTAMP:20101230T105620Z
UID:040000008200E00074C5B7101A82E0080000000060B34FC8EBCBCA0100000000000000
 001000000091242D4741CFC34597F3C83D5D1ECEA7
SUMMARY: [snip]
PRIORITY:5
ORGANIZER;CN=[snip]
ATTENDEE;CN=[snip]
ATTENDEE;CN=[snip]
ATTENDEE;CN=[snip]
EXDATE:20100916T163000
EXDATE:20100923T163000
EXDATE:20101111T163000
EXDATE:20101230T163000
RRULE:FREQ=WEEKLY;COUNT=48;BYDAY=TH
DTSTART;TZID=W. Europe Standard Time:20100325T163000
DTEND;TZID=Europe/Berlin:20100325T170000
CLASS:PUBLIC
LOCATION: [snip]
SEQUENCE:0
TRANSP:OPAQUE
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-DISALLOW-COUNTER:FALSE
X-MS-OLK-ALLOWEXTERNCHECK:TRUE
X-MS-OLK-APPTLASTSEQUENCE:0
X-MS-OLK-AUTOSTARTCHECK:FALSE
X-MS-OLK-CONFTYPE:0
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:Reminder
END:VALARM
END:VEVENT
END:VCALENDAR
"]

The only problem from this are the annoying pop-ups that appear every 30 seconds to remind me of this problem. Would be great if they could be disabled somehow.
(Assignee)

Comment 17

3 years ago
Niklas, in your case this is not the same issue. DTSTART in your event is referencing a timezone not defined in the event, so a fallback is the correct behaviour here. If you are the organizer of the event, open the event and edit the timezone to Europe/Berlin. However, if your Caldav server is sending serverside invitations, this may lead to spam the attendees with updates on this old event.

Comment 18

3 years ago
(In reply to MakeMyDay from comment #17)
> Niklas, in your case this is not the same issue. DTSTART in your event is
> referencing a timezone not defined in the event, so a fallback is the
> correct behaviour here. If you are the organizer of the event, open the
> event and edit the timezone to Europe/Berlin. However, if your Caldav server
> is sending serverside invitations, this may lead to spam the attendees with
> updates on this old event.

Thank you MakeMyDay! Unfortunately I am not the author of the event. Is there any way to catch this events? Or at least suppress the error pop-up? That would be really great.
(Assignee)

Comment 19

3 years ago
That depends on what popups you get. Are this reminders or error popups?

Can you please enable calendar.debug.lig, calendar.debug.log.verbose and javascript.option.showInConsole in config editor and post what you have in the error console (ctrl+shift+j) when reproducing?
(Assignee)

Comment 20

3 years ago
debug.lig->debug.log

Comment 21

3 years ago
The notification popup says "Timezone Error":"See Error Console: Unknown timezone ..."

My thunderbird is synchronizing with a ownCloud server using calDav.

A great number of the following short entries appear in the log (and after enabling debug messages):

CalDAV: skipping item with unmodified etag : "9a33b4cad93e149db956454d313ccdac"

followed by several big entries as following:

Timestamp: 20.01.2015 11:06:38
Error: Unknown timezone "W. Europe Standard Time" in "[snip: title]".  Treated as 'floating' local timezone instead: Wed 30 May 2007 13:30
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Berlin
X-LIC-LOCATION:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20070524T090503Z
LAST-MODIFIED:20090505T112526Z
DTSTAMP:20070524T090243Z
UID:040000008200E00074C5B7101A82E00800000000F0CA7D0DF39DC70100000000000000
 0010000000346E3CF354E30048B23D541AB86207B8
SUMMARY:IP-PALM: [snip: title again]
PRIORITY:5
ORGANIZER;CN=[snip: name, mail]
ATTENDEE;CN=[snip: name]:invalid:nomail
ATTENDEE;CN=[snip: name]:invalid:nomail
ATTENDEE;CN=[snip: name]:invalid:nomail
ATTENDEE;CN=[snip: name]:invalid:nomail
ATTENDEE;CN=[snip: name];ROLE=OPT-PARTICIPANT:invalid:nomail
ATTENDEE;CN=[snip: name];ROLE=OPT-PARTICIPANT:invalid:nomail
ATTENDEE;CN=[snip: name];ROLE=OPT-PARTICIPANT:invalid:nomail
ATTENDEE;CN=[snip: name];ROLE=OPT-PARTICIPANT:invalid:nomail
RRULE:FREQ=WEEKLY;COUNT=6;BYDAY=WE
DTSTART;TZID=W. Europe Standard Time:20070530T133000
DTEND;TZID=Europe/Berlin:20070530T143000
CLASS:PUBLIC
DESCRIPTION: [snip: full text]
LOCATION:T-Labs: [snip: location string]
SEQUENCE:0
TRANSP:OPAQUE
X-ALT-DESC;FMTTYPE=text/html:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//
 EN">\n<HTML>\n<HEAD>\n<META NAME="Generator" CONTENT="MS Exchange Server v
 ersion 14.02.5004.000">\n<TITLE></TITLE>\n</HEAD>\n<BODY>\n<!-- Converted 
 from text/plain format -->[snip: description]</BODY>\n</HTML>
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-DISALLOW-COUNTER:FALSE
X-MS-OLK-ALLOWEXTERNCHECK:TRUE
X-MS-OLK-APPTLASTSEQUENCE:0
X-MS-OLK-AUTOSTARTCHECK:FALSE
X-MS-OLK-CONFTYPE:0
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:Reminder
END:VALARM
END:VEVENT
END:VCALENDAR

a second example foolows

Timestamp: 20.01.2015 11:13:58
Error: Unknown timezone "W. Europe Standard Time" in "[snip: title]".  Treated as 'floating' local timezone instead: Wed 24 Oct 2007 14:00
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Berlin
X-LIC-LOCATION:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20071112T083726Z
LAST-MODIFIED:20090505T112533Z
DTSTAMP:20131213T153435Z
UID:040000008200E00074C5B7101A82E0080000000040CFA9A70F25C80100000000000000
 00100000009610DDC63F6CC34FB73856D7C5D194AF
SUMMARY:[snip: title]
PRIORITY:5
RRULE:FREQ=WEEKLY;COUNT=34;BYDAY=WE,TH
DTSTART;TZID=W. Europe Standard Time:20071024T140000
DTEND;TZID=Europe/Berlin:20071024T160000
CLASS:PUBLIC
LOCATION:[snip: location]
SEQUENCE:0
TRANSP:TRANSPARENT
X-MICROSOFT-CDO-BUSYSTATUS:FREE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-DISALLOW-COUNTER:FALSE
X-MS-OLK-ALLOWEXTERNCHECK:TRUE
X-MS-OLK-APPTLASTSEQUENCE:0
X-MS-OLK-CONFTYPE:0
END:VEVENT
END:VCALENDAR

Is there anything you can see in those? The thing is I won't be able to change settings on the server side. Plus those errors are, as far as I see, not causing any problems apart from the annoying pop-ups.
(Reporter)

Comment 22

2 years ago
Any chance of progress on this as it is causing a riot. Basically we're on the verge of being pushed into moving to Outlook/Exchange. Fixing this would help a lot.
(Reporter)

Comment 23

2 years ago
Just a reminder, Lightning shows the event and timezone perfectly when it's displayed inline. The information extracted and sent to the server misses the timezone so events are frequently time shifted.
(Assignee)

Comment 24

2 years ago
Sorry, i didn't have time to dig into this. We've had recently some timezone improvements, so can you please check whether this is still an issue with the upcoming major release versions TB38/Ltn 4.0 (currently Aurora channel)?

@Geoff, you currently have your hands on this timezone stuf. Can you take this from me?
Flags: needinfo?(geoff)
This is the same as bug 1135749. What's happening is Lightning doesn't have any concept of "Eastern Standard Time" (Lightning calls it America/New York), so it assumes local time. What should happen in this situation is the timezone info getting extracted from the ICS. We don't do that at present, and it's not an easy thing to fix unfortunately.

@Ian, as a workaround, you can change the timezone of an event in the event's window. There's a menu option called "show timezones". It's a terrible workaround, but it's the best that I know of.

@Philipp, I'd like to add aliases for the four American mainland timezones (any others?) as a temporary fix to reduce the severity of this bug. Any objections?
Flags: needinfo?(geoff) → needinfo?(philipp)
(Reporter)

Comment 26

2 years ago
The issue is that Lightning has a part that knows how to deal correctly with the ics file. The  viewer for the attachment that is provided by lightning shows the correct time. It's only when it's actually added to the cake day that it all goes pair shaped. Two parts of the same product work differently.

Manual work around is tricky as only some of the message require adjustment. As some are generated locally and others in the US. Aliases sound useful, but they would have to also cope wth dst which is now upon us.
(In reply to Ian from comment #26)
> The issue is that Lightning has a part that knows how to deal correctly with
> the ics file. The  viewer for the attachment that is provided by lightning
> shows the correct time. It's only when it's actually added to the cake day
> that it all goes pair shaped. Two parts of the same product work differently.

If it's any consolation I was testing it with a more recent version than the released one, and both parts appear broken now. :/

Comment 28

2 years ago
(In reply to Geoff Lankow (:darktrojan) from comment #25)
> @Ian, as a workaround, you can change the timezone of an event in the
> event's window. There's a menu option called "show timezones". It's a
> terrible workaround, but it's the best that I know of.

There's a another issue here: When you're not the "organizer" of an event, e.g. you've been sent the event information from someone else --which is very much the most common way to end up with non-Olson-time-zone-identifiers-- Lightning will refuse to let you edit the event. You only get to indicate your attendance, but there's no "i know what I'm doing, let me edit it" option to change anything else. So, for the most common occurence of the problem, this workaround unfortunately does not work.
I thought I could reproduce this earlier, but now I can't. Totally confused now.
(In reply to Geoff Lankow (:darktrojan) from comment #25)
> @Philipp, I'd like to add aliases for the four American mainland timezones
> (any others?) as a temporary fix to reduce the severity of this bug. Any
> objections?

Sounds good to me. Please also see this file, we might want to add all those aliases as a temporary workaround. http://mxr.mozilla.org/comm-central/source/calendar/providers/gdata/modules/timezoneMap.jsm

Note however, the mapping is not perfect. If you click on the link where I got that data from, you see that it depends on more than just the name. A great solution would be to add some code that detects the Olson timezone not only from the name but also from the remaining VTIMEZONE data, but that is obviously more than just a workaround.
Flags: needinfo?(philipp)
Depends on: 1149423
(Reporter)

Comment 31

2 years ago
Tried to grab TB38 beta and it doesn't seem to be available. Tried digging into the parent folder and got access denied:

Not Found

The requested URL /pub/mozilla.org/thunderbird/nightly/latest-earlybird/thunderbird-38.0a2.en-US.mac.dmg was not found on this server.
(Reporter)

Comment 32

2 years ago
Sorry, also got TB37beta but it says there isn't a Lightning for that version.
(Assignee)

Comment 33

2 years ago
We had merge day yesterday. Until everything is available on the regular beta channels, you can use:

TB: https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2015-03-30-00-40-10-comm-aurora/
Ltn: https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/2015-03-30-00-40-10-comm-aurora/
(Reporter)

Comment 34

2 years ago
Well now we're into the interesting realms of compatibility. I downloaded the two linked items and it said they were not compatible. I then allowed Thunderbird to update and it said it needed a new Lightning which I allowed it to choose and install. Currently that provides me with TB 39a2 and Lightning 4.1a2. When I start TB (Earlybird) I get the following message:

"The binary component required for Lightning could not be loaded, likely because the wrong version combination is being used. You currently have Lightning 4.1a2 installed, but should be using a version from the 4.1 series."
There's a Lightning beta for Tb 37 here: https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/?page=1#version-3.9b1

I can't reproduce on the beta channel either. I think I must've been mistaken earlier when I thought I'd managed to.
(Reporter)

Comment 36

2 years ago
Nope, it doesn't work with that combo. The event is shown as the correct timezone in the email message but doesn't end up with the correct timezone in the calendar. I also get a message reporting that it couldn't understand the timezone. That is when I try using TB 37.0 beta and Ln 3.9b1. I'm attaching the ics file I used and images of how it is displayed in email and in the event window.
(Reporter)

Comment 37

2 years ago
Created attachment 8586677 [details]
ics file used in Comment 36
(Reporter)

Comment 38

2 years ago
Created attachment 8586678 [details]
TB event preview provided by lightning.png

Image of how Lightning shows a preview of the event (note that it shows the correct time, thus this part of lightning detects and trusts the timezone correctly).
(Reporter)

Comment 39

2 years ago
Created attachment 8586679 [details]
Event result from lightning.png

The resultant event as it appear in lightning, showing that this part of lightning does not agree with the preview part of lightning. Why are these two parts of the same code done differently.
(Reporter)

Comment 40

2 years ago
I think that perhaps the reason you cannot reproduce is because your timezone and the one in the attachment are the same. You need an ics file that does not match your timezone. For example the one I have attached is from east coast USA, while we are located in the UK. Thus when it strips the TZ and adds the message we get a time shift. If the default TZ and the ics file TZ are the same then it doesn't matter if the TZ info is stripped.
I'm in New Zealand, so that's not it.

Going back to comment 13 for a moment: do you always try to add this event to your CalDAV calendar? Have you tried creating a "local" calendar and adding it?

Up until now I've been using a local calendar.
I just tried using a CalDAV connection to my Google Calendar, and the server converted the timezone from EST to America/New York, which Lightning understands. So I wonder if somewhere between Lightning and your server is unable to store the timezone correctly and bails out.

(FWIW, the display in the message pane is created directly from the .ics attachment, whereas anywhere else it's from an event that's been converted to some other form and stored somewhere. That's why a bug would cause a difference.)
(Reporter)

Comment 42

2 years ago
Yes, we tried a local calendar and it didn't work either. Using a local calendar it not an acceptable option, the calendar is shared and has to be accessible to multiple people.

Using Mac Mail and the same server the ics file works a treat. The server is not the problem. Looking at the console log (see comment 2). You can see that Lightning is stripping the timezone definition out of the ics file before sending it to the server.

For a local calendar I can see why that you need to process the file, however, if you are sending it to a calendar server why are you changing the ics file. That's just asking for this sort of problem.

The server is a Mac OS X machine running Mavericks OS X Server (formerly iCal).
(Assignee)

Comment 43

2 years ago
Created attachment 8588467 [details]
Modified_Mail_Attachment_copy.ics

Ian, Geoff, I tried to reproduce the issue once again based on the event attached by Ian related to comment #36. As organizer and attendee information have been removed there, I created new ones to be able to use that event (see attached ics). I tried both, libical and icaljs backend in release version 3.3 and current nightly 4.2.

For icaljs, I got consistently floating time applied everywhere in Lightning (invitation preview, today pane, calendar view) in on both versions. So for icaljs, there's no inconsistency, but in general no timezone applied, which should be resolved preliminary by adding the aliases and finally by using the timezone information provided by the ics as already mentioned by Geoff. (Btw, I think, we should not remove the tz aliasing, once tz evaluation from the ics is implemented, as there are also examples of ics referncing timezones like EST without shipping an according vtimezone in the ics).

For libical, I got timezones consistently applied correctly all over Lighting for both versions, although the event summary dialog displays the time not tranformed in local time but in senders timezone including tz reference. Is that the issue you're expiriencing, Ian?

I'm not quite sure, because your screenshots display the event dialog and not the summary dialog, which is shown for incoming invitations. (I even don't know how you managed to display the event dialog for an incoming invitation...)

That said, this looks to me just like a display issue in the summary dialog and not a backend issue.

Unfortunately, there is currently no way to switch between displaying datetime with tz information and converting to effective local time as this is available for the event dialog. Eventually, we can resolve this by using a hidden pref, as we would be to late for string changes for the upcoming release.
Flags: needinfo?(ian.kennedy)
(Assignee)

Comment 44

2 years ago
Created attachment 8588468 [details]
EST-3.3-libical.PNG
(Assignee)

Comment 45

2 years ago
Created attachment 8588469 [details]
EST-4.2-libical.PNG
(Assignee)

Comment 46

2 years ago
Created attachment 8588470 [details]
EST-3.3-icaljs.PNG
(Assignee)

Comment 47

2 years ago
Created attachment 8588471 [details]
EST-4.2-icaljs.PNG
(Assignee)

Comment 48

2 years ago
Created attachment 8591343 [details] [diff] [review]
EventSummaryInLocalTime-V1.diff

Although the reply from Ian is pending, time gets short for 4.0, so I prepared a patch to display datetime in localtime within summary dialog. Orginal time is is displayed additionally if applicable because we don't have a menu switch here like in event dialog.

This solves only the diplaying different time in the summary dialog, so there might be additional work to resolve the bug in a whole. Nevertheless, I set this for tracking for 4.0.
Attachment #8591343 - Flags: review?(philipp)
(Assignee)

Updated

2 years ago
Target Milestone: --- → 4.0
Comment on attachment 8591343 [details] [diff] [review]
EventSummaryInLocalTime-V1.diff

Review of attachment 8591343 [details] [diff] [review]:
-----------------------------------------------------------------

Do you have a screenshot what this looks like?

::: calendar/base/content/calendar-item-bindings.xml
@@ +75,5 @@
>            var hideLabels = (date == null);
>            if (hideLabels) {
>                this.setAttribute("hidden", "true");
>            } else {
> +              let localTime = date.getInTimezone(calendarDefaultTimezone());

cal.calendarDefaultTimezone()

There are also some other functions worth prefixing with cal.

@@ +76,5 @@
>            if (hideLabels) {
>                this.setAttribute("hidden", "true");
>            } else {
> +              let localTime = date.getInTimezone(calendarDefaultTimezone());
> +              itemDateTimeLabel.value = getDateFormatter().formatDateTime(localTime);

Given you use the date formatter twice you might want to use a local variable.
Attachment #8591343 - Flags: review?(philipp) → review+
(Assignee)

Comment 50

2 years ago
Created attachment 8591387 [details]
LocaltimeInSummary-Before-After.png

Sure. Unfortunately, the formatter provides only one option for  a datetime formatting (otherwise I would have cropped the weekday of the original datetime) to make it not too wide.
(Assignee)

Comment 51

2 years ago
Created attachment 8591389 [details] [diff] [review]
EventSummaryInLocalTime-V2.diff

Updated patch - I forgot to request a+b approvals.
Attachment #8591343 - Attachment is obsolete: true
Attachment #8591389 - Flags: approval-calendar-beta?(philipp)
Attachment #8591389 - Flags: approval-calendar-aurora?(philipp)
Attachment #8591389 - Flags: approval-calendar-beta?(philipp)
Attachment #8591389 - Flags: approval-calendar-beta+
Attachment #8591389 - Flags: approval-calendar-aurora?(philipp)
Attachment #8591389 - Flags: approval-calendar-aurora+
Attachment #8591389 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed, leave-open
(Reporter)

Comment 52

2 years ago
(In reply to MakeMyDay from comment #43)
> Created attachment 8588467 [details]
> Modified_Mail_Attachment_copy.ics
> 
> Ian, Geoff, I tried to reproduce the issue once again based on the event
> attached by Ian related to comment #36. As organizer and attendee
> information have been removed there, I created new ones to be able to use
> that event (see attached ics). I tried both, libical and icaljs backend in
> release version 3.3 and current nightly 4.2.
> 
> For icaljs, I got consistently floating time applied everywhere in Lightning
> (invitation preview, today pane, calendar view) in on both versions. So for
> icaljs, there's no inconsistency, but in general no timezone applied, which
> should be resolved preliminary by adding the aliases and finally by using
> the timezone information provided by the ics as already mentioned by Geoff.
> (Btw, I think, we should not remove the tz aliasing, once tz evaluation from
> the ics is implemented, as there are also examples of ics referncing
> timezones like EST without shipping an according vtimezone in the ics).
> 
> For libical, I got timezones consistently applied correctly all over
> Lighting for both versions, although the event summary dialog displays the
> time not tranformed in local time but in senders timezone including tz
> reference. Is that the issue you're expiriencing, Ian?

No! The time shown in the preview in TB (that is provided by lightning) is correct for local time. This is the way it should be, please do not modify it. If anything the code used to show this should be used everywhere in Lightning. The whole thing would then work.

> I'm not quite sure, because your screenshots display the event dialog and
> not the summary dialog, which is shown for incoming invitations. (I even
> don't know how you managed to display the event dialog for an incoming
> invitation...)
> 
> That said, this looks to me just like a display issue in the summary dialog
> and not a backend issue.

The panel displayed in the body of the document is correct. It is in the local timezone, not the one that the event originated from.

> Unfortunately, there is currently no way to switch between displaying
> datetime with tz information and converting to effective local time as this
> is available for the event dialog. Eventually, we can resolve this by using
> a hidden pref, as we would be to late for string changes for the upcoming
> release.
Flags: needinfo?(ian.kennedy)
(Assignee)

Comment 53

2 years ago
Ian, the event summary dialog is not the preview in mail view. It's the dialog that opens if you double click on an event (based on an invitation) in the today pane, a calendar view or the Details button in the notification bar in mail view. See the screenshots I posted.

But please note, it is not the dialog that enables you to edit all event details. You didn't mention how you managed to open that for received invitations.
(Reporter)

Comment 54

2 years ago
(In reply to MakeMyDay from comment #53)
> Ian, the event summary dialog is not the preview in mail view. It's the
> dialog that opens if you double click on an event (based on an invitation)
> in the today pane, a calendar view or the Details button in the notification
> bar in mail view. See the screenshots I posted.
> 
> But please note, it is not the dialog that enables you to edit all event
> details. You didn't mention how you managed to open that for received
> invitations.

I don't think I've ever seen an event summary dialog. The only thing that shows when I double click the event is the one that allows you to edit all event details. (as shown in my invitations). Which is why staff have been able to correct the times on the events.
(Assignee)

Comment 55

2 years ago
This is not supported by official Lightning builds - do you use further extensions to enable that option?
(Reporter)

Comment 56

2 years ago
Not that I'm aware of. The only items installed at Lightning, British English Dictionary and LookOut
(Reporter)

Comment 57

2 years ago
One thought. I could provide you with an account on our Calendar server for testing, if that would help. The server is the Mac OS X Server 4.1 calendar server on Mac OS 10.10.3 (as of this weekend).
(In reply to Ian from comment #54)
> I don't think I've ever seen an event summary dialog. The only thing that
> shows when I double click the event is the one that allows you to edit all
> event details. (as shown in my invitations). Which is why staff have been
> able to correct the times on the events.

This often happens when the configured email could not be found in either attendees list or organizer. Maybe thats the reason you are no seeing this dialog? Correcting times should provoke a COUNTER operation, which we don't support at the moment. If changing times still causes invitations to be sent, I guess this is server side scheduling taking over.
(Reporter)

Comment 59

2 years ago
Frequently the emails will be deleted from mail when the appointment is added. No email is generated in response to the change of timezones, an in this case we would't want it too. We are only correcting a timezone issue, not attempting to change the time of the meeting.

It's worth pointing out that the meeting invite is from a different organisation so there is no access to that persons email message by our calendar server. We're not particularly interested in some sort of scheduling conversations between the two system, we just want a quick way of putting the event into the calendar at our end. It it happens to send back an acknowledgement then that's fine.
Blocks: 1153752
https://hg.mozilla.org/comm-central/rev/23ac15cc2dfc
Keywords: checkin-needed
(Assignee)

Comment 61

2 years ago
Ian, can you please retest with the current beta for the upcoming release (4.0b1 with TB 38.0b1 or b2/b3 respectively, if already released at the time of testing)?
(Assignee)

Updated

2 years ago
Flags: needinfo?(ian.kennedy)
(Assignee)

Comment 62

2 years ago
One more thing: can you please provide information, how many calendars you have configured in Lightning, whether there are email addresses associated to them and whether they are writable (you get all of this from the list in the calendar view)?
This still not landed on aurora and beta, so this fix is not in 4.0 afaik.

Updated

2 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora, comm-beta]
Target Milestone: 4.0 → 4.2
(Reporter)

Comment 64

2 years ago
Just tested with latest TB 38 beta and lightning 4.0b1 and it does seem to work OK.
Flags: needinfo?(ian.kennedy)
(Reporter)

Comment 65

2 years ago
(In reply to MakeMyDay from comment #62)
> One more thing: can you please provide information, how many calendars you
> have configured in Lightning, whether there are email addresses associated
> to them and whether they are writable (you get all of this from the list in
> the calendar view)?

In my test configuration there are 3 calendars, Home, which is local to the machine and two test calendars on our server. Each of them has the same email address associated with it (mine). I have also a second email account setup on the TB side. Both accounts are IMAP connections to a Mac OS X server (Dovecot).
(Assignee)

Comment 66

2 years ago
Thanks for testing, Ian. Based comment 64, we can mark this resolved fixed, although bug 1149423 still needs a checkin for icaljs parity with libical. Also, this bug still needs aurora/beta checkin.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: leave-open
Resolution: --- → FIXED
Backported to releases/comm-aurora changeset 7640c298db78
Keywords: checkin-needed
Target Milestone: 4.2 → 4.1
Backported to releases/comm-beta changeset 886ea0718ad9
Target Milestone: 4.1 → 4.0
Whiteboard: [checkin-needed comm-aurora, comm-beta]

Comment 69

a year ago
I have this issue too with recent versions:
TB 38.4.0
Ln 4.0.5.2

but there is no error in the error console. I had it, but then I cleaned to reproduce and now, despite the error is still there, there is no error log.

Any suggestion?

Comment 70

8 months ago
Hi

I am having the exact same issue to date!
I just installed lightning, and after going into preferences to change the timezone - from Europe/London (default) to my own time zone, i click close, but after restarting Thunderbird, i check in the settings its reverted BACK to the default preference: Europe/London.  Why does it keep doing that??
Also, the time on my events is 2 hours out. 

I have even uninstalled and re-installed the addon

Thunderbird v. 45.4.0
Ubuntu 16.04

Please help fix this issue!! its the most basic feature anyone would need working on Thunderbird.
Flags: needinfo?(ian.kennedy)
Flags: needinfo?(ian.kennedy)
If you observe a similar bug, please file a new bug report with reference to this one, as the original fix has been made over 2 years ago.
You need to log in before you can comment on or make changes to this bug.