[e10s] "Move Tabs" addon does not work

RESOLVED WONTFIX

Status

()

Firefox
Extension Compatibility
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Aurélien MANCA, Unassigned)

Tracking

({addon-compat})

36 Branch
x86_64
Linux
addon-compat
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141021030208

Steps to reproduce:

1) Enable e10s experimental feature
2) Install latest Move Tabs extension (https://addons.mozilla.org/fr/firefox/addon/movetabs/)
3) Open a new tab
4) Try the shortcut "cmd + left arrow" or the page context menu "Move Tabs to / first"



Actual results:

Move Tabs shortcut doesn't work, and the context menu doesn't display any sub-menu.

It's a really simple addon made with the addon sdk, you can find the source on github with the 2 main scripts:
https://github.com/noreiller/move-tabs/blob/master/lib/main.js
https://github.com/noreiller/move-tabs/blob/master/lib/module-move-tabs.js
Component: Untriaged → Extension Compatibility

Updated

3 years ago
Blocks: 905436
Keywords: addon-compat
tracking-e10s: --- → +
Summary: [e10s] move tabs addon does not work → [e10s] "Move Tabs" addon does not work
Jérôme, are you the developer of the "Move Tabs" add-on? This add-on seems to be broken with multiprocess Firefox (e10s). If you have any questions about e10s support, just drop by the #e10s IRC channel on irc.mozilla.org. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox

Comment 2

3 years ago
Hi Chris,

yes, I am the developer of Move Tabs. Actually, this addon is kind of deprecated to me, as Firefox natively support to move tabulars with Ctrl-Shift-Page Up/Down.

Indeed, I did not use this functionality for a while...

But I don't think it is directly related to the multiprocess stuff. As stated in the MDN article:
> if you don't access web content at all, then you won't be affected

the Move tabs plugin should not be affected by this new communication scheme.

Anyway, I will try to test and fix that, or if I can't, I will state this plugin incompatible with the e10s version of Firefox.


Regards,
Jérôme
(Reporter)

Comment 3

3 years ago
Hi, I'm the reporter of the bug and also the one who created the addon Move Tabs (the no-restart one).
I reported the bug without knowing some apis of the SDK were unstable and moreover I didn't know the keyboard shortcuts have been implemented in Firefox.
It seems my addon is also deprecated.

@Jérôme Thank you for noticing me the new shortcuts. Do you know the release date of this feature ?

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.