Closed Bug 1086686 Opened 6 years ago Closed 6 years ago

[2.1][l10n][Settings] Basque: The USB button header text "USB storage" is truncated

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: rmead, Assigned: eragonj)

References

Details

(Keywords: regression, Whiteboard: LocRun2.1-2)

Attachments

(7 files, 2 obsolete files)

Attached image 2014-10-21-12-44-56.png
Description:
The title string of the USB storage button is truncated in Basque. The string should read "USB biltegiratze" but instead reads "USB biltegiratz..."
   
Prereq:
Have language set to Basque(eu) aka Euskara

Repro Steps:
1) Update a Flame device to BuildID: 20141021001201
2) Tap on 'Settings' app
3) Scroll down to the USB storage button and observe
  
Actual:
The header string "USB biltegiratze" is truncated to look like "USB biltegiratz..."
  
Expected: 
The header string "USB biltegiratze" is not truncated.
  

Flame 2.1(319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/14763/
See attached: screenshot
This issue does NOT occur on Flame 2.0(319mb)

The UBS Storage header, while in Basque(eu) language, is not truncated.


Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141021000201
Gaia: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko: 40584eecdc75
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
So this is a regression it seems. Asking for UX to see if the last "e" can appear instead of the "..."
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: regression
Duplicate of this bug: 1087090
[Blocking Requested - why for this release]:
Just realized this is a regression happening on multiple critical shipping locales
Well, to be exact it should read "USB biltegiratzea" (as it is translated).
Do we have to change the string, and put "USB biltegiratz." or something similar?
Assignee: nobody → ibai
Summary: [2.1][l10n][Settings] Basque: The USB storage button header text is truncated → [2.1][l10n][Settings] Basque: The USB button header text "USB storage" is truncated
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Component: eu / Basque → Gaia::Settings
Product: Mozilla Localizations → Firefox OS
Removing flag since this is noted as a regression.
Flags: needinfo?(firefoxos-ux-bugzilla)
Catalan is also affected by regression.
The vertical separator line is what causes less space for the string. It was not there in previous versions. It is actually not there in the menu items at the top of Settings (e.g. Plane mode).
Do you think it's necessary to put a vertical line before the toggle button?
I do not see it adding much value for the user. What I see is reduced space for a string that previously fit.
If this is a test for a new look for the toggle buttons, please note that shortening the already-limited space that we have for strings will cause several truncation bugs.
It would be much appreciated by localizers if design decisions would not be done at the expense of reducing the space for strings.

Please let us know whether this is going to be reverted of we need to change our string.
[Blocking Requested - why for this release]:
Not sure why my blocking request was dropped if this is a regression. Re-nominating since this regression affects multiple critical shipping locales
blocking-b2g: --- → 2.1?
In 2.1, we support MTP/UMS selections for USB storage in Settings app, based on UX spec, the reason why we are going to split the menu is because from UX's perspective, the left part and the right part are two different parts with different functionalities.

UX spec: https://bug921105.bugzilla.mozilla.org/attachment.cgi?id=8451433 
Please check page 6 & page 7
Attached image apn_demo.png
Another example for APN settings.
Based on my comments above, this is a new UX design and has been implementing in different places (and would be more I think).

For me, there are two ways to fix current problem. One is to change the translation while another one is change with another UX design and no matter which we chooses, they all need more discussions first.

Hope this information helps :)
blocking-b2g: 2.1? → 2.1+
Hi Axel, can you provide feedback on how many languages / words are effected by this case?
Flags: needinfo?(l10n)
(In reply to howie [:howie] from comment #12)
> Hi Axel, can you provide feedback on how many languages / words are effected
> by this case?

Forwarding this to Delphine
Flags: needinfo?(l10n) → needinfo?(lebedel.delphine)
By looking at this, I'd say at least ca, id, pl, pt-BR, and some others probably on the edge.
http://transvision.mozfr.org/string/?entity=apps/settings/settings.properties:enableUSBStorage1&repo=gaia_2_1
Reflaging UX as this is again classified as regression. Please see comment 2.
Flags: needinfo?(firefoxos-ux-bugzilla)
This is for Jenny, as she designed the spec.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(jelee)
ni Helen for comment 2, thanks Helen ;)
Flags: needinfo?(jelee) → needinfo?(hhuang)
Attached image L10n-layout.png
I think there is enough space to show the header string completely, it should not be truncated in this case, we just need to make sure it leaves 2.2 rem space before the separator. Please refer to the attachment.
Flags: needinfo?(hhuang)
Clearing out need info as Flod already answered here.
Flags: needinfo?(lebedel.delphine)
Hi Ibai, as Comment 18, can you help on this?
Flags: needinfo?(ibai)
Hello,
I'm sorry but I haven't understood what I have to do... Have I got to change the Basque translation?
Now it is translated as "USB biltegiratzea" in locamotion (for both 2.1 and 2.2). I see on the attachment from Comment 18 that there seems to be enough space.
Hi Ibai, per comment 14, there are strings longer than "USB biltegiratzea" in other languages, so we have to make it multiple lines instead of using shorter strings.

EJ, could you help on this based on what we discussed? It's okay to have a solution specific to this menu item to avoid potential side effects. Let's use a follow up bug for solving this with a complete solution, thanks.
Assignee: ibai → ejchen
Thanks for the info, Arthur. I assigned the bug to myself because I thought it was something concerning only to Basque localization, but I see it goes beyond.
Flags: needinfo?(ibai)
Comment on attachment 8522659 [details] [review]
WIP

Arthur, please help check this CSS patch !

Thanks :)
Attachment #8522659 - Flags: review?(arthur.chen)
Comment on attachment 8522659 [details] [review]
WIP

r=me with the comment addressed. Please also request an ui revivew, thanks!
Attachment #8522659 - Flags: review?(arthur.chen) → review+
Comment on attachment 8522659 [details] [review]
WIP

Hi Helen, I already fixed this bug and uploaded two demos for you (demo1.png & demo2.png). Please help me review it ! Thanks

For design spce, padding-top & padding-bottom is 0.5rem and its inner height would be expanded by its content (In order not to influence too much menuItems, we only let usb-item can be expandable while the others are intact)

Hope this information helps ! THanks
Attachment #8522659 - Flags: ui-review?(hhuang)
Attached file patch on v2.1
Arthur, because there are some conflicts, so I decided to make another 2.1 patch for it and it is basically the same with master patch. Can you help me review it ? Thanks !
Attachment #8525060 - Flags: review?(arthur.chen)
Attached image demo1.png
Attachment #8525043 - Attachment is obsolete: true
Attached image demo2.png
Attachment #8525044 - Attachment is obsolete: true
Comment on attachment 8522659 [details] [review]
WIP

The screenshots looks good! It works for me.
Thanks for your efforts:)
Attachment #8522659 - Flags: ui-review?(hhuang) → ui-review+
Comment on attachment 8525060 [details] [review]
patch on v2.1

LGTM, r=me.
Attachment #8525060 - Flags: review?(arthur.chen) → review+
Comment on attachment 8525060 [details] [review]
patch on v2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Users will not see full translation of usb menu item
[Testing completed]: no, only CSS changes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8525060 - Flags: approval-gaia-v2.1?
Keywords: verifyme
Attachment #8525060 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Merged into Gaia/v2.1: https://github.com/mozilla-b2g/gaia/commit/6c739275e963465658c18c7a9ebaa48cbe927d34

Thanks all :)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified the issue is fixed on 2.2 and 2.1 Flame

The "Storage USB" setting is not truncated an displayed fully

"Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121001202
Gaia: 6c739275e963465658c18c7a9ebaa48cbe927d34
Gecko: 9bfc7a166a94
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.