Closed Bug 1086715 Opened 8 years ago Closed 8 years ago

System Update Ready dialog does not fill the full screen

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S7 (24Oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: marcia, Assigned: mikehenrty)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Flame, while running:

Gaia   dc496d04907dd314f9736ff78bab3bd27156f79a
SourceStamp ca6b46cbca3b
BuildID 20141020040204
Version 36.0a1
base v184

STR:
1. Check for a System Update
2. Received the attached dialog

Expected: Settings would not be showing underneath the dialog
Actual: The System Update Ready screen does not show full screen as it should.
This is my fault, I gave the review for bug 1084458 and forgot about the non-SHB case. Taking. This is definitely a blocker.
Assignee: nobody → mhenretty
Blocks: 1084458
blocking-b2g: --- → 2.1+
Oh wow, looks pretty simple looking at the patch in bug 1084458  :) Thanks for taking.
Attachment #8509057 - Flags: review?(kgrandon) → review+
Component: Gaia::Settings → Gaia::System
Duplicate of this bug: 1087531
Kevin, can we please land this given its reviewed and is busting the smoketests(https://bugzilla.mozilla.org/show_bug.cgi?id=1087531)?
Flags: needinfo?(kgrandon)
(In reply to bhavana bajaj [:bajaj] from comment #5)
> Kevin, can we please land this given its reviewed and is busting the
> smoketests(https://bugzilla.mozilla.org/show_bug.cgi?id=1087531)?

Yes, the tree has been closed for the last day, so we haven't had *any* landings. This can land now as we're reopening the tree.
Flags: needinfo?(kgrandon)
Flags: needinfo?(kgrandon)
Mike - can you rebase and make sure this test is passing on gaia-try? Thanks!
Flags: needinfo?(kgrandon) → needinfo?(mhenretty)
master: https://github.com/mozilla-b2g/gaia/commit/e4828bb2d18645b6392c7cad56d201cb133a9d35
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(mhenretty)
Resolution: --- → FIXED
Comment on attachment 8509057 [details] [review]
[Gaia PR] update dialog fix without SHB

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
bug 1084458

[User impact] if declined:
Poor Visual UX for non-SHB devices

[Testing completed]:
Manual testing on device, integration test added for non-SHB case.

[Risk to taking this patch] (and alternatives if risky):
Low risk, css only change with integration test.

[String changes made]: none
Attachment #8509057 - Flags: approval-gaia-v2.1?
Duplicate of this bug: 1088348
Attachment #8509057 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
This issue is verified fixed on Flame 2.2 and 2.1.

Result: The dialog fits the full screen.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141026160206
Gaia: e91d99e4d96954f06383c00bb9d79598a697e310
Gecko: 8230834302c9
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141027001201
Gaia: c97463d61f45513a2123b19610386ddbfc916819
Gecko: 4f8c0c021128
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1089540
Duplicate of this bug: 1088426
You need to log in before you can comment on or make changes to this bug.