BUG with SELECTION selectedIndex property

VERIFIED DUPLICATE of bug 101720

Status

()

Core
JavaScript Engine
--
major
VERIFIED DUPLICATE of bug 101720
17 years ago
17 years ago

People

(Reporter: Saulius Gurklys, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

It does not matter if one of other than first <selection> <option> is
market as <option selected>. document.form.seletction.selectedIndex every time
returns 0.
Look source of page http://www.vtex.lt/sagu/testCase.html


Reproducible: Always
Steps to Reproduce:
1.run browser
2.enter URL http://www.vtex.lt/sagu/testCase.html
3.

Actual Results:  on the last line the last  digit is 0 (it is generated by
JavaScript document.form.selection.selectedIndex)

Expected Results:  it should be 1
This is fixed by the checkin for bug 34297.  Worksforme.

*** This bug has been marked as a duplicate of 101720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified WorksForMe with Mozilla trunk binary 20011105xx on WinNT.
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
(Also verified as duplicate of bug 101720,
"selectedIndex has wrong value right after intialization"
You need to log in before you can comment on or make changes to this bug.