Cannot set conditional breakpoints

RESOLVED INVALID

Status

DevTools
Debugger
RESOLVED INVALID
4 years ago
a month ago

People

(Reporter: erahm, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Setting a conditional breakpoint in WebIDE on a recent m-c build no longer works.

STR:
#1 Install/Launch app on device
#2 Start debugging
#3 Select a line you want to set a conditional breakpoint on
#4 Right-click, select "Add conditional breakpoint"
#5 Nothing happens
Anything seem relevant in the browser console? (Cmd+Shift+J)
Flags: needinfo?(erahm)
(In reply to Nick Fitzgerald [:fitzgen] from comment #1)
> Anything seem relevant in the browser console? (Cmd+Shift+J)

Nothing shows up in the browser console when I try to add the breakpoint.
Flags: needinfo?(erahm)
ni? jlongster, who was the last person to touch the conditional breakpoints stuff, AFAIK.
Flags: needinfo?(jlong)
Eric, exactly which versions of Firefox and Firefox OS? I just tried it with nightly and Firefox OS 2.0, and it worked.

I touched conditional breakpoints months ago, so if this is new I'm not sure how it's related. I would expect the problem would be that it's never hitting the breakpoint, since we have delicate code that implements that functionality client-side on older versions but on the server in newer versions. If you're saying that you select "Add Conditional Breakpoint" from the context menu and a breakpoint never even appears in the editor, that's surprising.
Flags: needinfo?(jlong)
(In reply to James Long (:jlongster) from comment #4)
> Eric, exactly which versions of Firefox and Firefox OS? I just tried it with
> nightly and Firefox OS 2.0, and it worked.
> 
> I touched conditional breakpoints months ago, so if this is new I'm not sure
> how it's related. I would expect the problem would be that it's never
> hitting the breakpoint, since we have delicate code that implements that
> functionality client-side on older versions but on the server in newer
> versions. If you're saying that you select "Add Conditional Breakpoint" from
> the context menu and a breakpoint never even appears in the editor, that's
> surprising.

Sorry just saw this. I'll try to repro on my Flame. I'm pretty sure it was nightly on desktop, m-c on device.
Flags: needinfo?(erahm)
I can't reproduce this anymore. Previously the issue was: "try to add conditional breakpoint, nothing shows up." I've tested w/ nightly and aurora against b2g m-c (2.2). I'll close this for now and reopen if I see it again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(erahm)
Resolution: --- → INVALID

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.